summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2022-05-04 16:15:22 +0300
committerSergey Popov <pinkbyte@gentoo.org>2022-05-04 16:15:37 +0300
commitbd913148f9734ab32fbc09977ab91fec72f24735 (patch)
tree70ef3846ca6a48f346dc8caac7da81f4ebba2bf3 /games-strategy/seven-kingdoms/seven-kingdoms-2.15.5.ebuild
parentapp-misc/detachtty: Fix compilation on sparc (diff)
downloadgentoo-bd913148f9734ab32fbc09977ab91fec72f24735.tar.gz
gentoo-bd913148f9734ab32fbc09977ab91fec72f24735.tar.bz2
gentoo-bd913148f9734ab32fbc09977ab91fec72f24735.zip
games-strategy/seven-kingdoms: version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'games-strategy/seven-kingdoms/seven-kingdoms-2.15.5.ebuild')
-rw-r--r--games-strategy/seven-kingdoms/seven-kingdoms-2.15.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-strategy/seven-kingdoms/seven-kingdoms-2.15.5.ebuild b/games-strategy/seven-kingdoms/seven-kingdoms-2.15.5.ebuild
new file mode 100644
index 000000000000..003704713e9f
--- /dev/null
+++ b/games-strategy/seven-kingdoms/seven-kingdoms-2.15.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs
+
+MY_PN="7kaa"
+MY_PV="$(ver_rs 3- '')"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Seven Kingdoms: Ancient Adversaries"
+HOMEPAGE="https://7kfans.com/"
+SRC_URI="https://github.com/the3dfxdude/${MY_PN}/releases/download/v${MY_PV}/${MY_P}.tar.xz
+ https://dev.gentoo.org/~pinkbyte/distfiles/${MY_PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="net-libs/enet:1.3=
+ media-libs/libsdl2[X,video]
+ media-libs/openal
+ net-misc/curl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${MY_P}.tar.xz
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ doicon "${DISTDIR}/${MY_PN}.png"
+ make_desktop_entry "${MY_PN}" "Seven Kingdoms: Ancient Adversaries" "${MY_PN}" "Game;StrategyGame"
+}