summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-12-24 11:22:31 +0100
committerPacho Ramos <pacho@gentoo.org>2024-12-24 11:23:41 +0100
commit0f02742d9a11dcb291b436366efa35dbd05f719c (patch)
tree87956127699f66a6b573760c6c7955eec1068e02 /games-strategy/wesnoth
parentmedia-plugins/gst-plugins-meta: add 1.22.12 (diff)
downloadgentoo-0f02742d9a11dcb291b436366efa35dbd05f719c.tar.gz
gentoo-0f02742d9a11dcb291b436366efa35dbd05f719c.tar.bz2
gentoo-0f02742d9a11dcb291b436366efa35dbd05f719c.zip
games-strategy/wesnoth: add 1.19.7
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/Manifest1
-rw-r--r--games-strategy/wesnoth/wesnoth-1.19.7.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index f396b6286ee7..d73fa1a2d796 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -2,3 +2,4 @@ DIST wesnoth-1.18.2.tar.bz2 461290798 BLAKE2B 6ff9538eca7f65e7413d9b220b07b5f76a
DIST wesnoth-1.18.3.tar.bz2 461694247 BLAKE2B 1998e2fdff56271dd86c390e3c25dcbaa98b4f131f15584e5d3f2f5866856a69aebf9c8d97b1126601b3e08467a9410f3ba7b53c253737c6bbf62ccb1e9ba96f SHA512 def324c9ed66ac59e2a9d0ab9ab95f00ddab2d31dacb2d0b5cfba42c5acdba210937f7dd6afde8870a387847a6d021a28dffcb04ce513272df6a4b52a626f30a
DIST wesnoth-1.19.1.tar.bz2 461918324 BLAKE2B 8fa97526831e14957449a0b33909b7d155be00659d9543efbea34bd7935fb05b4e99a419dcc2e9c426a2e0fb4fb1d40c2972236d0da5a1661970eb80103f04fc SHA512 73ab7d474b01ac753224f0c694a86679a28160e340a07d87b8f96398df2c39c39df95098b750516e7e69851843e68954b5939ae68dc3a232ec2e9cad256d1113
DIST wesnoth-1.19.5.tar.bz2 509947975 BLAKE2B 26ae05b709a2643af493b98531a8456a57ad725baac31e11b2ab2207b3fbbfe655389d80bae01aece08b14df2046bcb80092eca7691fce5b838b9c3ef9727930 SHA512 e0332cb20469ba74aa60d109a0abf536767c04ce5007fa2ec7512c3e5d88b4fa32aacafb0fb729647dc0eb922fa8846fcbc24ffb681cd59bad8a07e4db0968da
+DIST wesnoth-1.19.7.tar.bz2 501064088 BLAKE2B 202f2ed3fcb9810cc3d98bd003ab60ad3e78f199eae2d0fa135455dadc3305f46f154549337386b508472779ed707b27226d15a868705147bd2fc04ffcf91a0c SHA512 d39ecaa1dbea6c547e3767b555c6d1fa9c47dc8a06af0fb8d9171f01822520657c44e12f7bbfe7bd2a696f8b8cecb115e7fb6fff4e5ebc35278cca794b26c3e5
diff --git a/games-strategy/wesnoth/wesnoth-1.19.7.ebuild b/games-strategy/wesnoth/wesnoth-1.19.7.ebuild
new file mode 100644
index 000000000000..19a65877e088
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.19.7.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org
+ https://github.com/wesnoth/wesnoth"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+# uneven minor versions are development versions
+if [[ $(( $(ver_cut 2) % 2 )) == 0 ]] ; then
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+IUSE="dbus dedicated doc nls server"
+
+RDEPEND="
+ acct-group/wesnoth
+ acct-user/wesnoth
+ dev-libs/boost:=[bzip2,context,icu,nls]
+ >=media-libs/libsdl2-2.0.18:0[joystick,video,X]
+ !dedicated? (
+ dev-libs/glib:2
+ dev-libs/openssl:0=
+ >=media-libs/fontconfig-2.4.1
+ >=media-libs/sdl2-image-2.0.0[jpeg,png,webp]
+ >=media-libs/sdl2-mixer-2.0.0[vorbis]
+ media-libs/libvorbis
+ >=x11-libs/pango-1.22.0
+ >=x11-libs/cairo-1.10.0
+ sys-libs/readline:0=
+ dbus? ( sys-apps/dbus )
+ )"
+DEPEND="${RDEPEND}
+ x11-libs/libX11
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ if ! use doc ; then
+ sed -i \
+ -e '/manual/d' \
+ doc/CMakeLists.txt || die
+ fi
+
+ # respect LINGUAS (bug #483316)
+ if [[ ${LINGUAS+set} ]] ; then
+ local lang langs=()
+ for lang in $(cat po/LINGUAS) ; do
+ has ${lang} ${LINGUAS} && langs+=( ${lang} )
+ done
+ echo "${langs[@]}" > po/LINGUAS || die
+ fi
+}
+
+src_configure() {
+ filter-flags -ftracer -fomit-frame-pointer
+
+ local mycmakeargs=()
+
+ if use dedicated || use server ; then
+ mycmakeargs+=(
+ -DENABLE_CAMPAIGN_SERVER="ON"
+ -DENABLE_SERVER="ON"
+ -DSERVER_UID="${PN}"
+ -DSERVER_GID="${PN}"
+ -DFIFO_DIR="/run/wesnothd"
+ )
+ else
+ mycmakeargs+=(
+ -DENABLE_CAMPAIGN_SERVER="OFF"
+ -DENABLE_SERVER="OFF"
+ )
+ fi
+ mycmakeargs+=(
+ -Wno-dev
+ -DENABLE_GAME="$(usex !dedicated)"
+ -DENABLE_DESKTOP_ENTRY="$(usex !dedicated)"
+ -DENABLE_NLS="$(usex nls)"
+ -DENABLE_NOTIFICATIONS="$(usex dbus)"
+ -DENABLE_STRICT_COMPILATION="OFF"
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ # Allow SDL_Mixer test to pass, bug #931551
+ SDL_AUDIODRIVER=dummy cmake_src_test
+}
+
+src_install() {
+ local DOCS=( README.md changelog.md )
+ cmake_src_install
+ if use dedicated || use server ; then
+ rmdir "${ED}"/run{/wesnothd,} || die
+ newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
+ fi
+}