summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2017-11-10 23:26:09 +0200
committerJames Le Cuirot <chewi@gentoo.org>2017-11-10 22:17:56 +0000
commit4c92b224473531dcb8e13120e64f43a8329d78e3 (patch)
tree0d84c3e7bd3dff787173758de88b95b7e37102c9 /games-util
parentgnome-extra/nm-applet: bump to 1.8.6 (diff)
downloadgentoo-4c92b224473531dcb8e13120e64f43a8329d78e3.tar.gz
gentoo-4c92b224473531dcb8e13120e64f43a8329d78e3.tar.bz2
gentoo-4c92b224473531dcb8e13120e64f43a8329d78e3.zip
games-util/lutris: version bump to 0.4.13
Closes: https://github.com/gentoo/gentoo/pull/6150
Diffstat (limited to 'games-util')
-rw-r--r--games-util/lutris/Manifest1
-rw-r--r--games-util/lutris/lutris-0.4.13.ebuild68
-rw-r--r--games-util/lutris/metadata.xml8
3 files changed, 77 insertions, 0 deletions
diff --git a/games-util/lutris/Manifest b/games-util/lutris/Manifest
index 7c08cf18476b..eb27efbc5b86 100644
--- a/games-util/lutris/Manifest
+++ b/games-util/lutris/Manifest
@@ -1,2 +1,3 @@
+DIST lutris-0.4.13.tar.gz 1028111 SHA256 720ee375104af791f42298ea8d3beb5353ecbb8e933706768d95065724f17114 SHA512 006e4cc237a60bd925cee87046664f766686a15c692f7717e6fd25bee377880bd96f788309966e8e0dabdf2c938e0da0f8914c7e70554f216b8513aa41bc808a WHIRLPOOL 64f96116b6b448097c6de9bc955902669aa787a865604763a90dac0cc7a8712a0a484bf2dbe75144cb21f031c35f3f7a005845b8e2a38ed6a3fcd5c17ec67de0
DIST lutris_0.3.6.3.tar.gz 515606 SHA256 a9061403ef8844b2c1443b1c5f15fe98af224d652d66268b47ae8e215e289058 SHA512 548a3a79ffb1c378d923f404634acc3b5eb1055d087ff212cf8a35b7db56650bf616f3b7374ab9fdf996c8f10d80ab602d35d126ef3bb183b9ce55b36d270e97 WHIRLPOOL 9c6e08908a2462f639a89f05b8eea9c212dba103a9c0492d3bd8bba2d2002d718354b4410e6506c7e88c0b4a2bf930d6d05930d0b27d66de0b66b9526f2c2fac
DIST lutris_0.3.8.tar.xz 658408 SHA256 404b8379dbf9dcab6e25bca781b8afe0b3f9cd9b27ff58cba8b8c98f54fb74f4 SHA512 165e9c045e82407dfd6dd35fa73a98b68d095119596b9f0e66867c92071d1178526ddf991fc6b05449446c9d7c1a573ffea564d93d440cebdaa788c61e57fcfe WHIRLPOOL 618c85b3cf0c583d21787161ff44cac4fb2d75072a7d32c3d642026f39fbcb7333f79a4cd2901f552fc70a1f1dd8b6933017d070293813f1facde788701ed67e
diff --git a/games-util/lutris/lutris-0.4.13.ebuild b/games-util/lutris/lutris-0.4.13.ebuild
new file mode 100644
index 000000000000..960cafec846a
--- /dev/null
+++ b/games-util/lutris/lutris-0.4.13.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="sqlite,threads"
+
+inherit distutils-r1 gnome2-utils python-r1
+
+DESCRIPTION="Lutris is an open source gaming platform for GNU/Linux."
+HOMEPAGE="https://lutris.net/"
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/lutris/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/lutris/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ net-libs/libsoup
+ x11-apps/xrandr
+ x11-apps/xgamma"
+
+python_install() {
+ distutils-r1_python_install
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ # README.rst contains list of optional deps
+ DOCS=( AUTHORS README.rst INSTALL.rst )
+ distutils-r1_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+
+ elog "For a list of optional dependencies (runners) see:"
+ elog "/usr/share/doc/${PF}/README.rst.bz2"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
diff --git a/games-util/lutris/metadata.xml b/games-util/lutris/metadata.xml
index 5d9c019090ea..036f019d61d2 100644
--- a/games-util/lutris/metadata.xml
+++ b/games-util/lutris/metadata.xml
@@ -5,6 +5,14 @@
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
+ <maintainer type="person">
+ <email>fdsfgs@krutt.org</email>
+ <name>soredake</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<longdescription lang="en">
Lutris is a gaming platform for GNU/Linux. Its goal is to make
gaming on Linux as easy as possible by taking care of installing