summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-15 19:33:07 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-15 19:33:37 +0200
commit02aa485159f7f98b6a316ea9ecb75d369fdf6a43 (patch)
tree5e2baf257b861aa3710e78f9454c1a4aa3690009 /gnome-base/gnome-settings-daemon/files
parentgnome-base/gnome-control-center: version bump 3.24.2 → 3.24.3 (diff)
downloadgentoo-02aa485159f7f98b6a316ea9ecb75d369fdf6a43.tar.gz
gentoo-02aa485159f7f98b6a316ea9ecb75d369fdf6a43.tar.bz2
gentoo-02aa485159f7f98b6a316ea9ecb75d369fdf6a43.zip
gnome-base/gnome-settings-daemon: version bump 3.24.2 → 3.24.3
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'gnome-base/gnome-settings-daemon/files')
-rw-r--r--gnome-base/gnome-settings-daemon/files/3.24.3-optional.patch142
1 files changed, 142 insertions, 0 deletions
diff --git a/gnome-base/gnome-settings-daemon/files/3.24.3-optional.patch b/gnome-base/gnome-settings-daemon/files/3.24.3-optional.patch
new file mode 100644
index 000000000000..5202f77d5dc4
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/3.24.3-optional.patch
@@ -0,0 +1,142 @@
+From 7b7bbbeeb9fa422d5a291574910e0881fa13f171 Mon Sep 17 00:00:00 2001
+From: Ole Reifschneider <mail@ole-reifschneider.de>
+Date: Tue, 15 Aug 2017 18:51:42 +0200
+Subject: [PATCH] Make colord and wacom support optional
+
+Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
+---
+ configure.ac | 54 +++++++++++++++++++++++++++++++----------------
+ plugins/Makefile.am | 9 ++++++--
+ plugins/dummy/Makefile.am | 5 ++++-
+ 3 files changed, 47 insertions(+), 21 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 73fe91e6..d8778c93 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -158,13 +158,23 @@ PKG_CHECK_MODULES(CLIPBOARD,
+ gtk+-x11-3.0
+ x11)
+
+-PKG_CHECK_MODULES(COLOR,
+- colord >= 1.0.2
+- gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION
+- libcanberra-gtk3
+- libgeoclue-2.0 >= $GEOCLUE_REQUIRED_VERSION
+- lcms2 >= $LCMS_REQUIRED_VERSION
+- libnotify)
++AC_ARG_ENABLE([color],
++ AS_HELP_STRING([--disable-color],
++ [turn off color plugin]),
++ [],
++ [enable_color=yes])
++
++AS_IF([test "$enable_color" = "yes"],
++ [PKG_CHECK_MODULES(COLOR,
++ colord >= 1.0.2
++ gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION
++ libcanberra-gtk3
++ libgeoclue-2.0 >= $GEOCLUE_REQUIRED_VERSION
++ lcms2 >= $LCMS_REQUIRED_VERSION
++ libnotify)
++ AC_DEFINE(HAVE_COLOR, 1, [Define if color plugin is enabled])
++ ])
++AM_CONDITIONAL(BUILD_COLOR, test "x$enable_color" = "xyes")
+
+ PKG_CHECK_MODULES(DATETIME,
+ libnotify >= $LIBNOTIFY_REQUIRED_VERSION
+@@ -268,23 +278,31 @@ case $host_os in
+ if test "$host_cpu" = s390 -o "$host_cpu" = s390x; then
+ have_wacom=no
+ else
+- if test x$enable_gudev != xno; then
+- LIBWACOM_PKG="libwacom >= $LIBWACOM_REQUIRED_VERSION"
+- PKG_CHECK_MODULES(LIBWACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION])
+- PKG_CHECK_MODULES(WACOM, [gtk+-3.0 pango >= $PANGO_REQUIRED_VERSION])
+- PKG_CHECK_MODULES(WACOM_OLED, [gudev-1.0])
+- else
+- AC_MSG_ERROR([GUdev is necessary to compile Wacom support])
+- fi
+- AC_DEFINE_UNQUOTED(HAVE_WACOM, 1, [Define to 1 if wacom support is available])
+- have_wacom=yes
++ have_wacom=no
++ AS_IF([test "$enable_gudev" != "no"],
++ [AC_ARG_ENABLE([wacom],
++ AS_HELP_STRING([--disable-wacom],
++ [turn off wacom plugin]),
++ [],
++ [enable_wacom=no]) dnl Default value
++ AS_IF([test "$enable_wacom" = "yes"],
++ [
++ PKG_CHECK_MODULES(LIBWACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION])
++ PKG_CHECK_MODULES(WACOM, [gtk+-3.0 pango >= $PANGO_REQUIRED_VERSION])
++ PKG_CHECK_MODULES(WACOM_OLED, [gudev-1.0])
++ have_wacom=yes
++ AC_DEFINE_UNQUOTED(HAVE_WACOM, 1, [Define to 1 if wacom support is available])
++ ])
++ ], [
++ AC_MSG_ERROR([GUdev is necessary to compile Wacom support])
++ ])
+ fi
+ ;;
+ *)
+ have_wacom=no
+ ;;
+ esac
+-AM_CONDITIONAL(HAVE_WACOM, test x$have_wacom = xyes)
++AM_CONDITIONAL(BUILD_WACOM, test x$have_wacom = xyes)
+
+ dnl ---------------------------------------------------------------------------
+ dnl - common
+diff --git a/plugins/Makefile.am b/plugins/Makefile.am
+index 9324b406..ee78d6d0 100644
+--- a/plugins/Makefile.am
++++ b/plugins/Makefile.am
+@@ -4,7 +4,6 @@ enabled_plugins = \
+ a11y-keyboard \
+ a11y-settings \
+ clipboard \
+- color \
+ datetime \
+ dummy \
+ power \
+@@ -22,13 +21,19 @@ enabled_plugins = \
+
+ disabled_plugins = $(NULL)
+
++if BUILD_COLOR
++enabled_plugins += color
++else
++disabled_plugins += color
++endif
++
+ if SMARTCARD_SUPPORT
+ enabled_plugins += smartcard
+ else
+ disabled_plugins += smartcard
+ endif
+
+-if HAVE_WACOM
++if BUILD_WACOM
+ enabled_plugins += wacom
+ else
+ disabled_plugins += wacom
+diff --git a/plugins/dummy/Makefile.am b/plugins/dummy/Makefile.am
+index cb5856cf..d8e8bc4e 100644
+--- a/plugins/dummy/Makefile.am
++++ b/plugins/dummy/Makefile.am
+@@ -25,7 +25,10 @@ desktop_DATA =
+ if !SMARTCARD_SUPPORT
+ desktop_DATA += org.gnome.SettingsDaemon.Smartcard.desktop
+ endif
+-if !HAVE_WACOM
++if !BUILD_COLOR
++desktop_DATA += org.gnome.SettingsDaemon.Color.desktop
++endif
++if !BUILD_WACOM
+ desktop_DATA += org.gnome.SettingsDaemon.Wacom.desktop
+ endif
+ if !BUILD_PRINT_NOTIFICATIONS
+--
+2.14.0
+