summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-07-14 10:53:59 +0300
committerMart Raudsepp <leio@gentoo.org>2017-07-14 11:50:59 +0300
commitd991bddbdf67e8577a88a5a14dd10ca58db4871c (patch)
treebb8a8b39a4d192c228c00e75d4954356f8ae278f /gnome-base
parentgnome-base/gnome-shell: bump to 3.24.2 (diff)
downloadgentoo-d991bddbdf67e8577a88a5a14dd10ca58db4871c.tar.gz
gentoo-d991bddbdf67e8577a88a5a14dd10ca58db4871c.tar.bz2
gentoo-d991bddbdf67e8577a88a5a14dd10ca58db4871c.zip
gnome-base/gnome-shell-3.24.2: Sync in changes done over time in the 3.22 series
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-shell/gnome-shell-3.24.2.ebuild36
1 files changed, 12 insertions, 24 deletions
diff --git a/gnome-base/gnome-shell/gnome-shell-3.24.2.ebuild b/gnome-base/gnome-shell/gnome-shell-3.24.2.ebuild
index 4b2dd7cd2fa8..7df0c777a34c 100644
--- a/gnome-base/gnome-shell/gnome-shell-3.24.2.ebuild
+++ b/gnome-base/gnome-shell/gnome-shell-3.24.2.ebuild
@@ -3,19 +3,20 @@
EAPI=6
GNOME2_LA_PUNT="yes"
+GNOME2_EAUTORECONF="yes"
PYTHON_COMPAT=( python{3_4,3_5} )
-inherit autotools gnome2 multilib pax-utils python-r1 systemd
+inherit gnome2 multilib pax-utils python-r1 systemd
DESCRIPTION="Provides core UI functions for the GNOME 3 desktop"
HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell"
LICENSE="GPL-2+ LGPL-2+"
SLOT="0"
-IUSE="+bluetooth +networkmanager nsplugin +nls -openrc-force"
+IUSE="+bluetooth +browser-extension +ibus +networkmanager nsplugin -openrc-force"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+KEYWORDS="~amd64 ~ia64 ~x86"
# libXfixes-5.0 needed for pointer barriers
# FIXME:
@@ -96,43 +97,36 @@ RDEPEND="${COMMON_DEPEND}
networkmanager? (
net-misc/mobile-broadband-provider-info
sys-libs/timezone-data )
- nls? ( >=app-i18n/ibus-1.4.99[dconf(+),gtk3,introspection] )
+ ibus? ( >=app-i18n/ibus-1.4.99[dconf(+),gtk3,introspection] )
"
# avoid circular dependency, see bug #546134
PDEPEND="
>=gnome-base/gdm-3.5[introspection]
>=gnome-base/gnome-control-center-3.8.3[bluetooth(+)?,networkmanager(+)?]
+ browser-extension? ( gnome-extra/chrome-gnome-shell )
"
DEPEND="${COMMON_DEPEND}
dev-libs/libxslt
>=dev-util/gdbus-codegen-2.45.3
>=dev-util/gtk-doc-am-1.17
gnome-base/gnome-common
+ sys-devel/autoconf-archive
>=sys-devel/gettext-0.19.6
virtual/pkgconfig
- !!=dev-lang/spidermonkey-1.8.2*
"
-# libmozjs.so is picked up from /usr/lib while compiling, so block at build-time
-# https://bugs.gentoo.org/show_bug.cgi?id=360413
-src_prepare() {
+PATCHES=(
# Change favorites defaults, bug #479918
- eapply "${FILESDIR}"/${PN}-3.22.0-defaults.patch
-
+ "${FILESDIR}"/${PN}-3.22.0-defaults.patch
# Fix automagic gnome-bluetooth dep, bug #398145
- eapply "${FILESDIR}"/${PN}-3.12-bluetooth-flag.patch
-
+ "${FILESDIR}"/${PN}-3.12-bluetooth-flag.patch
# Add missing path to libmutter-clutter when building .gir, bug #597842
- eapply "${FILESDIR}"/${PN}-3.22.0-gir-build-fix.patch
-
- eautoreconf
- gnome2_src_prepare
-}
+ "${FILESDIR}"/${PN}-3.22.0-gir-build-fix.patch
+)
src_configure() {
# Do not error out on warnings
gnome2_src_configure \
- --enable-browser-plugin \
--enable-man \
$(use_enable !openrc-force systemd) \
$(use_with bluetooth) \
@@ -172,12 +166,6 @@ pkg_postinst() {
ewarn "apps.gnome-shell.recorder/pipeline to what you want to use."
fi
- if has_version "<x11-drivers/ati-drivers-12"; then
- ewarn "GNOME Shell has been reported to show graphical corruption under"
- ewarn "x11-drivers/ati-drivers-11.*; you may want to switch to open-source"
- ewarn "drivers."
- fi
-
if ! has_version "media-libs/mesa[llvm]"; then
elog "llvmpipe is used as fallback when no 3D acceleration"
elog "is available. You will need to enable llvm USE for"