summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-01-06 14:43:08 -0300
committerPacho Ramos <pacho@gentoo.org>2024-08-01 10:10:01 +0200
commit48388965037223c7a87769b2daa713d40cd0bdb7 (patch)
tree096c57ad6a8453b159410b8c9d9750c3dec3f95e /gnome-extra/gnome-system-monitor
parentgnome-base/libgtop: Bump to 2.41.3 (diff)
downloadgentoo-48388965037223c7a87769b2daa713d40cd0bdb7.tar.gz
gentoo-48388965037223c7a87769b2daa713d40cd0bdb7.tar.bz2
gentoo-48388965037223c7a87769b2daa713d40cd0bdb7.zip
gnome-extra/gnome-system-monitor: Bump to 46.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34678 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-system-monitor')
-rw-r--r--gnome-extra/gnome-system-monitor/Manifest1
-rw-r--r--gnome-extra/gnome-system-monitor/gnome-system-monitor-46.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/gnome-extra/gnome-system-monitor/Manifest b/gnome-extra/gnome-system-monitor/Manifest
index 5a05437f7ee2..0120025cfe0f 100644
--- a/gnome-extra/gnome-system-monitor/Manifest
+++ b/gnome-extra/gnome-system-monitor/Manifest
@@ -1 +1,2 @@
DIST gnome-system-monitor-45.0.2.tar.xz 1020000 BLAKE2B 9c35175e9b71fa9ea4689fdd17f8a7b9f251fc9039db6d89d6d05fa6fb2729ecce20c5d0f4a000f2f8a3eaa63026053a14a8681e62d8a5af9e589e230bd18026 SHA512 60c65a4e035d82bdae98622ed113ba26b45491c7e31358a138a6e4029a08448671190bf8eaf9bb1d30468a4cc00de7565ac25f0b93ac9c3ecee2fcb0515c62f7
+DIST gnome-system-monitor-46.0.tar.xz 1041848 BLAKE2B 29d87d6621538f7c0e0778eb7c598ac69bc52d05c5ce481e3d22d87cc540830481d34dccc992e44b59556104f567eeba9375d802418c371501994039065c0838 SHA512 2bba46bf5f03d4b8ad6e45e42b2d7ce21859037a1bd386ea17276d10c0eba506c718ab5bc4c203823cabd830bdaac3d61753dbb3b364eaf4dfea0031fea0ac27
diff --git a/gnome-extra/gnome-system-monitor/gnome-system-monitor-46.0.ebuild b/gnome-extra/gnome-system-monitor/gnome-system-monitor-46.0.ebuild
new file mode 100644
index 000000000000..f3b95e96f343
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/gnome-system-monitor-46.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="The Gnome System Monitor"
+HOMEPAGE="https://apps.gnome.org/SystemMonitor/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="systemd X"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-cpp/glibmm-2.68:2.68
+ >=dev-libs/glib-2.56.0:2
+ >=gui-libs/gtk-4.12.0:4[X(+)?]
+ >=dev-cpp/gtkmm-4.0.0:4.0
+ >=gnome-base/libgtop-2.41.2:2=
+ >=gnome-base/librsvg-2.46:2
+ >=dev-libs/libxml2-2.0:2
+ X? ( >=x11-libs/libwnck-2.91.0:3 )
+ systemd? ( >=sys-apps/systemd-44:0= )
+"
+# eautoreconf requires gnome-base/gnome-common
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ >=sys-auth/polkit-0.114
+" # polkit needed at buildtime for ITS rules of policy files, first available in 0.114
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use X wnck)
+ $(meson_use systemd)
+ -Ddevelopment=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}