summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-12-04 11:25:14 +0100
committerPacho Ramos <pacho@gentoo.org>2022-12-04 15:49:10 +0100
commit5133e8990833d7f29a1bffcf842d7b2338107244 (patch)
tree828d81b213711e8bf693e30708e78e55f55cf50f /gnome-extra
parentgnome-extra/gnome-shell-extension-bluetooth-quick-connect: stabilize 30 for A... (diff)
downloadgentoo-5133e8990833d7f29a1bffcf842d7b2338107244.tar.gz
gentoo-5133e8990833d7f29a1bffcf842d7b2338107244.tar.bz2
gentoo-5133e8990833d7f29a1bffcf842d7b2338107244.zip
gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen: Support Gnome 43
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/files/gnome-shell-extension-control-blur-effect-on-lock-screen-20220323-gnome43.patch12
-rw-r--r--gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20220323-r1.ebuild60
2 files changed, 72 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/files/gnome-shell-extension-control-blur-effect-on-lock-screen-20220323-gnome43.patch b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/files/gnome-shell-extension-control-blur-effect-on-lock-screen-20220323-gnome43.patch
new file mode 100644
index 000000000000..5692ec98793e
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/files/gnome-shell-extension-control-blur-effect-on-lock-screen-20220323-gnome43.patch
@@ -0,0 +1,12 @@
+--- a/metadata.json.old 2022-12-04 11:21:39.015695448 +0100
++++ b/metadata.json 2022-12-04 11:21:47.130043343 +0100
+@@ -5,7 +5,8 @@
+ "shell-version": [
+ "40",
+ "41",
+- "42"
++ "42",
++ "43"
+ ],
+ "url": "https://github.com/PRATAP-KUMAR/Control_Blur_Effect_On_Lock_Screen",
+ "uuid": "ControlBlurEffectOnLockScreen@pratap.fastmail.fm",
diff --git a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20220323-r1.ebuild b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20220323-r1.ebuild
new file mode 100644
index 000000000000..1f880da75164
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20220323-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+DESCRIPTION="Control the blur effect on gnome-shell lock screen"
+HOMEPAGE="https://github.com/PRATAP-KUMAR/Control_Blur_Effect_On_Lock_Screen"
+COMMIT="f24d6eda9bd1c625f5f35ab50a1caf5fef646a72"
+SRC_URI="https://github.com/PRATAP-KUMAR/Control_Blur_Effect_On_Lock_Screen/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-40
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+extension_uuid="ControlBlurEffectOnLockScreen@pratap.fastmail.fm"
+S="${WORKDIR}/${PN/gnome-shell-extension-/}-${COMMIT}"
+
+PATCHES=(
+ # https://github.com/PRATAP-KUMAR/control-blur-effect-on-lock-screen/issues/4
+ "${FILESDIR}/${P}-gnome43.patch"
+)
+
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf LICENSE README.md schemas
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}