summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2018-07-19 01:16:31 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-07-19 01:16:41 +0200
commitd32214bc7c8c8ad12f7d684966172cf5975db58c (patch)
treee184372c3eceecf08c5d25989cc5dc8e4d0ef37a /gnustep-apps/gnumail/gnumail-1.3.0.ebuild
parentgnustep-libs/pantomime: 1.3.0 bump (diff)
downloadgentoo-d32214bc7c8c8ad12f7d684966172cf5975db58c.tar.gz
gentoo-d32214bc7c8c8ad12f7d684966172cf5975db58c.tar.bz2
gentoo-d32214bc7c8c8ad12f7d684966172cf5975db58c.zip
gnustep-apps/gnumail: 1.3.0 bump
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'gnustep-apps/gnumail/gnumail-1.3.0.ebuild')
-rw-r--r--gnustep-apps/gnumail/gnumail-1.3.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnustep-apps/gnumail/gnumail-1.3.0.ebuild b/gnustep-apps/gnumail/gnumail-1.3.0.ebuild
new file mode 100644
index 000000000000..fd4b6e0cef6a
--- /dev/null
+++ b/gnustep-apps/gnumail/gnumail-1.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnustep-2
+
+MY_P=${P/gnum/GNUM}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A fully featured mail application for GNUstep"
+HOMEPAGE="http://www.nongnu.org/gnustep-nonfsf/gnumail/index.html"
+SRC_URI="mirror://nongnu/gnustep-nonfsf/${MY_P}.tar.gz"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="crypt"
+DEPEND=">=gnustep-base/gnustep-gui-0.11.0
+ =gnustep-libs/pantomime-1.3*
+ gnustep-apps/addresses"
+RDEPEND="crypt? ( app-crypt/gnupg )"
+
+src_prepare() {
+ use crypt || sed -i -e 's|Bundles/PGP||' GNUmakefile || die
+
+ default
+}
+
+src_install() {
+ gnustep-base_src_install
+ dodoc "${S}"/Documentation/*
+}