summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnustep-libs/cenonlibrary
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnustep-libs/cenonlibrary')
-rw-r--r--gnustep-libs/cenonlibrary/Manifest2
-rw-r--r--gnustep-libs/cenonlibrary/cenonlibrary-3.9.4.ebuild26
-rw-r--r--gnustep-libs/cenonlibrary/cenonlibrary-4.0.0.ebuild26
-rw-r--r--gnustep-libs/cenonlibrary/metadata.xml11
4 files changed, 65 insertions, 0 deletions
diff --git a/gnustep-libs/cenonlibrary/Manifest b/gnustep-libs/cenonlibrary/Manifest
new file mode 100644
index 000000000000..41ab5359c22b
--- /dev/null
+++ b/gnustep-libs/cenonlibrary/Manifest
@@ -0,0 +1,2 @@
+DIST CenonLibrary-3.9.4-1.tar.bz2 2058146 SHA256 eecb3c588f65cbe68db902e2c29264904a04b1042f74b598695667cd9aeea761
+DIST CenonLibrary-4.0.0-1.tar.bz2 2131692 SHA256 b329331a4b5b40d93eeeddd98f6922a53401b6e4f437538cd98392f8828cbb44 SHA512 75d1acc2635cb5daee3311d2c54a43abf9d0de7b29997fec86effc4dd3932fe73449c08cda642d1f92adcea9da74cd4732014bb04f7418c1f331701bafe44427 WHIRLPOOL bcfbe87deb051b9b48472914a68a38590cee11b3a67f5b02ca8b13037b59f1389f26b07e202920595293e6288a8c974868b861ac27d30b1f592e7db95ff4b43f
diff --git a/gnustep-libs/cenonlibrary/cenonlibrary-3.9.4.ebuild b/gnustep-libs/cenonlibrary/cenonlibrary-3.9.4.ebuild
new file mode 100644
index 000000000000..bcd5ffae0981
--- /dev/null
+++ b/gnustep-libs/cenonlibrary/cenonlibrary-3.9.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit gnustep-2
+
+S=${WORKDIR}/Cenon
+
+DESCRIPTION="Default library required to run Cenon"
+HOMEPAGE="http://www.cenon.info/"
+SRC_URI="http://www.vhf-group.com/vhf-interservice/download/source/CenonLibrary-${PV}-1.tar.bz2"
+KEYWORDS="amd64 ppc x86"
+SLOT="0"
+LICENSE="Cenon"
+IUSE=""
+
+src_compile() {
+ echo "nothing to compile"
+}
+
+src_install() {
+ egnustep_env
+ dodir ${GNUSTEP_SYSTEM_LIBRARY}
+ cp -pPR "${S}" "${D}"${GNUSTEP_SYSTEM_LIBRARY}
+}
diff --git a/gnustep-libs/cenonlibrary/cenonlibrary-4.0.0.ebuild b/gnustep-libs/cenonlibrary/cenonlibrary-4.0.0.ebuild
new file mode 100644
index 000000000000..dba6bc567ca8
--- /dev/null
+++ b/gnustep-libs/cenonlibrary/cenonlibrary-4.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gnustep-2
+
+S=${WORKDIR}/Cenon
+
+DESCRIPTION="Default library required to run Cenon"
+HOMEPAGE="http://www.cenon.info/"
+SRC_URI="http://www.vhf-group.com/vhf-interservice/download/source/CenonLibrary-${PV}-1.tar.bz2"
+KEYWORDS="amd64 ppc x86"
+SLOT="0"
+LICENSE="Cenon"
+IUSE=""
+
+src_compile() {
+ echo "nothing to compile"
+}
+
+src_install() {
+ egnustep_env
+ dodir ${GNUSTEP_SYSTEM_LIBRARY}
+ cp -pPR "${S}" "${D}"${GNUSTEP_SYSTEM_LIBRARY}
+}
diff --git a/gnustep-libs/cenonlibrary/metadata.xml b/gnustep-libs/cenonlibrary/metadata.xml
new file mode 100644
index 000000000000..73e8b8b06dff
--- /dev/null
+++ b/gnustep-libs/cenonlibrary/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnustep</herd>
+ <longdescription>
+ Cenon is a graphical tool of a special kind. Build upon a
+ modular graphical core, Cenon offers a wide variety of
+ possibilities and applications.
+ This package contains the supporting libraries for cenon itself.
+ </longdescription>
+</pkgmetadata>