summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2023-10-18 09:27:38 +0200
committerArsen Arsenović <arsen@gentoo.org>2023-10-18 09:37:56 +0200
commit343217835096b21c93b447b38adcf134bffe1837 (patch)
tree2a4103fcec598df32e0cfe20e64f59d852e3b040 /gui-apps
parentgui-apps/foot-terminfo: add 1.16.2 (diff)
downloadgentoo-343217835096b21c93b447b38adcf134bffe1837.tar.gz
gentoo-343217835096b21c93b447b38adcf134bffe1837.tar.bz2
gentoo-343217835096b21c93b447b38adcf134bffe1837.zip
gui-apps/foot: add 1.16.2
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/foot/Manifest1
-rw-r--r--gui-apps/foot/foot-1.16.2.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/gui-apps/foot/Manifest b/gui-apps/foot/Manifest
index 67ca72527c94..e063640eea4b 100644
--- a/gui-apps/foot/Manifest
+++ b/gui-apps/foot/Manifest
@@ -7,3 +7,4 @@ DIST foot-1.15.1.tar.gz 523399 BLAKE2B 6e9296dcb8fd16fb77ec1e7a7668b46da31f83343
DIST foot-1.15.2.tar.gz 524743 BLAKE2B 7c6f573e733210f532238eb0d2385d49f61fcb531265ff1474b93cd092c8d860f27b11e6b36c506379d7874b9cc285825f56518817a2623fdde93b7c3d0e4fc6 SHA512 931231e0518950d3ac42625befab63ecc9a253bb870ea4c439d1110c40b31c15d049b9fc1e2a6282927737a9f6d7cd3278d42dffa6a57c3c1366e342e1e79622
DIST foot-1.15.3.tar.gz 524297 BLAKE2B 3909a2cd9b7df1dbc6305a14675494d65874d1af2ad550fcbc7fe4b33c1a2bb2287029922daedbea8c9bfa5a855e1dd5c01fa2011bc0f9ebddca8565a44da591 SHA512 c27fefd40518382a184c590d02eee69deecf665759e909de6f4a61234159df7a1b38061eb9fd776ed205f10a556d5bf7520f5515fa9cec22a683f2f25d7495f8
DIST foot-1.16.1.tar.gz 529761 BLAKE2B a3b88cfd1f369dc89c1a1b459cc2de0a031624b1348b04737e2fba0b70fed6ad1407ab4972ee245d1e38cf00bc0dab52c7e7f2f88131c16d240672df4527fb60 SHA512 ba37f05b1bad9f2e3bc35aceb4465071273744b53b9f6cb93cd348e72ab37c9a14a268ba8d68e43ea5fc540f5d3deb33b88d9160c80b7743f7ca2f05130bd677
+DIST foot-1.16.2.tar.gz 529917 BLAKE2B 2ad75af2505da361b8a186119229516210492f48923186c747c4b010048782846026f53ab454e2ee4c61c42d03a01552377696fd4fc234ba233bea1f507d2d2f SHA512 c357f4c8479e70ba716ab65ddc6605c1705702306273eb6de9797892c7b2a6ea5b8c1b05d74f552f630307356ce2b5546a5bed8ae38dc3d45f090a77cb74bb49
diff --git a/gui-apps/foot/foot-1.16.2.ebuild b/gui-apps/foot/foot-1.16.2.ebuild
new file mode 100644
index 000000000000..df30967e93ea
--- /dev/null
+++ b/gui-apps/foot/foot-1.16.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg systemd
+
+DESCRIPTION="Fast, lightweight and minimalistic Wayland terminal emulator"
+HOMEPAGE="https://codeberg.org/dnkl/foot"
+SRC_URI="https://codeberg.org/dnkl/foot/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="+grapheme-clustering test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-libs/wayland
+ media-libs/fcft
+ media-libs/fontconfig
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ grapheme-clustering? (
+ dev-libs/libutf8proc:=
+ media-libs/fcft[harfbuzz]
+ )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ >=dev-libs/tllist-1.1.0
+ >=dev-libs/wayland-protocols-1.32
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ || (
+ >=sys-libs/ncurses-6.3[-minimal]
+ ~gui-apps/foot-terminfo-${PV}
+ )
+"
+BDEPEND="
+ app-text/scdoc
+ dev-util/wayland-scanner
+"
+
+src_prepare() {
+ default
+ # disable the systemd dep, we install the unit file manually
+ sed -i "s/systemd', required: false)$/', required: false)/" "${S}"/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature grapheme-clustering)
+ $(meson_use test tests)
+ -Dthemes=true
+ -Dime=true
+ -Dterminfo=disabled
+ )
+ meson_src_configure
+
+ sed 's|@bindir@|/usr/bin|g' "${S}"/foot-server.service.in > foot-server.service || die
+}
+
+src_install() {
+ local DOCS=( CHANGELOG.md README.md LICENSE )
+ meson_src_install
+
+ # foot unconditionally installs CHANGELOG.md, README.md and LICENSE.
+ # we handle this via DOCS and dodoc instead.
+ rm -r "${ED}/usr/share/doc/${PN}" || die
+ systemd_douserunit foot-server.service "${S}"/foot-server.socket
+}