summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-08-06 01:02:28 -0300
committerMatt Turner <mattst88@gentoo.org>2023-08-06 12:16:15 -0400
commita138d9ee40021ac4e493052c911e104577cd1cd7 (patch)
tree7e3080e5b3d3263600439df095b0a94395f05f53 /gui-apps
parentnet-misc/gnome-connections: Version bump to 45_beta (diff)
downloadgentoo-a138d9ee40021ac4e493052c911e104577cd1cd7.tar.gz
gentoo-a138d9ee40021ac4e493052c911e104577cd1cd7.tar.bz2
gentoo-a138d9ee40021ac4e493052c911e104577cd1cd7.zip
gui-apps/gnome-console: Version bump to 45_beta
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32191 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/gnome-console/Manifest1
-rw-r--r--gui-apps/gnome-console/gnome-console-45_beta.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/gui-apps/gnome-console/Manifest b/gui-apps/gnome-console/Manifest
index d7055a23367c..f0a9731cf13f 100644
--- a/gui-apps/gnome-console/Manifest
+++ b/gui-apps/gnome-console/Manifest
@@ -1 +1,2 @@
DIST gnome-console-44.0.tar.xz 160764 BLAKE2B db8438cf90ae7d54a359faa6cdda15dfcf4f47ba350d7b62febe71b9ade39b52e2da8883705ef7e31886eca7aa2940a1a9d4813460ef8a04402b829bb21f5ba5 SHA512 c53435f303d1625730174f3ec36c554c2090a5e64796b03642bb2ccc7edc301219f324d929b77dd8b4bfe12553c089103b2b57b6e1062b504b0d0007c2079f28
+DIST gnome-console-45.beta.tar.xz 169364 BLAKE2B b0834ce6b1398a0635097e29650ccce8dd0dd814e2efa1cb3d45986269e5491c031ef9c47113919fc26e424b04d2065f8c260befc786d62dc7deee09ee12c0b3 SHA512 1c9c9e34c39084c3182c6b03cee159b8e2a99e75acefc2882074d41fc62580e27acc12293c69b06a2cdb7e800a63b10b629f63d20ba52ce4bb493c1e09ffdaa6
diff --git a/gui-apps/gnome-console/gnome-console-45_beta.ebuild b/gui-apps/gnome-console/gnome-console-45_beta.ebuild
new file mode 100644
index 000000000000..48a5d7d780c9
--- /dev/null
+++ b/gui-apps/gnome-console/gnome-console-45_beta.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A simple user-friendly terminal emulator for the GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/console"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.76:2
+ >=gui-libs/gtk-4.10.5:4
+ >=gui-libs/libadwaita-1.4_alpha:1
+ >=gui-libs/vte-0.70.0:2.91-gtk4
+ gnome-base/libgtop:2=
+ >=dev-libs/libpcre2-10.32:0=
+ gnome-base/gsettings-desktop-schemas
+
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddevel=false
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}