summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-04-13 07:34:44 +0000
committerSam James <sam@gentoo.org>2023-04-16 07:55:05 +0100
commit0bda962f9afcafa7507d8d4124d63b7069b6cde8 (patch)
treee6f06a34037215d557aaf00aea9d076fd2861417 /gui-libs/gtk-layer-shell
parentx11-libs/gtk+: mask x11-libs/gtk+[cloudproviders] (diff)
downloadgentoo-0bda962f9afcafa7507d8d4124d63b7069b6cde8.tar.gz
gentoo-0bda962f9afcafa7507d8d4124d63b7069b6cde8.tar.bz2
gentoo-0bda962f9afcafa7507d8d4124d63b7069b6cde8.zip
gui-libs/gtk-layer-shell: add 0.8.1
Signed-off-by: Michael Vetter <jubalh@iodoru.org> Closes: https://github.com/gentoo/gentoo/pull/30579 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-libs/gtk-layer-shell')
-rw-r--r--gui-libs/gtk-layer-shell/Manifest1
-rw-r--r--gui-libs/gtk-layer-shell/gtk-layer-shell-0.8.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/gui-libs/gtk-layer-shell/Manifest b/gui-libs/gtk-layer-shell/Manifest
index d05cec42fde0..b444c88202e1 100644
--- a/gui-libs/gtk-layer-shell/Manifest
+++ b/gui-libs/gtk-layer-shell/Manifest
@@ -1 +1,2 @@
DIST gtk-layer-shell-0.8.0.tar.gz 134857 BLAKE2B 2f41411c849182f95c068040a17e961a34d1a3df0bb1280b6c57046729396108d4627b5cf9bd826f17ffb5cf77f6761212af159d4326b2d34d9663063667f9f4 SHA512 710019b05785abc3cc8bc639a110f141dd2f37ce1d78e03ed361f1c21caee6c43817499fa05c8228f233bff3ac0b6f6123fa9014a87ae99edb6b10e4ff8f3dde
+DIST gtk-layer-shell-0.8.1.tar.gz 136156 BLAKE2B 19c16d49d119572b0a3ef9bf0aee2341dedb4b2e5afedee16b9817e16fcd2adba7696a9d6f2f01b4ebaa3636c116d8977079a9b83ed1941f9d97df9389425780 SHA512 070673a73166c9fd0ea10e6aa98c480318fbf8a6c2dff2a9b4900aea40bb59680d41d9bba9917953fabe4358c0dfa6c3d0221c579ada37cee72ce23433b40329
diff --git a/gui-libs/gtk-layer-shell/gtk-layer-shell-0.8.1.ebuild b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.8.1.ebuild
new file mode 100644
index 000000000000..573e63d8743f
--- /dev/null
+++ b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.8.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+VALA_USE_DEPEND="vapigen"
+inherit vala meson python-any-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/wmww/${PN}"
+else
+ SRC_URI="https://github.com/wmww/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv x86"
+fi
+
+DESCRIPTION="Library to create desktop components for Wayland using the Layer Shell protocol"
+HOMEPAGE="https://github.com/wmww/gtk-layer-shell"
+
+LICENSE="MIT-with-advertising LGPL-3+"
+SLOT="0"
+IUSE="examples gtk-doc introspection test vala"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=x11-libs/gtk+-3.24.37:3[introspection?,wayland]
+ >=dev-libs/wayland-1.10.0
+ >=dev-libs/wayland-protocols-1.16
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ gtk-doc? ( dev-util/gtk-doc )
+ test? ( ${PYTHON_DEPS} )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ $(meson_use gtk-doc docs)
+ $(meson_use test tests)
+ $(meson_use introspection)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}