summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLorenzo Tucci <yamabiiko@protonmail.com>2021-05-13 12:59:07 +0200
committerMatthew Thode <prometheanfire@gentoo.org>2021-05-13 10:45:00 -0500
commiteaa62a639aeab9ab1b9a4addaff78e0dc00f7f8f (patch)
treede6a2e38fac4b022cd9a11372e2274aa211f1ae3 /gui-libs/xdg-desktop-portal-wlr
parentgames-action/minetest: allow building with gcc-11 (diff)
downloadgentoo-eaa62a639aeab9ab1b9a4addaff78e0dc00f7f8f.tar.gz
gentoo-eaa62a639aeab9ab1b9a4addaff78e0dc00f7f8f.tar.bz2
gentoo-eaa62a639aeab9ab1b9a4addaff78e0dc00f7f8f.zip
gui-libs/xdg-desktop-portal-wlr: 0.3.0 version bump
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Lorenzo Tucci <yamabiiko@protonmail.com> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-libs/xdg-desktop-portal-wlr')
-rw-r--r--gui-libs/xdg-desktop-portal-wlr/Manifest1
-rw-r--r--gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.3.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/gui-libs/xdg-desktop-portal-wlr/Manifest b/gui-libs/xdg-desktop-portal-wlr/Manifest
index 158e2400ed7c..79a4e78a55ab 100644
--- a/gui-libs/xdg-desktop-portal-wlr/Manifest
+++ b/gui-libs/xdg-desktop-portal-wlr/Manifest
@@ -1 +1,2 @@
DIST xdg-desktop-portal-wlr-0.2.0.tar.gz 22260 BLAKE2B a1f3a8244b985874a0b663b311157bc2e2098b8c50b6e3688c89d1c7bf7c454048b359ad42b97edb2faae7b232cd5b6843c07098c07e1f97ede507995d214271 SHA512 9b01919b380510389710c005901810ac6fa00299f2b35a37fa949aab361438ab08c30fc95b88e1805dcea7e97ebe2d19111693f82eee545864077347d2659ca9
+DIST xdg-desktop-portal-wlr-0.3.0.tar.gz 29340 BLAKE2B 848e3cb969a6d9f9cfcbb25336bd66bf75e2ae01fc5ba637950bb202399c2344f14cbc7a65c5940678bc4ca02134cee26ee425b88a91d050c6833c6098d34fd6 SHA512 2b01fab18296cb95cf659ff5a74ed6bf1482c033fdb274904bf2c3ea736dd3c8cb2e82f0662439a88f81ae86cc2fca2fbc3c1a9c72267ba126571973a7662e3d
diff --git a/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.3.0.ebuild b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.3.0.ebuild
new file mode 100644
index 000000000000..e5d42ca22778
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="xdg-desktop-portal backend for wlroots"
+HOMEPAGE="https://github.com/emersion/xdg-desktop-portal-wlr"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/emersion/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/9999"
+IUSE="elogind systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ >=media-video/pipewire-0.3.2:=
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.14:=
+ elogind? ( >=sys-auth/elogind-237 )
+ systemd? ( >=sys-apps/systemd-237 )
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/xdg-desktop-portal
+"
+BDEPEND="
+ >=media-video/pipewire-0.3.2:=
+ >=dev-libs/wayland-protocols-1.14
+ >=dev-util/meson-0.50.0
+ dev-libs/iniparser:0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}