summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-03-14 10:52:16 -0300
committerMatt Turner <mattst88@gentoo.org>2023-03-17 22:28:45 -0400
commit5836e636609e6da42d25cc46f93ad976567edfe4 (patch)
tree762d231c74c9682418c84d848c0ee241e1c0aaa3 /gui-libs
parentgui-libs/gtksourceview: Version bump to 5.8.0 (diff)
downloadgentoo-5836e636609e6da42d25cc46f93ad976567edfe4.tar.gz
gentoo-5836e636609e6da42d25cc46f93ad976567edfe4.tar.bz2
gentoo-5836e636609e6da42d25cc46f93ad976567edfe4.zip
gui-libs/libpanel: Version bump to 1.2.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/libpanel/Manifest1
-rw-r--r--gui-libs/libpanel/libpanel-1.2.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/gui-libs/libpanel/Manifest b/gui-libs/libpanel/Manifest
index 07171f0ac917..cd854ae598ac 100644
--- a/gui-libs/libpanel/Manifest
+++ b/gui-libs/libpanel/Manifest
@@ -1 +1,2 @@
DIST libpanel-1.0.2.tar.xz 101032 BLAKE2B 965140df480b4d6aad1fb008b54ce4c46e78c50136c1bbe200430e97b1f9f2f399bedb8d8695ddfdaef80fdb544be181f3e1a97bd6a4ad7bcacc2a091e00448e SHA512 3c13d7842ba1f1dc1a4bbea3e47517fffe20205c6145812659c203d065523310f1a9b991d7a70454c1333332b25b3eb52835122df14b2993a395fd2aa6046dca
+DIST libpanel-1.2.0.tar.xz 131296 BLAKE2B ee999166748e1cab227a970a9cc3ab05f47a88e5e9431b0e25f9e1933c31d13de1ce9a4132658905d6e0a7d7a6cc1ed214ff41d61ff3722355e7bc11465dce8a SHA512 28277d9679b71d6ea9ec891db2fad371e7f152240114def3ad84a24a4abe7b4de0dcec18448cd397dc79083109fdf2d0c9dd45bb198f059869a30b0f51afdb2f
diff --git a/gui-libs/libpanel/libpanel-1.2.0.ebuild b/gui-libs/libpanel/libpanel-1.2.0.ebuild
new file mode 100644
index 000000000000..242a28496abe
--- /dev/null
+++ b/gui-libs/libpanel/libpanel-1.2.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala xdg
+
+DESCRIPTION="A dock/panel library for GTK 4"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libpanel"
+
+LICENSE="LGPL-3+"
+SLOT="1"
+KEYWORDS="~amd64"
+
+IUSE="examples gtk-doc +introspection +vala"
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ vala? ( introspection )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.75:2
+ >=gui-libs/gtk-4.8:4[introspection?]
+ >=gui-libs/libadwaita-1.2:1
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( >=dev-util/gi-docgen-2021.1 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples install-examples)
+ $(meson_feature introspection)
+ $(meson_feature gtk-doc docs)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use gtk-doc; then
+ mkdir "${ED}"/usr/share/gtk-doc || die
+ mv "${ED}"/usr/share/doc/panel-1.0 "${ED}"/usr/share/gtk-doc/ || die
+ fi
+}