summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorMia Ksenia <koishi@koishi.de>2023-05-18 19:35:04 +0200
committerSam James <sam@gentoo.org>2023-06-05 06:12:50 +0100
commit61c03dd0e0d108c62376e97cf587ddbb8d43cda2 (patch)
tree6045724efa3595d118cd8b8783802f035010bcef /gui-wm
parentx11-libs/libxcb: enable py3.12 (diff)
downloadgentoo-61c03dd0e0d108c62376e97cf587ddbb8d43cda2.tar.gz
gentoo-61c03dd0e0d108c62376e97cf587ddbb8d43cda2.tar.bz2
gentoo-61c03dd0e0d108c62376e97cf587ddbb8d43cda2.zip
gui-wm/hyprland: Added check for LLVM16
Signed-off-by: Mia Ksenia <koishi@koishi.de> Closes: https://github.com/gentoo/gentoo/pull/31084 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/hyprland/hyprland-0.25.0.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/gui-wm/hyprland/hyprland-0.25.0.ebuild b/gui-wm/hyprland/hyprland-0.25.0.ebuild
index bf62573979c1..aff592df7d8c 100644
--- a/gui-wm/hyprland/hyprland-0.25.0.ebuild
+++ b/gui-wm/hyprland/hyprland-0.25.0.ebuild
@@ -54,10 +54,14 @@ BDEPEND="
"
src_prepare() {
- STDLIBVER=$(echo '#include <string>' | $(tc-getCXX) -x c++ -dM -E - | \
+ if [[ $(tc-is-gcc) ]]; then
+ STDLIBVER=$(echo '#include <string>' | $(tc-getCXX) -x c++ -dM -E - | \
grep GLIBCXX_RELEASE | sed 's/.*\([1-9][0-9]\)/\1/')
- if ! [[ ${STDLIBVER} -ge 12 ]]; then
- die "Hyprland requires >=sys-devel/gcc-12.1.0 to build"
+ if ! [[ ${STDLIBVER} -ge 12 ]]; then
+ die "Hyprland requires >=sys-devel/gcc-12.1.0 to build"
+ fi
+ elif [[ $(clang-major-version) -lt 16 ]]; then
+ die "Hyprland requires >=sys-devel/clang-16.0.3 to build";
fi
if use video_cards_nvidia; then