summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-12-16 19:38:26 +0100
committerJohannes Huber <johu@gentoo.org>2016-12-16 19:38:38 +0100
commit31645664f42a588800ba68febd89a9c9e6afc76f (patch)
treeccc391e5d2b2b2255adcafe060246a5ddf9a3396 /kde-apps/akonadi
parentprofiles: Update masks for KDE Applications 16.12 (diff)
downloadgentoo-31645664f42a588800ba68febd89a9c9e6afc76f.tar.gz
gentoo-31645664f42a588800ba68febd89a9c9e6afc76f.tar.bz2
gentoo-31645664f42a588800ba68febd89a9c9e6afc76f.zip
kde-apps: Version bump KDE Applications 16.12.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-apps/akonadi')
-rw-r--r--kde-apps/akonadi/Manifest1
-rw-r--r--kde-apps/akonadi/akonadi-16.12.0.ebuild120
-rw-r--r--kde-apps/akonadi/files/akonadi-16.12.0-mysql56-crash.patch39
3 files changed, 160 insertions, 0 deletions
diff --git a/kde-apps/akonadi/Manifest b/kde-apps/akonadi/Manifest
index 49b3bcf400f4..fa8b782756d8 100644
--- a/kde-apps/akonadi/Manifest
+++ b/kde-apps/akonadi/Manifest
@@ -1,2 +1,3 @@
DIST akonadi-1.13.1_pre20160203.tar.gz 384556 SHA256 4243b32e529be6aadc38dc4463cb6e7cede9442c05cfc04ba679dde28f37aa96 SHA512 0ef8213f504ad1e500a2c1ce19a7575cd1fd8b7ffc7e5fb0bd2437639d8c458c47bbfea7734fcd3e200136a661331dde32af0b064f0b25d324138ce6e35d15f3 WHIRLPOOL 69eff1889a19f8d5714d7e71a106871172cd25c651ea30046ab81270cf7e46c7a1983cf20fd8d5fd8ad243d70e881be705d57b0b93b54248d086e7b253a4873a
DIST akonadi-16.08.3.tar.xz 1021916 SHA256 7ecb926d6f750ba2903b9ce96819cce758e4e7c9333a0f85fc93e4500a3d26cd SHA512 2413cc848fea63776adc46ef33bb5d2a0d800e1854d23237e6d57ee0d30a4ae9ccdedf6c71bce88866d94c4c1a5aa80448023cbc18ce2c81aaf4f413bd98c3fa WHIRLPOOL 46c9d120cb5cf2a14c395ff75d11cdde0d7bc51e7a22e4ee7730b9822eb3c6a74040469fe63e5941ded41af4c19eec651d70c8ae2f63b0e42d756ee6d591558d
+DIST akonadi-16.12.0.tar.xz 1036192 SHA256 281c8c0adfff16f4f43e428a22d483865ca2f54c0c2b24aae4ac8e85705712bf SHA512 6ee9bac8fad8825189976359626a7d2dea280fd4aecf5d4ce1d94d4fd6c8d0d738ceeba51a27564d3cfd5736b5e51e1078be04efa05efbdcdd8e84630c02d54d WHIRLPOOL 745103d8f4e80f93b6455fd4a181779cd2351561a7a6add6c69134aca4855f797c28194b6a82de77d59c8f8419f758f6f59ce3ac544ee1c4d610b4c8d4be1e85
diff --git a/kde-apps/akonadi/akonadi-16.12.0.ebuild b/kde-apps/akonadi/akonadi-16.12.0.ebuild
new file mode 100644
index 000000000000..11dbcb1e0391
--- /dev/null
+++ b/kde-apps/akonadi/akonadi-16.12.0.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_DESIGNERPLUGIN="true"
+KDE_TEST="forceoptional"
+VIRTUALDBUS_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Storage service for PIM data and libraries for PIM apps"
+HOMEPAGE="https://pim.kde.org/akonadi"
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="LGPL-2.1+"
+IUSE="+mysql postgres sqlite tools xml"
+
+REQUIRED_USE="|| ( sqlite mysql postgres ) test? ( tools )"
+
+# drop qtgui subslot operator when QT_MINIMAL >= 5.7.0
+COMMON_DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui '' '' '5=')
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtsql 'mysql?,postgres?')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ x11-misc/shared-mime-info
+ sqlite? ( dev-db/sqlite:3 )
+ tools? ( xml? ( dev-libs/libxml2 ) )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+ dev-libs/libxslt
+ test? ( sys-apps/dbus )
+"
+RDEPEND="${COMMON_DEPEND}
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )
+ !kde-apps/kdepimlibs
+"
+
+# some akonadi tests time out, that probably needs more work as it's ~700 tests
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${PN}-16.12.0-mysql56-crash.patch" )
+
+pkg_setup() {
+ # Set default storage backend in order: MySQL, SQLite PostgreSQL
+ # reverse driver check to keep the order
+ if use postgres; then
+ DRIVER="QPSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use sqlite; then
+ DRIVER="QSQLITE3"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ if use mysql; then
+ DRIVER="QMYSQL"
+ AVAILABLE+=" ${DRIVER}"
+ fi
+
+ # Notify about MySQL is recommend by upstream
+ if use sqlite || has_version "<${CATEGORY}/${P}[sqlite]"; then
+ ewarn
+ ewarn "We strongly recommend you change your Akonadi database backend to MySQL in your"
+ ewarn "user configuration. This is the backend recommended by KDE upstream."
+ ewarn "In particular, kde-apps/kmail-4.10 does not work properly with the sqlite"
+ ewarn "backend anymore."
+ ewarn "You can select the backend in your ~/.config/akonadi/akonadiserverrc."
+ ewarn "Available drivers are:${AVAILABLE}"
+ ewarn
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DAKONADI_BUILD_QSQLITE=$(usex sqlite)
+ -DBUILD_TOOLS=$(usex tools)
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ )
+
+ kde5_src_configure
+}
+
+src_install() {
+ # Who knows, maybe it accidentally fixes our permission issues
+ cat <<-EOF > "${T}"/akonadiserverrc
+[%General]
+Driver=${DRIVER}
+EOF
+ insinto /usr/share/config/akonadi
+ doins "${T}"/akonadiserverrc
+
+ kde5_src_install
+}
+
+pkg_postinst() {
+ elog "${DRIVER} has been set as your default akonadi storage backend."
+ elog "You can override it in your ~/.config/akonadi/akonadiserverrc."
+ elog "Available drivers are: ${AVAILABLE}"
+}
diff --git a/kde-apps/akonadi/files/akonadi-16.12.0-mysql56-crash.patch b/kde-apps/akonadi/files/akonadi-16.12.0-mysql56-crash.patch
new file mode 100644
index 000000000000..8f33abb246d6
--- /dev/null
+++ b/kde-apps/akonadi/files/akonadi-16.12.0-mysql56-crash.patch
@@ -0,0 +1,39 @@
+Gentoo-bug: 530012
+
+diff --git a/src/server/storage/dbconfigmysql.cpp b/src/server/storage/dbconfigmysql.cpp
+index 5cfaa33..1d1ea02 100644
+--- a/src/server/storage/dbconfigmysql.cpp
++++ b/src/server/storage/dbconfigmysql.cpp
+@@ -81,6 +81,7 @@ bool DbConfigMysql::init(QSettings &settings)
+ << QStringLiteral("/usr/local/sbin")
+ << QStringLiteral("/usr/local/libexec")
+ << QStringLiteral("/usr/libexec")
++ << QStringLiteral("/usr/share/mysql/scripts")
+ << QStringLiteral("/opt/mysql/libexec")
+ << QStringLiteral("/opt/local/lib/mysql5/bin")
+ << QStringLiteral("/opt/mysql/sbin");
+@@ -512,7 +513,7 @@ bool DbConfigMysql::initializeMariaDBDatabase(const QString &confFile, const QSt
+ return 0 == execute(mMysqlInstallDbPath,
+ { QStringLiteral("--defaults-file=%1").arg(confFile),
+ QStringLiteral("--force"),
+- QStringLiteral("--basedir=%1").arg(baseDir),
++ QStringLiteral("--basedir=/usr"),
+ QStringLiteral("--datadir=%1/").arg(dataDir) });
+ }
+
+@@ -525,6 +526,7 @@ bool DbConfigMysql::initializeMySQL5_7_6Database(const QString &confFile, const
+ return 0 == execute(mMysqldPath,
+ { QStringLiteral("--defaults-file=%1").arg(confFile),
+ QStringLiteral("--initialize"),
++ QStringLiteral("--basedir=/usr"),
+ QStringLiteral("--datadir=%1/").arg(dataDir) });
+ }
+
+@@ -538,6 +540,6 @@ bool DbConfigMysql::initializeMySQLDatabase(const QString &confFile, const QStri
+ // Don't use --force, it has been removed in MySQL 5.7.5
+ return 0 == execute(mMysqlInstallDbPath,
+ { QStringLiteral("--defaults-file=%1").arg(confFile),
+- QStringLiteral("--basedir=%1").arg(baseDir),
++ QStringLiteral("--basedir=/usr"),
+ QStringLiteral("--datadir=%1/").arg(dataDir) });
+ }