summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-11 14:01:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-11 14:19:52 +0200
commit9575324283ad2babba8b22185b5255376b8c686b (patch)
tree1d5567c892d13a113f6d6e7ab923fe3a0c37ba13 /kde-apps/dolphin
parentmedia-gfx/krita: 4.1.4 version bump (diff)
downloadgentoo-9575324283ad2babba8b22185b5255376b8c686b.tar.gz
gentoo-9575324283ad2babba8b22185b5255376b8c686b.tar.bz2
gentoo-9575324283ad2babba8b22185b5255376b8c686b.zip
kde-apps: Add KDE Applications 18.08.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'kde-apps/dolphin')
-rw-r--r--kde-apps/dolphin/Manifest1
-rw-r--r--kde-apps/dolphin/dolphin-18.08.2.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/kde-apps/dolphin/Manifest b/kde-apps/dolphin/Manifest
index a5ae9b31d0ec..681eca503f75 100644
--- a/kde-apps/dolphin/Manifest
+++ b/kde-apps/dolphin/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-18.04.3.tar.xz 4850916 BLAKE2B 1d2a5c4f5e94e2f30055804d96c205eb2c03864ad2b6c245d917549986fbac26686e654818dacf93fcb711f59bfe6e7f3a011e578988f5bf9e6b6cb82fc33876 SHA512 167a35225dd4e75b7ff863771287a471273e0594c247ef058adc718682eb07f014ca84bc373e1c3a846e99711aad3d9a16b12aab8543aa3603e17f944b206b21
DIST dolphin-18.08.1.tar.xz 4859496 BLAKE2B 0daf6f60580b9981fcd57cc11d5ad6b4071b7d4cb90673bbdcdbb2eccb927e42e49932b0bd5fc466345ed56363f271b7d56edc7dce348dc4afef55bc1a082f34 SHA512 1ad302f332bbae523db78db5048b910b182ef396a4222da0718d5b280be1adb54eba6abeeaa9facc3ecc49353b91e1aa67bb6f7429446589d6b51d0458a726ae
+DIST dolphin-18.08.2.tar.xz 4859700 BLAKE2B b7d16f3e3b8cd459a0089a4b37da86c7d4f095bbc3f8450b709259a820dd8a8fd26dd7a03e2bafbc103bdf588df23436eb2c3dcef5e946a4cc0b054f718fbdee SHA512 44e2a55cfb80c267cd56e5da2af7c1446859adb100a68eda82d052279402cf8f7233e79522ecd8a2d098a8a51a977d3fec37da7d2544cca5f43212d4ef2a61fa
diff --git a/kde-apps/dolphin/dolphin-18.08.2.ebuild b/kde-apps/dolphin/dolphin-18.08.2.ebuild
new file mode 100644
index 000000000000..47da3a35d622
--- /dev/null
+++ b/kde-apps/dolphin/dolphin-18.08.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma filemanager focusing on usability"
+HOMEPAGE="https://www.kde.org/applications/system/dolphin https://userbase.kde.org/Dolphin"
+KEYWORDS="~amd64 ~x86"
+IUSE="semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ media-libs/phonon[qt5(+)]
+ semantic-desktop? (
+ $(add_frameworks_dep baloo)
+ $(add_frameworks_dep kfilemetadata)
+ $(add_kdeapps_dep baloo-widgets)
+ )
+ !semantic-desktop? (
+ $(add_frameworks_dep kdelibs4support)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kio-extras)
+ thumbnail? (
+ $(add_kdeapps_dep ffmpegthumbs)
+ $(add_kdeapps_dep thumbnailers)
+ )
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
+ $(cmake-utils_use_find_package semantic-desktop KF5BalooWidgets)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetaData)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-apps/ark:${SLOT}" ; then
+ elog "For compress/extract and other actions, please install kde-apps/ark:${SLOT}"
+ fi
+
+ if ! has_version "kde-apps/kleopatra:${SLOT}" ; then
+ elog "For crypto actions, please install kde-apps/kleopatra:${SLOT}"
+ fi
+}