summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 10:53:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 14:03:48 +0200
commit44068399ad98520a66cafb092af777af8d77a11e (patch)
tree41ec18453e7fe581c9f6020280baaa81ae0a167d /kde-apps/kcontacts
parentkde-frameworks: Add KDE Frameworks 5.50.0 (diff)
downloadgentoo-44068399ad98520a66cafb092af777af8d77a11e.tar.gz
gentoo-44068399ad98520a66cafb092af777af8d77a11e.tar.bz2
gentoo-44068399ad98520a66cafb092af777af8d77a11e.zip
kde-apps: Add KDE Applications 18.08.1
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'kde-apps/kcontacts')
-rw-r--r--kde-apps/kcontacts/Manifest1
-rw-r--r--kde-apps/kcontacts/kcontacts-18.08.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/kde-apps/kcontacts/Manifest b/kde-apps/kcontacts/Manifest
index 858a65b421ba..ad5a0ae6c72e 100644
--- a/kde-apps/kcontacts/Manifest
+++ b/kde-apps/kcontacts/Manifest
@@ -1 +1,2 @@
DIST kcontacts-18.04.3.tar.xz 206936 BLAKE2B 00df6e8da4a3d70f7d630b8dd671c6214bca8ed7d938aafc2342dbba97337f077cb77bc9d0bab31a91b7b0b8dd9074f667846120e667a52bcb477ec6b29c20d0 SHA512 bf177c4cf0ecbdb71e75ee32a4e71599f864062524f5663e3c1d4b49a06d58a3abf7b18d2840cf7e70248a426fa6b6367375a2aaea211ba15a697e0dbd27953e
+DIST kcontacts-18.08.1.tar.xz 207388 BLAKE2B 2b49a61b4288d34c23ce24992d0b94769324ce431dc9e2aa3db97dc5ea615b394410fdc3b5eae49d0ccce25a3a66107e37833efa3ca5630231b3da1d728810bd SHA512 a28f004bb7c87206a3d063f66fae54c0147a1489bae94e7b5e5b7756f88518ddf86bd425a590483bcde6f339fbba2f76ee44e2138f595b19b1944718537c5fb2
diff --git a/kde-apps/kcontacts/kcontacts-18.08.1.ebuild b/kde-apps/kcontacts/kcontacts-18.08.1.ebuild
new file mode 100644
index 000000000000..97521a397373
--- /dev/null
+++ b/kde-apps/kcontacts/kcontacts-18.08.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Address book API based on KDE Frameworks"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_qt_dep qtgui)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_prepare() {
+ kde5_src_prepare
+
+ # FIXME: Fails test because access to /dev/dri/card0 is denied
+ sed -i \
+ -e "/ecm_add_tests/ s/picturetest\.cpp //" \
+ autotests/CMakeLists.txt || die
+}
+
+src_test() {
+ mkdir -p "${HOME}/.local/share/kf5/kcontacts" || die
+ cp "${S}/src/countrytransl.map" "${HOME}/.local/share/kf5/kcontacts/" || die
+ kde5_src_test
+}