summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-14 23:14:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-14 23:25:03 +0100
commit576fc933c81aa6e526d87290af95e8e898e70ecb (patch)
tree73f9a202bcb454043dbb6b731d9b56ed4c5f49eb /kde-apps/kio-extras
parentdev-haskell/stack-bin: bump up to 1.6.1 (diff)
downloadgentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.tar.gz
gentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.tar.bz2
gentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.zip
kde-apps: Add KDE Applications 17.12.0
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'kde-apps/kio-extras')
-rw-r--r--kde-apps/kio-extras/Manifest1
-rw-r--r--kde-apps/kio-extras/kio-extras-17.12.0.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/kde-apps/kio-extras/Manifest b/kde-apps/kio-extras/Manifest
index 5a5209aa3b63..daf0ae63e899 100644
--- a/kde-apps/kio-extras/Manifest
+++ b/kde-apps/kio-extras/Manifest
@@ -1 +1,2 @@
DIST kio-extras-17.08.3.tar.xz 556316 BLAKE2B 9dc5d9b20c459777c2d5ae5445c28a2b7576665a4a6edec5329689fd35be3ab86fddf6bde665c5c0b00570bea01e498f8998796ad244df91db42bfd889ebd84e SHA512 660370a59bf506bdb1ebaddb7de639f67021df4d3c7c26866e35135a66d736cd1dc11fc1a74f880d38b9989f656d14982bf1ddf9b26d6c7e8b1ec81228f6a2e5
+DIST kio-extras-17.12.0.tar.xz 556016 BLAKE2B 8526eff9de1be0e206aa55e6ce5917ee0b875b3009f2e7910f7ff0626cc0fd89d7b94808773fee2be469bdbd8784461eb4b0b1e925ee8bb4fbac6cf559cf8e82 SHA512 5996c814bfad67f8de207d44aa362d4dc751dbc83a6bddd1ce0a4c81aa1999cbfac595a17f1e668734d0d9fd33642c209101536f918d463402ae7805d146701e
diff --git a/kde-apps/kio-extras/kio-extras-17.12.0.ebuild b/kde-apps/kio-extras/kio-extras-17.12.0.ebuild
new file mode 100644
index 000000000000..d8937b02076f
--- /dev/null
+++ b/kde-apps/kio-extras/kio-extras-17.12.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KIO plugins present a filesystem-like view of arbitrary data"
+HOMEPAGE="https://cgit.kde.org/kio-extras.git"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="activities htmlthumbs +man mtp openexr phonon samba +sftp slp taglib"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive 'bzip2,lzma')
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdnssd)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ activities? (
+ $(add_frameworks_dep kactivities)
+ $(add_qt_dep qtsql)
+ )
+ htmlthumbs? ( $(add_qt_dep qtwebengine 'widgets') )
+ man? ( $(add_frameworks_dep khtml) )
+ mtp? ( media-libs/libmtp:= )
+ openexr? ( media-libs/openexr )
+ phonon? ( media-libs/phonon[qt5(+)] )
+ samba? ( net-fs/samba[client] )
+ sftp? ( net-libs/libssh:=[sftp] )
+ slp? ( net-libs/openslp )
+ taglib? ( >=media-libs/taglib-1.11.1 )
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kded)
+"
+DEPEND="${COMMON_DEPEND}
+ x11-misc/shared-mime-info
+ man? ( dev-util/gperf )
+"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package activities KF5Activities)
+ $(cmake-utils_use_find_package htmlthumbs Qt5WebEngineWidgets)
+ $(cmake-utils_use_find_package man Gperf)
+ $(cmake-utils_use_find_package mtp Mtp)
+ $(cmake-utils_use_find_package openexr OpenEXR)
+ $(cmake-utils_use_find_package phonon Phonon4Qt5)
+ $(cmake-utils_use_find_package samba Samba)
+ $(cmake-utils_use_find_package sftp LibSSH)
+ $(cmake-utils_use_find_package slp SLP)
+ $(cmake-utils_use_find_package taglib Taglib)
+ )
+
+ kde5_src_configure
+}