summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-09 18:20:07 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-09 18:23:07 +0100
commit101f20b293d1a063a2a1237a3beeac631704d3e5 (patch)
tree4cc6096c25b56aa84df9d4b7a9d5826fae4d4d66 /kde-apps/kolourpaint
parentsys-kernel/vanilla-kernel-bin: Bump to 4.19.94 LTS (diff)
downloadgentoo-101f20b293d1a063a2a1237a3beeac631704d3e5.tar.gz
gentoo-101f20b293d1a063a2a1237a3beeac631704d3e5.tar.bz2
gentoo-101f20b293d1a063a2a1237a3beeac631704d3e5.zip
kde-apps: Add KDE Applications 19.12.1
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kolourpaint')
-rw-r--r--kde-apps/kolourpaint/Manifest1
-rw-r--r--kde-apps/kolourpaint/kolourpaint-19.12.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/kde-apps/kolourpaint/Manifest b/kde-apps/kolourpaint/Manifest
index 16991b76a636..9ad9dd6f6f8a 100644
--- a/kde-apps/kolourpaint/Manifest
+++ b/kde-apps/kolourpaint/Manifest
@@ -1,2 +1,3 @@
DIST kolourpaint-19.08.3.tar.xz 5654752 BLAKE2B 24a2700197cdec75201b0a51534ee5b14b13c94db82306161319e89db1ea189463e9ef8884ef9162195ca8c2c14ae073244dc6cd85b5c22045fb8905daa3c909 SHA512 97430f2a04d60bfe4d5131e961381b3390181a57cc4b6ca8eda048b60a32804dcd89fec5a69bc50383f88e1bce05a5b7a1dfde33292d0e72f6bda76cda0dd851
DIST kolourpaint-19.12.0.tar.xz 5653480 BLAKE2B 7447a09e61477161596a0959533edd9c0332640cbb48c31f42f2ea9eb9ada2e0ff854c94ab1f33b73cb29d6a5c8d12abdfaa9d7b0b9b8a3255888cbe1311bdc1 SHA512 901152a81a302de808343774b238ab7693c4298888a815debac91fc43ec84e2c784a6c26420a703f1887003962e0bd4b60946fc8d8f2ba43748997922988557f
+DIST kolourpaint-19.12.1.tar.xz 5651460 BLAKE2B a158d021dbbed74c47099162326a77ef791e234619d07560b81b420398b17b06455820ace0858dc4a5145af8d908371ab0f014880a8d295d7cc0a07be26b7233 SHA512 1e1ac2e423c972b900588f6f1f20d46a9201958bb0c6cb349b38ef8ff1c88d67b1240ad9c4b5fadfe4aa6c72df432e4962d4ff82d722f63e1235baee9a17d8ab
diff --git a/kde-apps/kolourpaint/kolourpaint-19.12.1.ebuild b/kde-apps/kolourpaint/kolourpaint-19.12.1.ebuild
new file mode 100644
index 000000000000..19898155700a
--- /dev/null
+++ b/kde-apps/kolourpaint/kolourpaint-19.12.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.63.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Paint Program by KDE"
+HOMEPAGE="https://kde.org/applications/graphics/org.kde.kolourpaint"
+
+LICENSE="BSD-2 LGPL-2 LGPL-2+ || ( LGPL-2.1 LGPL-3 ) GPL-2 handbook? ( FDL-1.2 )"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="scanner"
+
+DEPEND="
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdelibs4support-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ scanner? ( >=kde-apps/libksane-${PVCUT}:5 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package scanner KF5Sane)
+ )
+
+ ecm_src_configure
+}