summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-base/perlkde
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-base/perlkde')
-rw-r--r--kde-base/perlkde/Manifest1
-rw-r--r--kde-base/perlkde/files/perlkde-4.11.3-vendor.patch11
-rw-r--r--kde-base/perlkde/metadata.xml12
-rw-r--r--kde-base/perlkde/perlkde-4.14.3.ebuild39
4 files changed, 63 insertions, 0 deletions
diff --git a/kde-base/perlkde/Manifest b/kde-base/perlkde/Manifest
new file mode 100644
index 000000000000..b9385e0d0d04
--- /dev/null
+++ b/kde-base/perlkde/Manifest
@@ -0,0 +1 @@
+DIST perlkde-4.14.3.tar.xz 40604 SHA256 6bde6c1871a0bcb78e1bf72a4ffe536d1098233f150931730ad723b02b473b2a SHA512 fc9d3300f3b0ba52ccb2baef06a955921d8e29a4f60f072eed76d05361b0600c1e6fd94e5f0f9f57df91964a9e2368c0607975b70f9bface215d6dfff3134490 WHIRLPOOL 368749f3515976ade55adf44653d7e61c32e9cef10a943f10ab70df6157c3a4062240cea434f82017d2acfc0064c6d327cd39964e9726f31ee8065b47eb2a2b2
diff --git a/kde-base/perlkde/files/perlkde-4.11.3-vendor.patch b/kde-base/perlkde/files/perlkde-4.11.3-vendor.patch
new file mode 100644
index 000000000000..635428fb260f
--- /dev/null
+++ b/kde-base/perlkde/files/perlkde-4.11.3-vendor.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -38,7 +38,7 @@
+ include (FindPerlMore)
+ string(LENGTH "${PERL_INSTALL_PREFIX}" PERL_INSTALL_PREFIX_LEN)
+ math(EXPR PERL_INSTALL_PREFIX_LEN "${PERL_INSTALL_PREFIX_LEN}+1")
+-string(SUBSTRING ${PERL_SITE_ARCH_DIR} ${PERL_INSTALL_PREFIX_LEN} -1 CUSTOM_PERL_SITE_ARCH_DIR)
++string(SUBSTRING ${PERL_VENDOR_ARCH_DIR} ${PERL_INSTALL_PREFIX_LEN} -1 CUSTOM_PERL_SITE_ARCH_DIR)
+ file(TO_NATIVE_PATH "${CMAKE_INSTALL_PREFIX}/${CUSTOM_PERL_SITE_ARCH_DIR}" CUSTOM_PERL_SITE_ARCH_DIR)
+ set(CUSTOM_PERL_SITE_ARCH_DIR ${CUSTOM_PERL_SITE_ARCH_DIR} CACHE DIR "Custom installation directory for perl binary extension")
+
diff --git a/kde-base/perlkde/metadata.xml b/kde-base/perlkde/metadata.xml
new file mode 100644
index 000000000000..ac14d321549c
--- /dev/null
+++ b/kde-base/perlkde/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="akonadi">Compile bindings for Akonadi</flag>
+ <flag name="attica">Compile bindings for <pkg>dev-libs/libattica</pkg></flag>
+ <flag name="kate">Compile bindings for KDE Advanced Text Editor</flag>
+ <flag name="nepomuk">Compile bindings for Nepomuk</flag>
+ <flag name="okular">Compile bindings for <pkg>kde-base/okular</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/kde-base/perlkde/perlkde-4.14.3.ebuild b/kde-base/perlkde/perlkde-4.14.3.ebuild
new file mode 100644
index 000000000000..5e561784c984
--- /dev/null
+++ b/kde-base/perlkde/perlkde-4.14.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="KDE Perl bindings"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi attica debug kate okular nepomuk test"
+
+RDEPEND="
+ >=dev-lang/perl-5.10.1:=
+ $(add_kdebase_dep perlqt)
+ $(add_kdebase_dep smokekde 'akonadi?,attica?,kate?,nepomuk?,okular?')
+ nepomuk? ( >=dev-libs/soprano-2.9.0 )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/List-MoreUtils )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-4.11.3-vendor.patch" )
+
+RESTRICT="test"
+# yes they all fail.
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_disable kate)
+ $(cmake-utils_use_with nepomuk)
+ $(cmake-utils_use_with nepomuk Soprano)
+ $(cmake-utils_use_with okular)
+ )
+ kde4-base_src_configure
+}