summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-14 13:46:10 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-14 13:46:10 +0200
commit82d39affe7c0394f58b7dbda11a4df2d233e86d1 (patch)
tree0c87d649221962703f877bfcae356c45a4d72b6c /kde-frameworks/frameworkintegration
parentkde-apps/kde-dev-utils: Fix build with KF-5.48 (diff)
downloadgentoo-82d39affe7c0394f58b7dbda11a4df2d233e86d1.tar.gz
gentoo-82d39affe7c0394f58b7dbda11a4df2d233e86d1.tar.bz2
gentoo-82d39affe7c0394f58b7dbda11a4df2d233e86d1.zip
kde-frameworks: Add KDE Frameworks 5.48
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.48.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 8c78bea2fe8a..4f2a559d668e 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.46.0.tar.xz 1753332 BLAKE2B 8ad4b5009096bcbf63a9b4874a353b84733aeadf577fc175ff17265aacda73ef4be543526ce6977756aba1758e56ebf65a3d66d98246ff3424a1540dcc906522 SHA512 34325df3f56d9e659237cb81bae755e2c4dd5b256d7878bcb3b1d3fdf15c749c5b8e2b590d27f93b6d5d31db73e826f63f988ac8c9544801ccd0591117653e12
DIST frameworkintegration-5.47.0.tar.xz 1753288 BLAKE2B 71072be882ea1f86260ee9394d5ba7f4c0abd4cdbf3b09a2a4ab8a15887f0d981134f8370099aaa9a165378c3638ba14227406ce99f3c19c4c0322a9a30e5c9f SHA512 99682597ebf4167f88eea0b95951fc85a7628a4db6d3c4c5075c6a08ca1cb3ae14561c939be784190455e4412f4778c2952f968778a5cb064a2d3d77928a3940
+DIST frameworkintegration-5.48.0.tar.xz 1753284 BLAKE2B 4a23c8179773702096d0c9bd77c789c6366832660b2dec75c8e30a7f9a3373b897f25583f83a1204eeb212bd5b0a21ad8d711a86f4c3b689b20fbb48a1214f17 SHA512 81029ec6e5536c12566cd36a344747461588de08ef45388ad67b57a8b6ac8a461bfc7f7cbaa162e1369763a0f89b57787f69a68b997285ec2c2d17027d9c1adf
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.48.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.48.0.ebuild
new file mode 100644
index 000000000000..b6c0da034de8
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.48.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_QTHELP="false"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="appstream X"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ appstream? (
+ app-admin/packagekit-qt
+ dev-libs/appstream[qt5]
+ )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_prepare() {
+ punt_bogus_dep Qt5 DBus
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package appstream AppStreamQt)
+ $(cmake-utils_use_find_package appstream packagekitqt5)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}