summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-15 12:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-15 13:58:34 +0100
commitb5f0806e00fadca2d0c9819e9ab46b0d4c2da58f (patch)
tree651d11303c1a4fdb7aae0dd382ce043ffb840404 /kde-frameworks/frameworkintegration
parentapp-emulation/qemu: bump up to 4.2.0, bug #702036 (diff)
downloadgentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.tar.gz
gentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.tar.bz2
gentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.zip
kde-frameworks: Add KDE Frameworks 5.65
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.65.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index a802c998c017..9b3331fd8bac 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1 +1,2 @@
DIST frameworkintegration-5.64.0.tar.xz 1754716 BLAKE2B a9812b62c8973b5286b06388a5a9bb2f65bed49684b72c56696ab8e5ea7a03b24ba9d8b58b210cfbd06d46a695106d81f22b5fbd6440bc68dc639c5385dbce62 SHA512 7288578fcec9c1fe1d768692380acff00267513e0092361b0c0739e669a86ffde1df96f20e0ce91685df440ae7fcd7786d96fc18c1faa00e5e82d7fc9b8d60df
+DIST frameworkintegration-5.65.0.tar.xz 1755240 BLAKE2B d126efbec1e2a18fa49bf279a0cfbf80feed3b263eeb3589fa6e28db8f6e9b1708865c16db85735c73c39f830e69eb8771d51ba19d58bff3b5ac623e75439f47 SHA512 0af9b631e40d44c06661fd671898f102930f2efec9273f9efc1f7b11a16a42e25525e1a5a9c165e9d901cff01b08f36c1ac9845f316368b7f630a06dd32f414e
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.65.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.65.0.ebuild
new file mode 100644
index 000000000000..fe0c4fd45943
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.65.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="appstream X"
+
+# drop qtwidgets subslot operator when QT_MINIMAL >= 5.14.0
+DEPEND="
+ >=kde-frameworks/kconfig-${PVCUT}:5
+ >=kde-frameworks/kconfigwidgets-${PVCUT}:5
+ >=kde-frameworks/ki18n-${PVCUT}:5
+ >=kde-frameworks/kiconthemes-${PVCUT}:5
+ >=kde-frameworks/knewstuff-${PVCUT}:5
+ >=kde-frameworks/knotifications-${PVCUT}:5
+ >=kde-frameworks/kpackage-${PVCUT}:5
+ >=kde-frameworks/kwidgetsaddons-${PVCUT}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5=
+ appstream? (
+ app-admin/packagekit-qt
+ dev-libs/appstream[qt5]
+ )
+ X? (
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libxcb
+ )
+"
+RDEPEND="${DEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_prepare() {
+ ecm_punt_bogus_dep Qt5 DBus
+ ecm_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package appstream AppStreamQt)
+ $(cmake_use_find_package appstream packagekitqt5)
+ $(cmake_use_find_package X XCB)
+ )
+
+ ecm_src_configure
+}