summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-12 10:24:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-12 15:35:00 +0100
commit9f729a3ed257b5878ea19a9bae536e90546dde9d (patch)
tree4cf6fbf0ff3bfc39b541d81b55fb2cfee0a64827 /kde-frameworks/plasma/plasma-5.54.0.ebuild
parentdev-lang/mujs: stabilize v1.0.5 on amd64 (diff)
downloadgentoo-9f729a3ed257b5878ea19a9bae536e90546dde9d.tar.gz
gentoo-9f729a3ed257b5878ea19a9bae536e90546dde9d.tar.bz2
gentoo-9f729a3ed257b5878ea19a9bae536e90546dde9d.zip
kde-frameworks: Add KDE Frameworks 5.54.0
Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/plasma/plasma-5.54.0.ebuild')
-rw-r--r--kde-frameworks/plasma/plasma-5.54.0.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/kde-frameworks/plasma/plasma-5.54.0.ebuild b/kde-frameworks/plasma/plasma-5.54.0.ebuild
new file mode 100644
index 000000000000..f1d6e2255b4b
--- /dev/null
+++ b/kde-frameworks/plasma/plasma-5.54.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KMNAME="${PN}-framework"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma framework"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="gles2 wayland X"
+
+RDEPEND="
+ $(add_frameworks_dep kactivities)
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kirigami)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui 'gles2=')
+ $(add_qt_dep qtquickcontrols)
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ !gles2? ( virtual/opengl )
+ wayland? (
+ $(add_frameworks_dep kwayland)
+ media-libs/mesa[egl]
+ )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}
+ $(add_frameworks_dep kdoctools)
+ X? ( x11-base/xorg-proto )
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package !gles2 OpenGL)
+ $(cmake-utils_use_find_package wayland EGL)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ $(cmake-utils_use_find_package X X11)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}