summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-misc/plasma-emergelog
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-misc/plasma-emergelog')
-rw-r--r--kde-misc/plasma-emergelog/Manifest1
-rw-r--r--kde-misc/plasma-emergelog/files/plasma-emergelog-0.0.2-list.patch21
-rw-r--r--kde-misc/plasma-emergelog/metadata.xml6
-rw-r--r--kde-misc/plasma-emergelog/plasma-emergelog-0.0.2-r1.ebuild34
4 files changed, 62 insertions, 0 deletions
diff --git a/kde-misc/plasma-emergelog/Manifest b/kde-misc/plasma-emergelog/Manifest
new file mode 100644
index 000000000000..61f632e42802
--- /dev/null
+++ b/kde-misc/plasma-emergelog/Manifest
@@ -0,0 +1 @@
+DIST plasma-emergelog-0.0.2.tar.gz 16551 SHA256 8d11ac9652b0e4bb44f148cfcbdce515540efc0285553598b58039b80105e4be SHA512 caac6f65b97ff2de73d2f89f7639f9382f9522c8a7e83012760e0915a37970fb672f37102723ab49bab0ff28c34d4aa8e51fc33546e5dbe3995fbce63e1c37f5 WHIRLPOOL 017b1c19c7a25573b8964a89388c63f5887654272aac683bac39cab0fd9f62d6aede973f3cbf82c203aa28a96f8fb5faf0b31217b46341c09e67a70f405ad4f9
diff --git a/kde-misc/plasma-emergelog/files/plasma-emergelog-0.0.2-list.patch b/kde-misc/plasma-emergelog/files/plasma-emergelog-0.0.2-list.patch
new file mode 100644
index 000000000000..732cde2d7a67
--- /dev/null
+++ b/kde-misc/plasma-emergelog/files/plasma-emergelog-0.0.2-list.patch
@@ -0,0 +1,21 @@
+diff --git plasma-emergelog.cpp plasma-emergelog.cpp
+index 362eaa3..f3e8ea8 100644
+--- old/plasma-emergelog-0.0.2/plasma-emergelog.cpp
++++ new/plasma-emergelog-0.0.2/plasma-emergelog.cpp
+@@ -35,6 +35,7 @@
+ #include "plasma-emergelog-painter.h"
+ #include <exception>
+ #include <iostream>
++#include <cmath>
+
+
+ class myexception: public std::exception
+@@ -167,7 +168,7 @@ void emergelog::process_data(){
+ /* Create a list . Each element is a line from that file */
+ list = data.split('\n', QString::SkipEmptyParts);
+ /* read the block BACKWARDS */
+- for (int i=list.size()-1;i>(list.size()-(document->maximumBlockCount()));i--){
++ for (int i=list.size()-1;i>std::max<int>(0, list.size()-(document->maximumBlockCount()));i--){
+ if(cursor.position() != 0){
+ cursor.insertBlock();
+ }
diff --git a/kde-misc/plasma-emergelog/metadata.xml b/kde-misc/plasma-emergelog/metadata.xml
new file mode 100644
index 000000000000..6222792776c2
--- /dev/null
+++ b/kde-misc/plasma-emergelog/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>
+
diff --git a/kde-misc/plasma-emergelog/plasma-emergelog-0.0.2-r1.ebuild b/kde-misc/plasma-emergelog/plasma-emergelog-0.0.2-r1.ebuild
new file mode 100644
index 000000000000..a420c3b6438d
--- /dev/null
+++ b/kde-misc/plasma-emergelog/plasma-emergelog-0.0.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="KDE4 plasmoid for monitoring emerge progress"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=103928"
+SRC_URI="http://dev.gentooexperimental.org/~hwoarang/projects/plasma-emergelog/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+# Included LICENSE is GPL-2, but all headers say 3+. hwoarang said
+# that it can be licensed as 3+
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug"
+
+RDEPEND="
+ $(add_kdebase_dep plasma-workspace)
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.0.2-list.patch
+)
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+ einfo "You need to add your user to 'portage' group"
+ einfo "in order to use this plasmoid. To do that, use"
+ einfo "the following command:"
+ einfo "usermod -a -G portage <your_user_here>"
+}