summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-26 14:47:15 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-26 15:17:42 +0100
commit920af2f13d32fd57b7fe5e391faae8063ce573ee (patch)
treed85ad3d3f126a0912fecfd4e68e56a6ed9b66819 /kde-plasma/ksshaskpass
parentdev-python/curtsies: clean old versions (diff)
downloadgentoo-920af2f13d32fd57b7fe5e391faae8063ce573ee.tar.gz
gentoo-920af2f13d32fd57b7fe5e391faae8063ce573ee.tar.bz2
gentoo-920af2f13d32fd57b7fe5e391faae8063ce573ee.zip
kde-plasma: Add KDE Plasma 5.15.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.15.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index b82711b08476..47bcde5711c4 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.14.5.tar.xz 21332 BLAKE2B a29b1fc2802925759eaf1b9ff8dec7dd0dddcf67b2093fd6b8a9bccb112264a9f01cbc8b42e707b9782cd3efe9d272ae9ca573e3e084f5a3dfe632d88be52104 SHA512 5517193df92ad868d06bcc8f353bfd38932d0a96d98e6af38d3714478233ea91771cbb7b075e76c133d595812643a0e2fea6a6086be94845a252c215b243b37f
DIST ksshaskpass-5.15.1.tar.xz 21328 BLAKE2B 8e68633d71cfb72ff6beb72174053b95f00fc39d8c847cde9335d7f02c5386afcedce6bc4a495b4a8e46ea439f0c18d6fc866163d80481e536d8c0ef1c0e269c SHA512 ef679b3ee09fbba989e192b64d53591dcfbf302859960bbae29036c5f26a14fb7efd9f54080e76690817edfc7a03b664d90ab4a9f7e3af56872ac84295fcd241
+DIST ksshaskpass-5.15.2.tar.xz 21208 BLAKE2B ca20778495349c7922b12f53400dd54aaaaaa2edbba3f24f34dfa9c77b552baebc409731192759653220a1b3be44a070beb72c934b00ad0a2fcba72d82041075 SHA512 bbb873cd690d98aed1ebfaa882bd28bfa55fff338e9f25af4f83d5de1c295fdf4ac52346ccb0fa9f794e393609cd2b70788189febd68a92bfb21c8f3d491568d
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.15.2.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.15.2.ebuild
new file mode 100644
index 000000000000..dc9bad4320f1
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.15.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}