summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-03-08 13:56:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-03-08 18:15:58 +0100
commit211fc7d5f383d0ae3054b93b08d3d7b7e82fa3a8 (patch)
treee0084240641d1371e1e81b96c6bef3bec59ad7a3 /kde-plasma/kwallet-pam
parentkde-plasma/ksystemstats: 5.24.3 version bump (diff)
downloadgentoo-211fc7d5f383d0ae3054b93b08d3d7b7e82fa3a8.tar.gz
gentoo-211fc7d5f383d0ae3054b93b08d3d7b7e82fa3a8.tar.bz2
gentoo-211fc7d5f383d0ae3054b93b08d3d7b7e82fa3a8.zip
kde-plasma/kwallet-pam: 5.24.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.24.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 8878ab50754b..500ba9b308ff 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.23.5.tar.xz 20128 BLAKE2B 8c6aab56cce55f750981d9bdf2c0b9daf9855d64fd69d406828c426c588f80a042761db795b754f1c0e02d28fd4946f7a26f03d66db029223f2775c3279714b5 SHA512 d7f876c6ede1719fa0d7886fd4f79ff52d8d62b175e52552bbc587ecd5464812eb19c875c51e64ab557af4668446a4b3838b76637555604239f3e314a605d18b
DIST kwallet-pam-5.24.2.tar.xz 20472 BLAKE2B 1c790445c6a8e5407f1a40d6c193e33727618230bd5b36aa7e109c3b8f740431172b1306eac0ff0e1d656df0ab35b66edec86e2920f78f086d89f98d601ff3bb SHA512 fd58ff1f3898fb76c2dc5e9b85fe9dfc73b9820bd96a3281b42aa80ffbd119f6ab0d048fd9ac3454a5a4c83135c585f99ba38c9199fcdf75f85431775ff1d78d
+DIST kwallet-pam-5.24.3.tar.xz 20488 BLAKE2B a5e8eb2d23e454e5a08a821000cf24ebabcf82946811d2d879f39ee03c5f5a4f362c465d08b1d4ff6b069f4fe0659bee05f404604d244d34dc91e7fbd7769564 SHA512 21a66c9ce117843231b6ae24ebe0d2446f69b84b622ca4a79279c8729c8d0acac385153a8befb76fe2ff19dc17f7412634c4b13e15dd8b3c08a2524fcea677db
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.24.3.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.24.3.ebuild
new file mode 100644
index 000000000000..940910a2e750
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.24.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.90.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}