summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-06-17 23:06:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-06-18 16:51:12 +0200
commitd28cf6f2d17e19ec2011857eae9d2134b0cfec79 (patch)
treeba97e276be53da2f0ff80293838dd933ac3aedba /kde-plasma/kwayland
parentkde-plasma/kwallet-pam: 6.1.0 version bump (diff)
downloadgentoo-d28cf6f2d17e19ec2011857eae9d2134b0cfec79.tar.gz
gentoo-d28cf6f2d17e19ec2011857eae9d2134b0cfec79.tar.bz2
gentoo-d28cf6f2d17e19ec2011857eae9d2134b0cfec79.zip
kde-plasma/kwayland: 6.1.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwayland')
-rw-r--r--kde-plasma/kwayland/Manifest1
-rw-r--r--kde-plasma/kwayland/kwayland-6.1.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-plasma/kwayland/Manifest b/kde-plasma/kwayland/Manifest
index 2757180e35fa..4946a47ff402 100644
--- a/kde-plasma/kwayland/Manifest
+++ b/kde-plasma/kwayland/Manifest
@@ -1,2 +1,3 @@
DIST kwayland-5.116.0.tar.xz 337540 BLAKE2B e238af4a122317fde2b207762858fb913005afde60f1b9cf2dfd90163021d8c3d7d9c3b055a4bb3ae26b5d0560e90c9e0d1e1e51480315bf1a5bc5592a231d11 SHA512 48b24c88872a21d237274868fea601120fb9700f888ab0a7531651dc6501db8559af3a70b6131d89d31010e1f32013222d42e9d1244ae91bf9972588494957a9
DIST kwayland-6.0.90.tar.xz 134000 BLAKE2B d6ea6bc231e19f73166788cdbac255ecd8b76a5e7c7ce38f4f24c4b3e9546b131787c382cfc0b2bd298c5adf224398214db78125002e76635a0adb9762e0a470 SHA512 2f83cb29744992925051f62a803a175b871277265faa60ca3f8dd31815175a79077880c10d459b6a38d52ac96182f617c5bdeaa3af3d458786305624a0dc0063
+DIST kwayland-6.1.0.tar.xz 134004 BLAKE2B dcf9b3a8374e40fbcf878bb3ecf6333e7b438bd7792cbf7e61e13f20f6dee60b919dd736f3aaea50633830d4898aa09c27840c1c7f0963982a826e0361ef0827 SHA512 351133a57ffd87560c32e71ea6f14172ad7ea513bc2e7ca8abd3a0b5d92f6ddf7c762501ce7bf57da22e0e269b965c06d5cfd97ff0334cf4ee394d5b2c2f8fec
diff --git a/kde-plasma/kwayland/kwayland-6.1.0.ebuild b/kde-plasma/kwayland/kwayland-6.1.0.ebuild
new file mode 100644
index 000000000000..7b741a079775
--- /dev/null
+++ b/kde-plasma/kwayland/kwayland-6.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=6.3.0
+QTMIN=6.7.1
+inherit ecm flag-o-matic plasma.kde.org
+
+DESCRIPTION="Qt-style API to interact with the wayland-client API"
+HOMEPAGE="https://invent.kde.org/frameworks/kwayland"
+
+LICENSE="LGPL-2.1"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+# All failing, I guess we need a virtual wayland server
+RESTRICT="test"
+
+# slot ops: includes qpa/qplatformnativeinterface.h, surface_p.h
+RDEPEND="
+ >=dev-libs/wayland-1.15.0
+ >=dev-qt/qtbase-${QTMIN}:6=[concurrent,gui,opengl]
+ >=dev-qt/qtwayland-${QTMIN}:6=
+ media-libs/libglvnd
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.13.0
+ >=dev-libs/wayland-protocols-1.15
+ sys-kernel/linux-headers
+"
+BDEPEND="
+ >=dev-qt/qtwayland-${QTMIN}:6
+ >=dev-util/wayland-scanner-1.19.0
+"
+
+src_configure() {
+ filter-lto # bug 866575
+ ecm_src_configure
+}