summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-04-06 21:34:33 +0200
committerJohannes Huber <johu@gentoo.org>2016-04-06 21:43:49 +0200
commit244143483d79122cb433381d37f3f482b747968c (patch)
tree141942602702353f6541470ee960e2c7fc5dd144 /kde-plasma/plasma-sdk
parentprofiles: mask net-libs/libqinfinity for removal (diff)
downloadgentoo-244143483d79122cb433381d37f3f482b747968c.tar.gz
gentoo-244143483d79122cb433381d37f3f482b747968c.tar.bz2
gentoo-244143483d79122cb433381d37f3f482b747968c.zip
kde-plasma: Version bump KDE Plasma 5.6.2
Package-Manager: portage-2.2.28
Diffstat (limited to 'kde-plasma/plasma-sdk')
-rw-r--r--kde-plasma/plasma-sdk/Manifest1
-rw-r--r--kde-plasma/plasma-sdk/plasma-sdk-5.6.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/kde-plasma/plasma-sdk/Manifest b/kde-plasma/plasma-sdk/Manifest
index fb2f8944b912..e3fd866e8d24 100644
--- a/kde-plasma/plasma-sdk/Manifest
+++ b/kde-plasma/plasma-sdk/Manifest
@@ -1,2 +1,3 @@
DIST plasma-sdk-5.5.5.tar.xz 666148 SHA256 a8e99087d41eeedcf9f74de1805035bfb7be21c729156023072d961f2080010c SHA512 a858a09318f53b3f45f9a5a1fd84039b2e6075c80527fbae7e99d9e39623c3a725bc81b9bb76715c255c9075ce20ab31de7e8b3065e0dae326a7d7a0f9243cc4 WHIRLPOOL ce0ae9e8198794b7bd43cfd1d340626dcc543863b84a3027c12f7b1c83f9c2ffa2648326f7fbb64222eb9af7e92db510171b5549868daeec5c55d396c253f3fa
DIST plasma-sdk-5.6.1.tar.xz 702980 SHA256 92282f29b145bcc830e8e5da89d767dff94625e700510b19df7b5ddc76dee391 SHA512 1bf1ba6eabe35af75a4d90382b3e7195db4fd52dbc3adce3a4ac8e4d4e70f290e62339b1a14ed8b91999bf0ca1dc84215f99826ea1364ba1806187d9fc0f026a WHIRLPOOL b63dfba1767483525929f4f36fb9edab7c4d7fdfc642430a43158cde13e73b7253c9066a07ae4fc3e9dcd321bddd42b70862d3efc04d17d09a41e66fbe4ac770
+DIST plasma-sdk-5.6.2.tar.xz 702944 SHA256 a4147b954001267cf7a10e44947cabf900706cf83885699ad84678ee7cc04f8b SHA512 5fbee99000a38e9dd4fa1399caa014beba9684bfc76d912c7ae793be58182507f5e427e6df19647fcb4e48d55c9f74a593e4132c6789e56855f0973c61eb4c76 WHIRLPOOL 596e58067b8ec2dbb1dd67b5f56f7afb97f043eb3398e20fb3f7390990b29675421ed7b17dc412973bace951c05eb9252d70fd7369cf8e297c786d21af7ee964
diff --git a/kde-plasma/plasma-sdk/plasma-sdk-5.6.2.ebuild b/kde-plasma/plasma-sdk/plasma-sdk-5.6.2.ebuild
new file mode 100644
index 000000000000..a6551494bc66
--- /dev/null
+++ b/kde-plasma/plasma-sdk/plasma-sdk-5.6.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Useful applications for Plasma development"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="plasmate"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ plasmate? (
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_qt_dep qtwebkit)
+ dev-util/kdevplatform:5
+ )
+"
+RDEPEND="${DEPEND}
+ !dev-util/plasmate
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.5.5-qtwebkit-optional.patch" # git master
+ "${FILESDIR}/${PN}-5.5.5-dependencies.patch" # RR pending
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package plasmate KDevPlatform)
+ $(cmake-utils_use_find_package plasmate Qt5WebKit)
+ $(cmake-utils_use_find_package plasmate Qt5WebKitWidgets)
+ )
+
+ kde5_src_configure
+}