summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-05 16:22:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-05 18:35:49 +0100
commit2d20b8f1f2d3b117b9060f0a0d152a20c20dcbcc (patch)
treeb58d48d7efdca54403543bb4d947cab54d04bd1d /kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.20.5.ebuild
parentkde-plasma/plasma-sdk: 5.20.5 version bump (diff)
downloadgentoo-2d20b8f1f2d3b117b9060f0a0d152a20c20dcbcc.tar.gz
gentoo-2d20b8f1f2d3b117b9060f0a0d152a20c20dcbcc.tar.bz2
gentoo-2d20b8f1f2d3b117b9060f0a0d152a20c20dcbcc.zip
kde-plasma/plasma-thunderbolt: 5.20.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.20.5.ebuild')
-rw-r--r--kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.20.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.20.5.ebuild b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.20.5.ebuild
new file mode 100644
index 000000000000..69da5b0cc09a
--- /dev/null
+++ b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.20.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="true"
+KFMIN=5.74.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.1
+inherit ecm kde.org
+
+DESCRIPTION="Plasma integration for controlling Thunderbolt devices"
+HOMEPAGE="https://invent.kde.org/plasma/plasma-thunderbolt"
+
+LICENSE="|| ( GPL-2 GPL-3+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ sys-apps/bolt
+"
+
+# tests require DBus
+RESTRICT+=" test"