summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-09-10 17:41:35 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-09-10 18:34:47 +0200
commit2c564f928f15b0e6e826e4dbaceffb7cd6a9e0f3 (patch)
treed166004cf6d700bda0177648c08c6d89c905c9ed /kde-plasma
parentkde-plasma/plasma-welcome: 6.1.5 version bump (diff)
downloadgentoo-2c564f928f15b0e6e826e4dbaceffb7cd6a9e0f3.tar.gz
gentoo-2c564f928f15b0e6e826e4dbaceffb7cd6a9e0f3.tar.bz2
gentoo-2c564f928f15b0e6e826e4dbaceffb7cd6a9e0f3.zip
kde-plasma/plasma-workspace: 6.1.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/plasma-workspace/Manifest1
-rw-r--r--kde-plasma/plasma-workspace/plasma-workspace-6.1.5.ebuild230
2 files changed, 231 insertions, 0 deletions
diff --git a/kde-plasma/plasma-workspace/Manifest b/kde-plasma/plasma-workspace/Manifest
index 7ea9164a81ee..ab8ee02877bf 100644
--- a/kde-plasma/plasma-workspace/Manifest
+++ b/kde-plasma/plasma-workspace/Manifest
@@ -1,2 +1,3 @@
DIST plasma-workspace-5.27.11.1.tar.xz 19490624 BLAKE2B eef62c13407073aea855878b0e8a109b2ea4532e9bffe97903e7163747b56ac01d881d9649c6a4d220a569e6fcaa9e7fb34996c8bb9a3f0abd5f6fa2e73abc47 SHA512 72bb17ba874be28ed15eb8536caa00cf0fb7777ad76728107ea8baa6216c5655a595d1364ec146f4c33b876c239c249bada9f75e3b0604d29de5f06bd327d006
DIST plasma-workspace-6.1.4.tar.xz 19294480 BLAKE2B c0ebf51f6f67f43a09dcffe40fae7114b6234719e56053f36600999e289eb42e5d2ca281da0259fa0c60f5b3a3cfef4a8bb912f48cbf05eefc60fb5bc48193ec SHA512 c7ac27c60e75998e2cc6abb96004ce2abd84b7a7978de4fc256bf06892fca818595e2a5dd505768bcce9be4103ccecbb34d82761c0f7be45a402ca6173e90f05
+DIST plasma-workspace-6.1.5.tar.xz 19305196 BLAKE2B 4eb75be1404d84519fabdb148accbeb48227aebd2fadeee5c27ba37dc158685b8bf9283f41172dff86dbe07ffe47a62097f873e907dd44ada61a53b3dd1f04b8 SHA512 1b68ddb1d287733ec16900a14b56bf1dbdfb9bce0d10666c1a710612dee6cc786629ea0a924627d58f1268a9594e3bfae587d57bcd7c926bf48b8e914c5d9238
diff --git a/kde-plasma/plasma-workspace/plasma-workspace-6.1.5.ebuild b/kde-plasma/plasma-workspace/plasma-workspace-6.1.5.ebuild
new file mode 100644
index 000000000000..9a0e73749591
--- /dev/null
+++ b/kde-plasma/plasma-workspace/plasma-workspace-6.1.5.ebuild
@@ -0,0 +1,230 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="optional"
+ECM_TEST="forceoptional"
+KFMIN=6.5.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.7.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="KDE Plasma workspace"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="appstream +calendar +fontconfig geolocation gps +policykit
+screencast +semantic-desktop systemd telemetry +wallpaper-metadata"
+
+REQUIRED_USE="gps? ( geolocation )"
+RESTRICT="test"
+
+# kde-frameworks/kwindowsystem[X]: Uses KX11Extras
+# slot op: Uses Qt::GuiPrivate for qtx11extras_p.h
+# slot op: various private QtWaylandClient headers
+COMMON_DEPEND="
+ dev-libs/icu:=
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qt5compat-${QTMIN}:6[qml]
+ >=dev-qt/qtbase-${QTMIN}:6=[dbus,gui,libinput,network,sql,widgets,xml]
+ >=dev-qt/qtdeclarative-${QTMIN}:6[widgets]
+ >=dev-qt/qtshadertools-${QTMIN}:6
+ >=dev-qt/qtsvg-${QTMIN}:6
+ >=dev-qt/qtwayland-${QTMIN}:6=
+ >=kde-frameworks/karchive-${KFMIN}:6
+ >=kde-frameworks/kauth-${KFMIN}:6
+ >=kde-frameworks/kbookmarks-${KFMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kcrash-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/kdeclarative-${KFMIN}:6
+ >=kde-frameworks/kded-${KFMIN}:6
+ >=kde-frameworks/kglobalaccel-${KFMIN}:6
+ >=kde-frameworks/kguiaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kidletime-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kitemmodels-${KFMIN}:6
+ >=kde-frameworks/kitemviews-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+ >=kde-frameworks/knewstuff-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/knotifyconfig-${KFMIN}:6
+ >=kde-frameworks/kpackage-${KFMIN}:6
+ >=kde-frameworks/kparts-${KFMIN}:6
+ >=kde-frameworks/krunner-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ >=kde-frameworks/kstatusnotifieritem-${KFMIN}:6
+ >=kde-frameworks/ksvg-${KFMIN}:6
+ >=kde-frameworks/ktexteditor-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/kunitconversion-${KFMIN}:6
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6[X]
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ >=kde-frameworks/prison-${KFMIN}:6[qml]
+ >=kde-frameworks/solid-${KFMIN}:6
+ >=kde-plasma/breeze-${PVCUT}:6
+ >=kde-plasma/kscreenlocker-${PVCUT}:6
+ >=kde-plasma/kwayland-${PVCUT}:6
+ >=kde-plasma/kwin-${PVCUT}:6
+ >=kde-plasma/layer-shell-qt-${PVCUT}:6
+ >=kde-plasma/libkscreen-${PVCUT}:6
+ >=kde-plasma/libksysguard-${PVCUT}:6
+ >=kde-plasma/libplasma-${PVCUT}:6
+ >=kde-plasma/plasma-activities-${PVCUT}:6
+ >=kde-plasma/plasma-activities-stats-${PVCUT}:6
+ >=kde-plasma/plasma5support-${PVCUT}:6
+ media-libs/libcanberra
+ >=media-libs/phonon-4.12.0[qt6(+)]
+ sci-libs/libqalculate:=
+ sys-libs/zlib
+ virtual/libudev:=
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libxcb
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/xcb-util
+ appstream? ( >=dev-libs/appstream-1[qt6] )
+ calendar? ( >=kde-frameworks/kholidays-${KFMIN}:6 )
+ fontconfig? (
+ media-libs/fontconfig
+ x11-libs/libXft
+ x11-libs/xcb-util-image
+ )
+ geolocation? ( >=kde-frameworks/networkmanager-qt-${KFMIN}:6 )
+ gps? ( sci-geosciences/gpsd )
+ policykit? (
+ >=sys-auth/polkit-qt-0.175[qt6(+)]
+ virtual/libcrypt:=
+ )
+ screencast? (
+ >=dev-qt/qtbase-${QTMIN}:6=[opengl]
+ >=kde-plasma/kpipewire-${PVCUT}:6
+ media-libs/libglvnd
+ >=media-video/pipewire-0.3:=
+ x11-libs/libdrm
+ )
+ semantic-desktop? ( >=kde-frameworks/baloo-${KFMIN}:6 )
+ systemd? ( sys-apps/systemd:= )
+ telemetry? ( >=kde-frameworks/kuserfeedback-${KFMIN}:6 )
+ wallpaper-metadata? ( kde-apps/libkexiv2:6 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.13.0
+ dev-libs/qcoro[dbus]
+ >=dev-qt/qtbase-${QTMIN}:6[concurrent]
+ x11-base/xorg-proto
+ fontconfig? ( x11-libs/libXrender )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-plasma/libkworkspace:5
+ !<kde-plasma/plasma-desktop-5.27.0:5
+ !kde-plasma/xembed-sni-proxy:*
+ app-text/iso-codes
+ dev-libs/kirigami-addons:6
+ >=dev-qt/qttools-${QTMIN}:*[qdbus]
+ kde-apps/kio-extras:6
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ >=kde-frameworks/kquickcharts-${KFMIN}:6
+ >=kde-plasma/kactivitymanagerd-${PVCUT}:6
+ >=kde-plasma/kdesu-gui-${PVCUT}:*
+ >=kde-plasma/milou-${PVCUT}:6
+ >=kde-plasma/plasma-integration-${PVCUT}:6
+ sys-apps/dbus
+ x11-apps/xmessage
+ x11-apps/xprop
+ x11-apps/xrdb
+ x11-apps/xsetroot
+ policykit? ( sys-apps/accountsservice )
+"
+BDEPEND="
+ >=dev-qt/qtwayland-${QTMIN}:6
+ >=dev-util/wayland-scanner-1.19.0
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ virtual/pkgconfig
+ test? ( >=dev-qt/qtwayland-${QTMIN}:6[compositor] )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.22.5-krunner-cwd-at-home.patch" # TODO upstream: KDE-bug 432975, bug 767478
+)
+
+src_prepare() {
+ ecm_src_prepare
+
+ # TODO: try to get a build switch upstreamed
+ if ! use screencast; then
+ ecm_punt_bogus_dep KPipeWire
+ sed -e "s/^pkg_check_modules.*PipeWire/#&/" -i CMakeLists.txt || die
+ fi
+
+ # TODO: try to get a build switch upstreamed
+ if use geolocation; then
+ use gps || sed -e "s/^pkg_check_modules.*LIBGPS/#&/" \
+ -i dataengines/geolocation/CMakeLists.txt || die
+ fi
+
+ if ! use policykit; then
+ cmake_run_in kcms cmake_comment_add_subdirectory users
+ fi
+
+ if ! use fontconfig; then
+ ecm_punt_bogus_dep XCB IMAGE
+ sed -e "s/check_X11_lib(Xft)/#&/" -i CMakeLists.txt || die
+ fi
+
+ # TODO: try to get a build switch upstreamed
+ if ! use systemd; then
+ sed -e "s/^pkg_check_modules.*SYSTEMD/#&/" -i CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_X11=ON # TODO: broken upstream, fix it if you can
+ -DGLIBC_LOCALE_GEN=$(usex policykit)
+ $(cmake_use_find_package appstream AppStreamQt)
+ $(cmake_use_find_package calendar KF6Holidays)
+ $(cmake_use_find_package fontconfig Fontconfig)
+ $(cmake_use_find_package geolocation KF6NetworkManagerQt)
+ $(cmake_use_find_package semantic-desktop KF6Baloo)
+ $(cmake_use_find_package telemetry KF6UserFeedback)
+ $(cmake_use_find_package wallpaper-metadata KExiv2Qt6)
+ )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # default startup and shutdown scripts
+ insinto /etc/xdg/plasma-workspace/env
+ doins "${FILESDIR}"/10-agent-startup.sh
+
+ insinto /etc/xdg/plasma-workspace/shutdown
+ doins "${FILESDIR}"/10-agent-shutdown.sh
+ fperms +x /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh
+}
+
+pkg_postinst () {
+ ecm_pkg_postinst
+
+ elog "To enable gpg-agent and/or ssh-agent in Plasma sessions,"
+ elog "edit ${EPREFIX}/etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and ${EPREFIX}/etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+}