summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-02 12:18:27 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-02 18:46:38 +0200
commit8483f7d42d6341298e3c515db3192581f885a329 (patch)
tree1918560337e0469036541053595289be9a2f0a50 /kde-plasma
parentkde-plasma/khotkeys: 5.22.5 version bump (diff)
downloadgentoo-8483f7d42d6341298e3c515db3192581f885a329.tar.gz
gentoo-8483f7d42d6341298e3c515db3192581f885a329.tar.bz2
gentoo-8483f7d42d6341298e3c515db3192581f885a329.zip
kde-plasma/kinfocenter: 5.22.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.22.5.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index 6ed3350ea99e..e294468de2bc 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,3 +1,4 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.21.5.tar.xz 1304704 BLAKE2B e63d261bd57f69f3941c670f7d4e45428959544f15187829a704a240706bc04a65dad4bbfeca32444050abb1a5a8c50ccb9365d261cf71149498d1ca408bb77d SHA512 2becdd6f6be00de309467fee1478bec75bc6fa7d8d233b0a5bc8e6124f780add705d549209c842c3cd621bc8931a8ecdecb5a2902ab369bcd476939580bec41a
DIST kinfocenter-5.22.4.tar.xz 1164096 BLAKE2B ad384dfdf35c237075e2e25ac08eea1fafcfabb3bd28f72a452ff9a770577f416af52564aad9911e4d1282988512889864f20abd7f1a27e15c35f55d9d7a2953 SHA512 cb48dbe47e8d65441ba59fa1617a685218482a13099dc83667a37cfa512e0db2f0dbb954e26055926dede8ec52eebfe60312471b735b3abd1f229c3286979b14
+DIST kinfocenter-5.22.5.tar.xz 1170716 BLAKE2B 8e9cefdb426e9635928aa2b81359acc1e8b2113865b18109fa442efa7cd35684fdf911a39c3ce8a43c31afabced6820d6bac6ce31a5c00eb629f6a8462906a7b SHA512 7eaafde6f9a388e9d4cfe9a8f4057c462bf83f9fecdd39fdd96e05f4c5094c1a116bf66a781bba67721e63e8cfd5a8bfb32fb1906392c2acb70263afaa17c560
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.22.5.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.22.5.ebuild
new file mode 100644
index 000000000000..6a89294f40b2
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.22.5.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.82.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+inherit ecm kde.org optfeature
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://userbase.kde.org/KInfoCenter"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="gles2-only ieee1394 +opengl +pci usb wayland +X"
+
+REQUIRED_USE="opengl? ( X ) wayland? ( || ( opengl gles2-only ) )"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[gles2-only=]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ gles2-only? ( media-libs/mesa[gles2] )
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ media-libs/libglvnd[X?]
+ !gles2-only? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ usb? ( virtual/libusb:1 )
+ wayland? (
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ media-libs/mesa[egl(+)]
+ )
+ X? ( x11-libs/libX11 )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+ >=kde-plasma/systemsettings-${PVCUT}:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package ieee1394 RAW1394)
+ $(cmake_use_find_package pci PCIUTILS)
+ $(cmake_use_find_package usb USB1)
+ $(cmake_use_find_package wayland EGL)
+ $(cmake_use_find_package wayland KF5Wayland)
+ $(cmake_use_find_package X X11)
+ )
+
+ if has_version "dev-qt/qtgui[gles2-only]"; then
+ mycmakeargs+=( $(cmake_use_find_package gles2-only OpenGLES) )
+ else
+ mycmakeargs+=( $(cmake_use_find_package opengl OpenGL) )
+ fi
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "NFS information module" net-fs/nfs-utils
+ optfeature "Samba status information module" net-fs/samba
+ fi
+ ecm_pkg_postinst
+}