summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /lxde-base/lxpanel/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'lxde-base/lxpanel/files')
-rw-r--r--lxde-base/lxpanel/files/lxpanel-0.5.9-sandbox.patch29
-rw-r--r--lxde-base/lxpanel/files/lxpanel-0.7.0-right-click-fix.patch25
2 files changed, 54 insertions, 0 deletions
diff --git a/lxde-base/lxpanel/files/lxpanel-0.5.9-sandbox.patch b/lxde-base/lxpanel/files/lxpanel-0.5.9-sandbox.patch
new file mode 100644
index 000000000000..0f40c185bc6d
--- /dev/null
+++ b/lxde-base/lxpanel/files/lxpanel-0.5.9-sandbox.patch
@@ -0,0 +1,29 @@
+Index: lxpanel-0.5.9/src/plugins/Makefile.am
+===================================================================
+--- lxpanel-0.5.9.orig/src/plugins/Makefile.am
++++ lxpanel-0.5.9/src/plugins/Makefile.am
+@@ -49,6 +49,3 @@ EXTRA_DIST = \
+ icon.xpm
+
+ install-exec-hook:
+- rm -f $(DESTDIR)$(libdir)/lxpanel/plugins/*.la
+- rm -f $(DESTDIR)$(libdir)/lxpanel/plugins/*.a
+- rm -f $(DESTDIR)$(libdir)/lxpanel/plugins/*.
+Index: lxpanel-0.5.9/src/plugins/netstat/Makefile.am
+===================================================================
+--- lxpanel-0.5.9.orig/src/plugins/netstat/Makefile.am
++++ lxpanel-0.5.9/src/plugins/netstat/Makefile.am
+@@ -33,4 +33,3 @@ netstat_la_LDFLAGS = \
+ @LXPANEL_MODULE@
+
+ install-exec-hook:
+- rm -f "$(moduledir)\*.la" *.a
+Index: lxpanel-0.5.9/src/plugins/netstatus/Makefile.am
+===================================================================
+--- lxpanel-0.5.9.orig/src/plugins/netstatus/Makefile.am
++++ lxpanel-0.5.9/src/plugins/netstatus/Makefile.am
+@@ -34,4 +34,3 @@ netstatus_la_LDFLAGS = \
+ $(LXPANEL_MODULE)
+
+ install-exec-hook:
+- rm -f "$(moduledir)\*.la" *.a
diff --git a/lxde-base/lxpanel/files/lxpanel-0.7.0-right-click-fix.patch b/lxde-base/lxpanel/files/lxpanel-0.7.0-right-click-fix.patch
new file mode 100644
index 000000000000..f6325b6f8c3f
--- /dev/null
+++ b/lxde-base/lxpanel/files/lxpanel-0.7.0-right-click-fix.patch
@@ -0,0 +1,25 @@
+From d4943c80cded6325284be8b58003fe63dd6e8255 Mon Sep 17 00:00:00 2001
+From: Raimar <no@email.de>
+Date: Thu, 21 Aug 2014 23:21:28 +0200
+Subject: [PATCH 1/1] fix crash after click on empty part of panel
+
+---
+ src/panel.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/panel.c b/src/panel.c
+index 6b2ede6..87903d8 100644
+--- a/src/panel.c
++++ b/src/panel.c
+@@ -233,7 +233,7 @@ static gboolean lxpanel_button_press(GtkWidget *widget, GdkEventButton *event)
+ gtk_menu_popup(popup, NULL, NULL, NULL, NULL, event->button, event->time);
+ return TRUE;
+ }
+- return GTK_WIDGET_CLASS(lxpanel_parent_class)->button_press_event(widget, event);
++ return FALSE;
+ }
+
+ static void lxpanel_class_init(PanelToplevelClass *klass)
+--
+1.7.10.4
+