summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-15 16:21:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-15 16:23:35 +0100
commitf9cd603681a70a781b34e96804b10d34d5e084f4 (patch)
tree1b0e6453624b0a98bf4dec614e6f5b5b531fe9b9 /lxde-base/lxterminal/lxterminal-0.4.0.ebuild
parentx11-misc/openbox-menu: Switch to GTK3 (diff)
downloadgentoo-f9cd603681a70a781b34e96804b10d34d5e084f4.tar.gz
gentoo-f9cd603681a70a781b34e96804b10d34d5e084f4.tar.bz2
gentoo-f9cd603681a70a781b34e96804b10d34d5e084f4.zip
lxde-base/lxterminal: 0.4.0 version bump
See also: https://github.com/gentoo/gentoo/pull/19925 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'lxde-base/lxterminal/lxterminal-0.4.0.ebuild')
-rw-r--r--lxde-base/lxterminal/lxterminal-0.4.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/lxde-base/lxterminal/lxterminal-0.4.0.ebuild b/lxde-base/lxterminal/lxterminal-0.4.0.ebuild
new file mode 100644
index 000000000000..50c4a08d1e48
--- /dev/null
+++ b/lxde-base/lxterminal/lxterminal-0.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg
+
+DESCRIPTION="Lightweight vte-based tabbed terminal emulator for LXDE"
+HOMEPAGE="https://wiki.lxde.org/en/LXTerminal"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/pango
+ x11-libs/vte:2.91
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-util/intltool-0.40.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-man --enable-gtk3
+}