summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-client/thunderbird/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-client/thunderbird/files')
-rw-r--r--mail-client/thunderbird/files/enigmail-1.6.0-parallel-fix.patch38
-rw-r--r--mail-client/thunderbird/files/icon/thunderbird-unbranded.desktop9
-rw-r--r--mail-client/thunderbird/files/icon/thunderbird.desktop9
-rw-r--r--mail-client/thunderbird/files/thunderbird-31.7.0-gcc5-1.patch242
-rw-r--r--mail-client/thunderbird/files/thunderbird-gentoo-default-prefs-1.js-19
5 files changed, 307 insertions, 0 deletions
diff --git a/mail-client/thunderbird/files/enigmail-1.6.0-parallel-fix.patch b/mail-client/thunderbird/files/enigmail-1.6.0-parallel-fix.patch
new file mode 100644
index 000000000000..ab4b613c364b
--- /dev/null
+++ b/mail-client/thunderbird/files/enigmail-1.6.0-parallel-fix.patch
@@ -0,0 +1,38 @@
+commit dd4ad2eebd36c84307222ca56c10c073527d7054
+Author: Patrick Brunschwig <patrick@enigmail.net>
+Date: Sun Nov 24 19:06:23 2013 +0100
+
+ fixed broken parallel full build of TB (patch by Fabio Rossi)
+
+diff --git a/lang/Makefile.in b/lang/Makefile.in
+index 2334d4f..38688e0 100644
+--- a/lang/Makefile.in
++++ b/lang/Makefile.in
+@@ -16,12 +16,12 @@ include $(topsrcdir)/config/config.mk
+
+ include $(srcdir)/../util/build.mk
+
+-all: export jar
++all: jar
+
+ export:
+ $(PERL) $(srcdir)/make-lang-xpi.pl $(srcdir)/current-languages.txt $(srcdir)
+
+-jar:
++jar: export
+ $(MAKEJAR)
+
+ clean:
+diff --git a/ui/Makefile.in b/ui/Makefile.in
+index 6309525..13c98ee 100644
+--- a/ui/Makefile.in
++++ b/ui/Makefile.in
+@@ -28,7 +28,7 @@ include $(topsrcdir)/config/config.mk
+
+ include $(srcdir)/../util/build.mk
+
+-jar:
++jar: dirs
+ $(MAKEJAR)
+
+ clean:
diff --git a/mail-client/thunderbird/files/icon/thunderbird-unbranded.desktop b/mail-client/thunderbird/files/icon/thunderbird-unbranded.desktop
new file mode 100644
index 000000000000..f9d87bef2ffd
--- /dev/null
+++ b/mail-client/thunderbird/files/icon/thunderbird-unbranded.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Mozilla Thunderbird
+Comment=Mail & News Reader
+Exec=/usr/bin/thunderbird %u
+Icon=thunderbird-icon-unbranded
+Terminal=false
+Type=Application
+Categories=Office;Network;Email;
+MimeType=x-scheme-handler/mailto;
diff --git a/mail-client/thunderbird/files/icon/thunderbird.desktop b/mail-client/thunderbird/files/icon/thunderbird.desktop
new file mode 100644
index 000000000000..f9c31eba37b2
--- /dev/null
+++ b/mail-client/thunderbird/files/icon/thunderbird.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Mozilla Thunderbird
+Comment=Mail & News Reader
+Exec=/usr/bin/thunderbird %u
+Icon=thunderbird-icon
+Terminal=false
+Type=Application
+Categories=Office;Network;Email;
+MimeType=x-scheme-handler/mailto;
diff --git a/mail-client/thunderbird/files/thunderbird-31.7.0-gcc5-1.patch b/mail-client/thunderbird/files/thunderbird-31.7.0-gcc5-1.patch
new file mode 100644
index 000000000000..7723b81488a4
--- /dev/null
+++ b/mail-client/thunderbird/files/thunderbird-31.7.0-gcc5-1.patch
@@ -0,0 +1,242 @@
+Submitted By: Fernando de Oliveira <famobr at yahoo dot com dot br>
+Date: 2015-05-17
+Initial Package Version: 31.7.0
+Upstream Status: Unknown
+Origin: Upstream, self
+URL: URL=https://bug1024492.bugzilla.mozilla.org/attachment.cgi?id=8439834&action=diff&context=patch&format=raw&headers=1
+Description: Fix building with gcc5
+
+diff -Nur comm-esr31.orig/mozilla/js/src/builtin/TypedObject.cpp comm-esr31/mozilla/js/src/builtin/TypedObject.cpp
+--- comm-esr31.orig/mozilla/js/src/builtin/TypedObject.cpp 2015-05-07 15:53:49.000000000 -0300
++++ comm-esr31/mozilla/js/src/builtin/TypedObject.cpp 2015-05-17 09:38:36.550714030 -0300
+@@ -710,12 +710,12 @@
+ contents.append(")");
+ RootedAtom stringRepr(cx, contents.finishAtom());
+ if (!stringRepr)
+- return nullptr;
++ return false;
+
+ // Extract ArrayType.prototype
+ RootedObject arrayTypePrototype(cx, GetPrototype(cx, arrayTypeGlobal));
+ if (!arrayTypePrototype)
+- return nullptr;
++ return false;
+
+ // Create the instance of ArrayType
+ Rooted<UnsizedArrayTypeDescr*> obj(cx);
+@@ -728,7 +728,7 @@
+ if (!JSObject::defineProperty(cx, obj, cx->names().length,
+ UndefinedHandleValue, nullptr, nullptr,
+ JSPROP_READONLY | JSPROP_PERMANENT))
+- return nullptr;
++ return false;
+
+ args.rval().setObject(*obj);
+ return true;
+@@ -762,7 +762,7 @@
+ if (!size.isValid()) {
+ JS_ReportErrorNumber(cx, js_GetErrorMessage, nullptr,
+ JSMSG_TYPEDOBJECT_TOO_BIG);
+- return nullptr;
++ return false;
+ }
+
+ // Construct a canonical string `new ArrayType(<elementType>).dimension(N)`:
+@@ -775,7 +775,7 @@
+ contents.append(")");
+ RootedAtom stringRepr(cx, contents.finishAtom());
+ if (!stringRepr)
+- return nullptr;
++ return false;
+
+ // Create the sized type object.
+ Rooted<SizedArrayTypeDescr*> obj(cx);
+@@ -793,7 +793,7 @@
+ if (!JSObject::defineProperty(cx, obj, cx->names().length,
+ lengthVal, nullptr, nullptr,
+ JSPROP_READONLY | JSPROP_PERMANENT))
+- return nullptr;
++ return false;
+
+ // Add `unsized` property, which is a link from the sized
+ // array to the unsized array.
+@@ -801,7 +801,7 @@
+ if (!JSObject::defineProperty(cx, obj, cx->names().unsized,
+ unsizedTypeDescrValue, nullptr, nullptr,
+ JSPROP_READONLY | JSPROP_PERMANENT))
+- return nullptr;
++ return false;
+
+ args.rval().setObject(*obj);
+ return true;
+@@ -1253,7 +1253,7 @@
+ Rooted<TypedProto*> proto(cx);
+ proto = NewObjectWithProto<TypedProto>(cx, objProto, nullptr, TenuredObject);
+ if (!proto)
+- return nullptr;
++ return false;
+ proto->initTypeDescrSlot(*descr);
+ descr->initReservedSlot(JS_DESCR_SLOT_TYPROTO, ObjectValue(*proto));
+
+@@ -1358,14 +1358,14 @@
+ #define BINARYDATA_SCALAR_DEFINE(constant_, type_, name_) \
+ if (!DefineSimpleTypeDescr<ScalarTypeDescr>(cx, global, module, constant_, \
+ cx->names().name_)) \
+- return nullptr;
++ return false;
+ JS_FOR_EACH_SCALAR_TYPE_REPR(BINARYDATA_SCALAR_DEFINE)
+ #undef BINARYDATA_SCALAR_DEFINE
+
+ #define BINARYDATA_REFERENCE_DEFINE(constant_, type_, name_) \
+ if (!DefineSimpleTypeDescr<ReferenceTypeDescr>(cx, global, module, constant_, \
+ cx->names().name_)) \
+- return nullptr;
++ return false;
+ JS_FOR_EACH_REFERENCE_TYPE_REPR(BINARYDATA_REFERENCE_DEFINE)
+ #undef BINARYDATA_REFERENCE_DEFINE
+
+@@ -1375,14 +1375,14 @@
+ arrayType = DefineMetaTypeDescr<ArrayMetaTypeDescr>(
+ cx, global, module, TypedObjectModuleObject::ArrayTypePrototype);
+ if (!arrayType)
+- return nullptr;
++ return false;
+
+ RootedValue arrayTypeValue(cx, ObjectValue(*arrayType));
+ if (!JSObject::defineProperty(cx, module, cx->names().ArrayType,
+ arrayTypeValue,
+ nullptr, nullptr,
+ JSPROP_READONLY | JSPROP_PERMANENT))
+- return nullptr;
++ return false;
+
+ // StructType.
+
+@@ -1390,14 +1390,14 @@
+ structType = DefineMetaTypeDescr<StructMetaTypeDescr>(
+ cx, global, module, TypedObjectModuleObject::StructTypePrototype);
+ if (!structType)
+- return nullptr;
++ return false;
+
+ RootedValue structTypeValue(cx, ObjectValue(*structType));
+ if (!JSObject::defineProperty(cx, module, cx->names().StructType,
+ structTypeValue,
+ nullptr, nullptr,
+ JSPROP_READONLY | JSPROP_PERMANENT))
+- return nullptr;
++ return false;
+
+ // Everything is setup, install module on the global object:
+ RootedValue moduleValue(cx, ObjectValue(*module));
+@@ -1407,7 +1407,7 @@
+ nullptr, nullptr,
+ 0))
+ {
+- return nullptr;
++ return false;
+ }
+
+ return module;
+@@ -2466,7 +2466,7 @@
+ if (length < 0) {
+ JS_ReportErrorNumber(cx, js_GetErrorMessage,
+ nullptr, JSMSG_TYPEDOBJECT_BAD_ARGS);
+- return nullptr;
++ return false;
+ }
+ Rooted<TypedObject*> obj(cx, createZeroed(cx, callee, length));
+ if (!obj)
+diff -Nur comm-esr31.orig/mozilla/js/src/frontend/BytecodeCompiler.cpp comm-esr31/mozilla/js/src/frontend/BytecodeCompiler.cpp
+--- comm-esr31.orig/mozilla/js/src/frontend/BytecodeCompiler.cpp 2015-05-07 15:53:49.000000000 -0300
++++ comm-esr31/mozilla/js/src/frontend/BytecodeCompiler.cpp 2015-05-17 09:39:00.183186652 -0300
+@@ -544,7 +544,7 @@
+
+ RootedScriptSource sourceObject(cx, CreateScriptSourceObject(cx, options));
+ if (!sourceObject)
+- return nullptr;
++ return false;
+ ScriptSource* ss = sourceObject->source();
+
+ SourceCompressionTask sct(cx);
+diff -Nur comm-esr31.orig/mozilla/js/src/vm/ScopeObject.h comm-esr31/mozilla/js/src/vm/ScopeObject.h
+--- comm-esr31.orig/mozilla/js/src/vm/ScopeObject.h 2015-05-07 15:53:56.000000000 -0300
++++ comm-esr31/mozilla/js/src/vm/ScopeObject.h 2015-05-17 09:53:20.202966820 -0300
+@@ -63,21 +63,9 @@
+ bool onNamedLambda;
+
+ public:
+- StaticScopeIter(ExclusiveContext* cx, JSObject* obj)
+- : obj(cx, obj), onNamedLambda(false)
+- {
+- JS_STATIC_ASSERT(allowGC == CanGC);
+- JS_ASSERT_IF(obj, obj->is<StaticBlockObject>() || obj->is<StaticWithObject>() ||
+- obj->is<JSFunction>());
+- }
++ StaticScopeIter(ExclusiveContext *cx, JSObject *obj);
+
+- StaticScopeIter(JSObject* obj)
+- : obj((ExclusiveContext*) nullptr, obj), onNamedLambda(false)
+- {
+- JS_STATIC_ASSERT(allowGC == NoGC);
+- JS_ASSERT_IF(obj, obj->is<StaticBlockObject>() || obj->is<StaticWithObject>() ||
+- obj->is<JSFunction>());
+- }
++ explicit StaticScopeIter(JSObject *obj);
+
+ bool done() const;
+ void operator++(int);
+diff -Nur comm-esr31.orig/mozilla/js/src/vm/ScopeObject-inl.h comm-esr31/mozilla/js/src/vm/ScopeObject-inl.h
+--- comm-esr31.orig/mozilla/js/src/vm/ScopeObject-inl.h 2015-05-07 15:53:56.000000000 -0300
++++ comm-esr31/mozilla/js/src/vm/ScopeObject-inl.h 2015-05-17 09:51:33.939344362 -0300
+@@ -13,6 +13,26 @@
+
+ namespace js {
+
++template <AllowGC allowGC>
++inline
++StaticScopeIter<allowGC>::StaticScopeIter(ExclusiveContext *cx, JSObject *obj)
++ : obj(cx, obj), onNamedLambda(false)
++{
++ JS_STATIC_ASSERT(allowGC == CanGC);
++ JS_ASSERT_IF(obj, obj->is<StaticBlockObject>() || obj->is<StaticWithObject>() ||
++ obj->is<JSFunction>());
++}
++
++template <AllowGC allowGC>
++inline
++StaticScopeIter<allowGC>::StaticScopeIter(JSObject *obj)
++ : obj((ExclusiveContext *) nullptr, obj), onNamedLambda(false)
++{
++ JS_STATIC_ASSERT(allowGC == NoGC);
++ JS_ASSERT_IF(obj, obj->is<StaticBlockObject>() || obj->is<StaticWithObject>() ||
++ obj->is<JSFunction>());
++}
++
+ inline void
+ ScopeObject::setAliasedVar(JSContext* cx, ScopeCoordinate sc, PropertyName* name, const Value& v)
+ {
+diff -Naur comm-esr31.orig/mozilla/netwerk/ipc/NeckoParent.cpp porg-build-2015.05.17-10h30m39s/comm-esr31/mozilla/netwerk/ipc/NeckoParent.cpp
+--- comm-esr31.orig/mozilla/netwerk/ipc/NeckoParent.cpp 2015-05-07 15:53:46.000000000 -0300
++++ porg-build-2015.05.17-10h30m39s/comm-esr31/mozilla/netwerk/ipc/NeckoParent.cpp 2015-05-17 10:51:24.013181648 -0300
+@@ -359,7 +359,7 @@
+ RtspChannelParent* p = static_cast<RtspChannelParent*>(aActor);
+ return p->Init(aConnectArgs);
+ #else
+- return nullptr;
++ return false;
+ #endif
+ }
+
+diff -Naur comm-esr31.orig/mozilla/js/xpconnect/wrappers/XrayWrapper.cpp comm-esr31/mozilla/js/xpconnect/wrappers/XrayWrapper.cpp
+--- comm-esr31.orig/mozilla/js/xpconnect/wrappers/XrayWrapper.cpp 2015-05-07 15:53:42.000000000 -0300
++++ comm-esr31/mozilla/js/xpconnect/wrappers/XrayWrapper.cpp 2015-05-17 11:22:59.442942469 -0300
+@@ -351,7 +351,7 @@
+ {
+ JSAutoCompartment ac(cx, target);
+ if (!JS_GetClassPrototype(cx, key, protop))
+- return nullptr;
++ return false;
+ }
+ return JS_WrapObject(cx, protop);
+ }
diff --git a/mail-client/thunderbird/files/thunderbird-gentoo-default-prefs-1.js-1 b/mail-client/thunderbird/files/thunderbird-gentoo-default-prefs-1.js-1
new file mode 100644
index 000000000000..97c5fd09b8a6
--- /dev/null
+++ b/mail-client/thunderbird/files/thunderbird-gentoo-default-prefs-1.js-1
@@ -0,0 +1,9 @@
+pref("app.update.enabled", false);
+pref("app.update.autoInstallEnabled", false);
+pref("browser.display.use_system_colors", true);
+pref("intl.locale.matchOS", true);
+pref("general.useragent.locale", "chrome://global/locale/intl.properties");
+pref("mail.shell.checkDefaultClient", false);
+# Do not switch to Smart Folders after upgrade to 3.0b4
+pref("mail.folder.views.version", "1");
+pref("extensions.autoDisableScopes", 0);