summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2025-01-26 14:05:31 +0100
committerYixun Lan <dlan@gentoo.org>2025-02-08 10:08:42 +0800
commitc50e1538afd5f9a98c6519c678b12c45a5f76a72 (patch)
tree2ccc865dc9aee1442ffa9028e3a623fc8116721d /mail-client
parentsci-mathematics/4ti2: add 1.6.10 (diff)
downloadgentoo-c50e1538afd5f9a98c6519c678b12c45a5f76a72.tar.gz
gentoo-c50e1538afd5f9a98c6519c678b12c45a5f76a72.tar.bz2
gentoo-c50e1538afd5f9a98c6519c678b12c45a5f76a72.zip
mail-client/alpine: fix eautoreconf with gettext-0.23
Closes: https://bugs.gentoo.org/946128 Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/alpine/alpine-2.26-r5.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/mail-client/alpine/alpine-2.26-r5.ebuild b/mail-client/alpine/alpine-2.26-r5.ebuild
index ebbe665ab898..4c869a5ce45b 100644
--- a/mail-client/alpine/alpine-2.26-r5.ebuild
+++ b/mail-client/alpine/alpine-2.26-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -34,6 +34,12 @@ src_prepare() {
# optional extra features, see https://alpineapp.email/alpine/index.html
use chappa && eapply "${WORKDIR}/${P}-patches/chappa-rebased.patch"
+ # fix gettext macros to work with >=0.23 (bug #946128)
+ # eautoreconf will call autopoint, which will install any necessary files
+ # from the version we set in configure.ac
+ local gettext_version=$(gettextize --version | awk '/GNU gettext-tools/{print $NF}' || die)
+ sed -i "s/^AM_GNU_GETTEXT_VERSION(.*)/AM_GNU_GETTEXT_VERSION([${gettext_version}])/g" configure.ac || die
+
eautoreconf
tc-export CC RANLIB AR
export CC_FOR_BUILD="$(tc-getBUILD_CC)"