summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-filter/anomy-sanitizer/anomy-sanitizer-1.76-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-filter/anomy-sanitizer/anomy-sanitizer-1.76-r1.ebuild')
-rw-r--r--mail-filter/anomy-sanitizer/anomy-sanitizer-1.76-r1.ebuild107
1 files changed, 107 insertions, 0 deletions
diff --git a/mail-filter/anomy-sanitizer/anomy-sanitizer-1.76-r1.ebuild b/mail-filter/anomy-sanitizer/anomy-sanitizer-1.76-r1.ebuild
new file mode 100644
index 000000000000..950c1b71343e
--- /dev/null
+++ b/mail-filter/anomy-sanitizer/anomy-sanitizer-1.76-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils user
+
+DESCRIPTION="Perl based e-mail filtering tool, sensitive to html tags, mime types and attachments"
+HOMEPAGE="http://mailtools.anomy.net/"
+SRC_URI="
+ http://dev.gentoo.org/~jlec/distfiles/sample_e-mail-architecture.png.tar
+ http://mailtools.anomy.net/dist/${PN}-${PV}.tar.gz
+ http://dev.gentoo.org/~pacho/maintainer-needed/sample_e-mail-architektur.flw"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ >=virtual/perl-MIME-Base64-2.12-r2
+ >=dev-perl/Mail-Audit-2.1-r1
+ dev-perl/Convert-TNEF
+ dev-perl/MIME-tools
+ dev-perl/libwww-perl
+ virtual/mta"
+
+S="${WORKDIR}/anomy"
+DEST="/usr/share/${PN}"
+SANI_WORKDIR="/var/spool/sanitizer"
+SANI_CONFDIR="/etc/mail/${PN}"
+
+src_install() {
+ dodoc *.sanitizer CREDITS UNICODE.TXT
+ dohtml sanitizer.html
+ rm -rf "${S}/contrib/.tmp"
+ rm -f *.sanitizer CREDITS UNICODE.TXT sanitizer.html
+ mv "${S}/contrib" "${D}/usr/share/doc/${PF}/"
+
+ insinto /usr/share/doc/${PF}/examples
+ doins "${FILESDIR}"/*.sh "${WORKDIR}"/*.png "${DISTDIR}"/*.flw
+
+ keepdir ${SANI_CONFDIR}
+ insinto ${SANI_CONFDIR}
+ doins "${FILESDIR}"/*.conf
+
+ keepdir ${SANI_WORKDIR}
+ dodir ${DEST}
+ insinto ${DEST}
+
+# generate lists for doins
+ _list="anomy anomy/bin anomy/bin/Anomy anomy/bin/Anomy/Sanitizer anomy/testcases anomy/testcases/results.def"
+
+ for i in $_list; do
+ _di=`echo $i | sed -e "s/^anomy//g; s/^\///g"` &>/dev/null
+ insinto ${DEST}/$_di
+
+ _sublist=`find "${WORKDIR}"/$i/* -maxdepth 0 -type f`
+ for l in $_sublist; do
+ echo &>/dev/null
+ doins $l
+ done
+ done
+
+ dosym ${SANI_CONFDIR}/anomy.conf ${DEST}/anomy.conf
+}
+
+pkg_preinst() {
+ enewgroup sanitizer
+ enewuser sanitizer -1 -1 ${SANI_WORKDIR} sanitizer
+}
+
+pkg_postinst() {
+ chown -R sanitizer:sanitizer "${ROOT}"/${SANI_WORKDIR}
+ chmod -R a-rwx,g+X,u+rwX "${ROOT}"/${SANI_WORKDIR}
+ chown -R sanitizer:sanitizer "${ROOT}"/${DEST}
+ chmod -R a-rwx,g+rX,u+rX "${ROOT}"/${DEST}
+ chown sanitizer:sanitizer "${ROOT}"/${SANI_CONFDIR}/anomy.conf
+ chmod 0640 "${ROOT}"/${SANI_CONFDIR}/anomy.conf
+ chmod u+x "${ROOT}"/${DEST}/bin/*.pl
+ chmod u+x "${ROOT}"/${DEST}/testcases/*.sh
+ chmod u+w "${ROOT}"/${DEST}/*
+ chmod u+w "${ROOT}"/${DEST}/bin
+ chmod u+w "${ROOT}"/${DEST}/bin/Anomy
+ chmod u+w "${ROOT}"/${DEST}/bin/Anomy/Sanitizer
+ chmod u+w "${ROOT}"/${DEST}/testcases
+ chmod u+w "${ROOT}"/${DEST}/testcases/results.def
+
+ elog ""
+ elog "There is a howto for the integration of sanitizer"
+ elog "into your (postfix) mail system at"
+ elog "http://advosys.ca/papers/postfix-filtering.html"
+ elog "Please find example scripts to be used to integrate sanitizer"
+ elog "into your (postfix) mail system at"
+ elog "/usr/share/doc/${PF}/examples"
+ elog "There is also a png and kivio document about a possible"
+ elog "e-mail architecture"
+ elog ""
+
+}
+
+pkg_postrm() {
+ elog "After unmerging this ebuild, you will have to remove"
+ elog "created user and group manually. To do so, run:"
+ elog "userdel -r sanitizer; groupdel sanitizer"
+}