summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-16 00:00:45 +0100
committerSam James <sam@gentoo.org>2022-08-16 00:00:45 +0100
commitaed1a61d6f82c8237eed41fb9825bbf9510c92d6 (patch)
tree9b27da4fb259ccdf20ec80169444e9b6be47b56f /mail-filter/postsrsd/postsrsd-1.12.ebuild
parentapp-arch/xar: Stabilize 1.8.0.0.487.100.1 x86, #865131 (diff)
downloadgentoo-aed1a61d6f82c8237eed41fb9825bbf9510c92d6.tar.gz
gentoo-aed1a61d6f82c8237eed41fb9825bbf9510c92d6.tar.bz2
gentoo-aed1a61d6f82c8237eed41fb9825bbf9510c92d6.zip
mail-filter/postsrsd: add 1.12
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mail-filter/postsrsd/postsrsd-1.12.ebuild')
-rw-r--r--mail-filter/postsrsd/postsrsd-1.12.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/mail-filter/postsrsd/postsrsd-1.12.ebuild b/mail-filter/postsrsd/postsrsd-1.12.ebuild
new file mode 100644
index 000000000000..f0e2b1145da9
--- /dev/null
+++ b/mail-filter/postsrsd/postsrsd-1.12.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake systemd
+
+DESCRIPTION="Postfix Sender Rewriting Scheme daemon"
+HOMEPAGE="https://github.com/roehling/postsrsd"
+SRC_URI="https://github.com/roehling/postsrsd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="sys-apps/help2man"
+
+CHROOT_DIR="${EPREFIX}/var/lib/postsrsd"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCHROOT_DIR="${CHROOT_DIR}"
+
+ # This doesn't affect functionality on OpenRC, it just
+ # forces the build system to install the systemd units.
+ -DINIT_FLAVOR="systemd"
+ -DSYSD_UNIT_DIR="$(systemd_get_systemunitdir)"
+
+ -DDOC_DIR="${EPREFIX}"/usr/share/doc/${PF}
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ newinitd "${FILESDIR}"/postsrsd.init-r2 postsrsd
+ newconfd "${BUILD_DIR}"/postsrsd.default postsrsd
+ keepdir "${CHROOT_DIR}"
+}