summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2024-06-02 19:18:49 -0400
committerSam James <sam@gentoo.org>2024-06-03 02:31:01 +0100
commitef3433e77824185dca2aff5a495d8611d28a3179 (patch)
treedf4071e7c905ddcc9de084140263d8862d70565a /mail-filter
parentdev-libs/boost: fix aliasing violation in boost::container (diff)
downloadgentoo-ef3433e77824185dca2aff5a495d8611d28a3179.tar.gz
gentoo-ef3433e77824185dca2aff5a495d8611d28a3179.tar.bz2
gentoo-ef3433e77824185dca2aff5a495d8611d28a3179.zip
mail-filter/spamassassin: Fix sa_txrep test when no dbm
Upstream's fix is way more involved. I'll leave that for 4.0.2, I guess. https://github.com/apache/spamassassin/commit/1c6fe5993ce48099aa73eb1d87419f50f922a0a6 Closes: https://bugs.gentoo.org/933406 Closes: https://github.com/gentoo/gentoo/pull/36986 Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/spamassassin/files/4.0.1-tests-sa_txrep.t-no-dbm.patch16
-rw-r--r--mail-filter/spamassassin/spamassassin-4.0.1.ebuild1
2 files changed, 17 insertions, 0 deletions
diff --git a/mail-filter/spamassassin/files/4.0.1-tests-sa_txrep.t-no-dbm.patch b/mail-filter/spamassassin/files/4.0.1-tests-sa_txrep.t-no-dbm.patch
new file mode 100644
index 000000000000..6d6b4dd9a024
--- /dev/null
+++ b/mail-filter/spamassassin/files/4.0.1-tests-sa_txrep.t-no-dbm.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/933406
+--- a/t/sa_txrep.t
++++ b/t/sa_txrep.t
+@@ -4,7 +4,11 @@ use lib '.'; use lib 't';
+ use SATest; sa_t_init("sa_txrep");
+
+
+-use Test::More tests => 8;
++use Test::More;
++
++my @dbmods = grep eval "require $_", ('DB_File', 'GDBM_File', 'SDBM_File');
++plan skip_all => "No db module is available" unless @dbmods;
++plan tests => 8;
+
+ # ---------------------------------------------------------------------------
+
diff --git a/mail-filter/spamassassin/spamassassin-4.0.1.ebuild b/mail-filter/spamassassin/spamassassin-4.0.1.ebuild
index d778722d02cc..4e04f9b1ff8d 100644
--- a/mail-filter/spamassassin/spamassassin-4.0.1.ebuild
+++ b/mail-filter/spamassassin/spamassassin-4.0.1.ebuild
@@ -91,6 +91,7 @@ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/spamassassin.apache.org.asc
PATCHES=(
"${FILESDIR}/mention-geoip.cf-in-init.pre.patch"
"${FILESDIR}/4.0.0-tests-dnsbl_subtests.t_001_load-URIDNSBL.patch"
+ "${FILESDIR}/4.0.1-tests-sa_txrep.t-no-dbm.patch"
)
# There are a few renames and use-dependent ones in src_install as well.