summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-01-06 04:14:40 +0000
committerSam James <sam@gentoo.org>2025-01-06 04:15:50 +0000
commit659e9d57f19c606bec9bc7ba69c956c4abf80ddd (patch)
treea26c3fa9c64deda18a353de3d2f206560c42d1d0 /mail-mta/proton-mail-bridge
parentsys-devel/bc: add 1.08.1 (diff)
downloadgentoo-659e9d57f19c606bec9bc7ba69c956c4abf80ddd.tar.gz
gentoo-659e9d57f19c606bec9bc7ba69c956c4abf80ddd.tar.bz2
gentoo-659e9d57f19c606bec9bc7ba69c956c4abf80ddd.zip
mail-mta/proton-mail-bridge: fix src_test
The test change was wrong. Tests are restricted but if you unrestrict, the default doesn't work, because it uses cmake_src_test which finds nothing. Need to keep the explicit emake test call to use the test target from the Makefile instead. Also, use -Onone because of what the targets in the Makefile do here to avoid no output for long stretches of the build. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mail-mta/proton-mail-bridge')
-rw-r--r--mail-mta/proton-mail-bridge/proton-mail-bridge-3.15.1-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/mail-mta/proton-mail-bridge/proton-mail-bridge-3.15.1-r1.ebuild b/mail-mta/proton-mail-bridge/proton-mail-bridge-3.15.1-r1.ebuild
index f7c426050794..09ece2bf26ab 100644
--- a/mail-mta/proton-mail-bridge/proton-mail-bridge-3.15.1-r1.ebuild
+++ b/mail-mta/proton-mail-bridge/proton-mail-bridge-3.15.1-r1.ebuild
@@ -85,7 +85,7 @@ src_configure() {
}
src_compile() {
- emake build-nogui
+ emake -Onone build-nogui
if use gui; then
BUILD_DIR="${WORKDIR}"/gui_build \
@@ -94,6 +94,10 @@ src_compile() {
fi
}
+src_test() {
+ emake -Onone test
+}
+
src_install() {
exeinto /usr/bin
newexe bridge ${PN}