summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Grigo <agrigo2001@yahoo.com.au>2020-11-27 14:13:08 +1100
committerJoonas Niilola <juippis@gentoo.org>2020-12-03 09:32:12 +0200
commit406cafd8aab1d7d2a166513504800a57396d9bcd (patch)
tree92a4c6277ea80270e28cc1e99881c6d622d71326 /media-gfx/blender/files
parentmedia-gfx/blender: Use subslot binder for media-libs/osl (diff)
downloadgentoo-406cafd8aab1d7d2a166513504800a57396d9bcd.tar.gz
gentoo-406cafd8aab1d7d2a166513504800a57396d9bcd.tar.bz2
gentoo-406cafd8aab1d7d2a166513504800a57396d9bcd.zip
media-gfx/blender: Set Build Type for Blender
Blender requires that the build type is set to None, Debug, Release, RelWithDebInfo or MinSizeRel. This requires it to be overridden. If this is not done, then it is set to Gentoo by cmake.eclass, and the scripts in CMakeLists fail to set one of DEBUG or NDEBUG. In blender 2.91, this results in not defining GPU_vertex_buffer._data_end, but also attempting to execute an assert which requires it to be defined. Setting CMAKE_BUILD_TYPE to Release resolves the issue by setting NDEBUG to prevent compilation of the assert, and unsetting DEBUG so that the _data_end is not compiled. This means that the patch to prevent the compilation of the assert is no longer required. Older version of blender in the tree also have the same requirement for the value of CMAKE_BUILD_TYPE, but so far compiled correctly even when it was set to Gentoo. Signed-off-by: Adrian Grigo <agrigo2001@yahoo.com.au> Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx/blender/files')
-rw-r--r--media-gfx/blender/files/blender-2.91.0-define-data-end.patch14
1 files changed, 0 insertions, 14 deletions
diff --git a/media-gfx/blender/files/blender-2.91.0-define-data-end.patch b/media-gfx/blender/files/blender-2.91.0-define-data-end.patch
deleted file mode 100644
index 99705adae25c..000000000000
--- a/media-gfx/blender/files/blender-2.91.0-define-data-end.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -Naur a/source/blender/gpu/GPU_vertex_buffer.h b/source/blender/gpu/GPU_vertex_buffer.h
---- a/source/blender/gpu/GPU_vertex_buffer.h 2020-11-26 16:36:36.226883721 +1100
-+++ b/source/blender/gpu/GPU_vertex_buffer.h 2020-11-26 16:38:08.691212985 +1100
-@@ -118,7 +118,10 @@
- {
- unsigned char *data = a->data;
- a->data += a->stride;
-+#ifdef DEBUG
-+ /* Assert only compiles if _data_end exists */
- BLI_assert(data < a->_data_end);
-+#endif
- return (void *)data;
- }
-