summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-06-06 23:46:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-06-07 08:09:51 +0200
commit30f7dfcd4f9710d6f01ec079cb9ed71424347e5b (patch)
tree309602e339148d30773745f7d7fa0cd8fd27b956 /media-gfx/exiv2/files
parentprofiles: Mask media-gfx/exiv2-0.26 for testing (diff)
downloadgentoo-30f7dfcd4f9710d6f01ec079cb9ed71424347e5b.tar.gz
gentoo-30f7dfcd4f9710d6f01ec079cb9ed71424347e5b.tar.bz2
gentoo-30f7dfcd4f9710d6f01ec079cb9ed71424347e5b.zip
media-gfx/exiv2: 0.26 version bump
Gentoo-bug: 621028 Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'media-gfx/exiv2/files')
-rw-r--r--media-gfx/exiv2/files/exiv2-0.26-CVE-2017-9239.patch22
-rw-r--r--media-gfx/exiv2/files/exiv2-0.26-cmake1.patch22
-rw-r--r--media-gfx/exiv2/files/exiv2-0.26-cmake2.patch65
-rw-r--r--media-gfx/exiv2/files/exiv2-0.26-cmake3.patch53
-rw-r--r--media-gfx/exiv2/files/exiv2-0.26-cmake4.patch24
-rw-r--r--media-gfx/exiv2/files/exiv2-0.26-cmake5.patch33
-rw-r--r--media-gfx/exiv2/files/exiv2-0.26-cmake6.patch27
-rw-r--r--media-gfx/exiv2/files/exiv2-0.26-cmake7.patch38
-rw-r--r--media-gfx/exiv2/files/exiv2-0.26-fix-docs.patch70
-rw-r--r--media-gfx/exiv2/files/exiv2-0.26-tools-optional.patch27
10 files changed, 381 insertions, 0 deletions
diff --git a/media-gfx/exiv2/files/exiv2-0.26-CVE-2017-9239.patch b/media-gfx/exiv2/files/exiv2-0.26-CVE-2017-9239.patch
new file mode 100644
index 000000000000..2a3e20c9fac2
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.26-CVE-2017-9239.patch
@@ -0,0 +1,22 @@
+From 2f8681e120d277e418941c4361c83b5028f67fd8 Mon Sep 17 00:00:00 2001
+From: clanmills <robin@clanmills.com>
+Date: Sat, 27 May 2017 10:18:17 +0100
+Subject: [PATCH] #1296 Fix submitted.
+
+---
+ src/tiffcomposite.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/tiffcomposite.cpp b/src/tiffcomposite.cpp
+index c6b860d8..0c9b9c4a 100644
+--- a/src/tiffcomposite.cpp
++++ b/src/tiffcomposite.cpp
+@@ -1611,6 +1611,8 @@ namespace Exiv2 {
+ uint32_t TiffImageEntry::doWriteImage(IoWrapper& ioWrapper,
+ ByteOrder /*byteOrder*/) const
+ {
++ if ( !pValue() ) throw Error(21); // #1296
++
+ uint32_t len = pValue()->sizeDataArea();
+ if (len > 0) {
+ #ifdef DEBUG
diff --git a/media-gfx/exiv2/files/exiv2-0.26-cmake1.patch b/media-gfx/exiv2/files/exiv2-0.26-cmake1.patch
new file mode 100644
index 000000000000..672017e404b6
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.26-cmake1.patch
@@ -0,0 +1,22 @@
+From d5ae1a7502cc3a19f2ca45f5f17f1ee8fc6ad979 Mon Sep 17 00:00:00 2001
+From: Timo Gurr <timo.gurr@gmail.com>
+Date: Tue, 30 May 2017 20:25:28 +0200
+Subject: [PATCH] Use CMAKE_INSTALL_LOCALEDIR
+
+---
+ config/CMakeChecks.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/config/CMakeChecks.txt b/config/CMakeChecks.txt
+index 77922930..b3a888f2 100644
+--- a/config/CMakeChecks.txt
++++ b/config/CMakeChecks.txt
+@@ -98,7 +98,7 @@ IF( EXIV2_ENABLE_NLS )
+ #FIND_PACKAGE(Intl REQUIRED)
+ #INCLUDE_DIRECTORIES(${Intl_INCLUDE_DIRS})
+ IF( NOT LOCALEDIR )
+- SET( LOCALEDIR "${CMAKE_INSTALL_PREFIX}/share/locale" )
++ SET( LOCALEDIR "${CMAKE_INSTALL_LOCALEDIR}" )
+ IF( WIN32 )
+ STRING( REPLACE "/" "\\\\" LOCALEDIR ${LOCALEDIR} )
+ ENDIF( WIN32 )
diff --git a/media-gfx/exiv2/files/exiv2-0.26-cmake2.patch b/media-gfx/exiv2/files/exiv2-0.26-cmake2.patch
new file mode 100644
index 000000000000..76a194424866
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.26-cmake2.patch
@@ -0,0 +1,65 @@
+From 3af0d1a6b2c12b7f62a293d19bdf235db75d6b07 Mon Sep 17 00:00:00 2001
+From: Bernd Kuhls <bernd.kuhls@t-online.de>
+Date: Sat, 3 Jun 2017 17:18:24 +0200
+Subject: [PATCH] cmake: fix gettext support
+
+Building exiv2 with uclibc and gettext fails currently as detected
+by the buildroot autobuilders:
+http://autobuild.buildroot.net/results/def/defcdd3dd57b031c31bb16c0075f079a482bf52d/build-end.log
+---
+ config/CMakeChecks.txt | 12 ++++++++++--
+ src/CMakeLists.txt | 6 +++---
+ 2 files changed, 13 insertions(+), 5 deletions(-)
+
+diff --git a/config/CMakeChecks.txt b/config/CMakeChecks.txt
+index b3a888f2..f7621a92 100644
+--- a/config/CMakeChecks.txt
++++ b/config/CMakeChecks.txt
+@@ -95,8 +95,16 @@ ELSE( EXIV2_ENABLE_SHARED )
+ ENDIF( EXIV2_ENABLE_SHARED )
+
+ IF( EXIV2_ENABLE_NLS )
+- #FIND_PACKAGE(Intl REQUIRED)
+- #INCLUDE_DIRECTORIES(${Intl_INCLUDE_DIRS})
++ FIND_PACKAGE(Intl)
++ if(Intl_FOUND)
++ INCLUDE_DIRECTORIES(${Intl_INCLUDE_DIRS})
++ find_library(LIBINTL_LIBRARY NAMES intl libintl)
++ if(libintl_FOUND)
++ SET(LIBINTL_LIBRARIES ${LIBINTL_LIBRARY})
++ else(libintl_FOUND)
++ SET(LIBINTL_LIBRARIES)
++ endif()
++ endif()
+ IF( NOT LOCALEDIR )
+ SET( LOCALEDIR "${CMAKE_INSTALL_LOCALEDIR}" )
+ IF( WIN32 )
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index aecd6215..e2904c6f 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -316,13 +316,13 @@ msvc_runtime_configure(${EXIV2_ENABLE_SHARED} ${EXIV2_ENABLE_DYNAMIC_RUNTIME})
+ # ******************************************************************************
+ # exiv2 application
+ ADD_EXECUTABLE( exiv2 ${EXIV2_SRC} ${EXIV2_HDR} )
+-TARGET_LINK_LIBRARIES( exiv2 exiv2lib )
++TARGET_LINK_LIBRARIES( exiv2 exiv2lib ${LIBINTL_LIBRARIES} )
+ INSTALL( TARGETS exiv2 ${INSTALL_TARGET_STANDARD_ARGS} )
+
+ # ******************************************************************************
+ # connection test application
+ ADD_EXECUTABLE( conntest ${CONNTEST} )
+-TARGET_LINK_LIBRARIES( conntest ${PRIVATE_VAR} exiv2lib ${CURL_LIBRARIES} ${SSH_LIBRARIES})
++TARGET_LINK_LIBRARIES( conntest ${PRIVATE_VAR} exiv2lib ${CURL_LIBRARIES} ${SSH_LIBRARIES} ${LIBINTL_LIBRARIES} )
+
+ # ******************************************************************************
+ # exifprint application
+@@ -332,7 +332,7 @@ TARGET_LINK_LIBRARIES( conntest ${PRIVATE_VAR} exiv2lib ${CURL_LIBRARIES} ${SSH
+ # ******************************************************************************
+ # remotetest application
+ ADD_EXECUTABLE( remotetest ${REMOTETEST} )
+-TARGET_LINK_LIBRARIES( remotetest exiv2lib )
++TARGET_LINK_LIBRARIES( remotetest exiv2lib ${LIBINTL_LIBRARIES} )
+
+ # ******************************************************************************
+ # Headers
diff --git a/media-gfx/exiv2/files/exiv2-0.26-cmake3.patch b/media-gfx/exiv2/files/exiv2-0.26-cmake3.patch
new file mode 100644
index 000000000000..7a78d1c8bd86
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.26-cmake3.patch
@@ -0,0 +1,53 @@
+From 8af901ce05aeeaa4f5033da99670091f857d5931 Mon Sep 17 00:00:00 2001
+From: Bernd Kuhls <bernd.kuhls@t-online.de>
+Date: Sat, 3 Jun 2017 18:25:05 +0200
+Subject: [PATCH] cmake: always depend on threads, not only in the xmp case
+
+---
+ CMakeLists.txt | 1 -
+ config/CMakeChecks.txt | 2 ++
+ src/CMakeLists.txt | 2 ++
+ 3 files changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7034bb67..64604c6f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -120,7 +120,6 @@ IF( EXIV2_ENABLE_XMP )
+ IF (NOT MINGW)
+ set(THREADS_PREFER_PTHREAD_FLAG ON)
+ ENDIF()
+- find_package(Threads REQUIRED)
+ ENDIF( EXIV2_ENABLE_XMP )
+
+ INCLUDE( config/CMakeChecks.txt )
+diff --git a/config/CMakeChecks.txt b/config/CMakeChecks.txt
+index f7621a92..0dfe96b7 100644
+--- a/config/CMakeChecks.txt
++++ b/config/CMakeChecks.txt
+@@ -51,6 +51,8 @@ INCLUDE_DIRECTORIES( ${CMAKE_INCLUDE_PATH} ${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_C
+ LINK_DIRECTORIES( ${CMAKE_LIBRARY_PATH} )
+ SET( CMAKE_REQUIRED_INCLUDES ${CMAKE_INCLUDE_PATH} )
+
++find_package(Threads REQUIRED)
++
+ IF( EXIV2_ENABLE_PNG )
+ FIND_PACKAGE( ZLIB REQUIRED )
+ INCLUDE_DIRECTORIES( ${ZLIB_INCLUDE_DIR} )
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index e2904c6f..dcfb37e1 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -268,10 +268,12 @@ else()
+ TARGET_LINK_LIBRARIES( exiv2lib ${PRIVATE_VAR} dl ${EXPAT_LIBRARIES} )
+ TARGET_LINK_LIBRARIES( exiv2lib ${PRIVATE_VAR} dl ${CURL_LIBRARIES} )
+ TARGET_LINK_LIBRARIES( exiv2lib ${PRIVATE_VAR} dl ${SSH_LIBRARIES} )
++ TARGET_LINK_LIBRARIES( exiv2lib ${PRIVATE_VAR} dl ${CMAKE_THREAD_LIBS_INIT} )
+ else()
+ TARGET_LINK_LIBRARIES( exiv2lib ${PRIVATE_VAR} ${EXPAT_LIBRARIES} )
+ TARGET_LINK_LIBRARIES( exiv2lib ${PRIVATE_VAR} ${CURL_LIBRARIES} )
+ TARGET_LINK_LIBRARIES( exiv2lib ${PRIVATE_VAR} ${SSH_LIBRARIES} )
++ TARGET_LINK_LIBRARIES( exiv2lib ${PRIVATE_VAR} ${CMAKE_THREAD_LIBS_INIT} )
+ endif()
+ endif()
+
diff --git a/media-gfx/exiv2/files/exiv2-0.26-cmake4.patch b/media-gfx/exiv2/files/exiv2-0.26-cmake4.patch
new file mode 100644
index 000000000000..3824a5740005
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.26-cmake4.patch
@@ -0,0 +1,24 @@
+From 23ac3eeced6a4de0d34ae162ac7784ab9b7e4310 Mon Sep 17 00:00:00 2001
+From: clanmills <robin@clanmills.com>
+Date: Sat, 3 Jun 2017 20:58:08 +0100
+Subject: [PATCH] #7 Fix for libintl
+
+---
+ config/CMakeChecks.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/config/CMakeChecks.txt b/config/CMakeChecks.txt
+index 0dfe96b7..8c88aa27 100644
+--- a/config/CMakeChecks.txt
++++ b/config/CMakeChecks.txt
+@@ -103,8 +103,8 @@ IF( EXIV2_ENABLE_NLS )
+ find_library(LIBINTL_LIBRARY NAMES intl libintl)
+ if(libintl_FOUND)
+ SET(LIBINTL_LIBRARIES ${LIBINTL_LIBRARY})
+- else(libintl_FOUND)
+- SET(LIBINTL_LIBRARIES)
++ else()
++ SET(LIBINTL_LIBRARIES -lintl)
+ endif()
+ endif()
+ IF( NOT LOCALEDIR )
diff --git a/media-gfx/exiv2/files/exiv2-0.26-cmake5.patch b/media-gfx/exiv2/files/exiv2-0.26-cmake5.patch
new file mode 100644
index 000000000000..0df4a19689fb
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.26-cmake5.patch
@@ -0,0 +1,33 @@
+From 4e86c1d61c4b8ab2cbbb31db0031b8e1d1872231 Mon Sep 17 00:00:00 2001
+From: clanmills <robin@clanmills.com>
+Date: Sun, 4 Jun 2017 07:41:03 +0100
+Subject: [PATCH] Fix https://github.com/Exiv2/exiv2/pull/6 for
+ Linux/Cygwin/MacOSX
+
+---
+ config/CMakeChecks.txt | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/config/CMakeChecks.txt b/config/CMakeChecks.txt
+index 8c88aa27..e6100c0f 100644
+--- a/config/CMakeChecks.txt
++++ b/config/CMakeChecks.txt
+@@ -98,13 +98,16 @@ ENDIF( EXIV2_ENABLE_SHARED )
+
+ IF( EXIV2_ENABLE_NLS )
+ FIND_PACKAGE(Intl)
+- if(Intl_FOUND)
++ if(Intl_FOUND AND NOT MSVC)
+ INCLUDE_DIRECTORIES(${Intl_INCLUDE_DIRS})
+ find_library(LIBINTL_LIBRARY NAMES intl libintl)
+ if(libintl_FOUND)
+ SET(LIBINTL_LIBRARIES ${LIBINTL_LIBRARY})
+ else()
+- SET(LIBINTL_LIBRARIES -lintl)
++ SET(LIBINTL_LIBRARIES)
++ if ( APPLE OR CYGWIN )
++ SET(LIBINTL_LIBRARIES -lintl)
++ endif()
+ endif()
+ endif()
+ IF( NOT LOCALEDIR )
diff --git a/media-gfx/exiv2/files/exiv2-0.26-cmake6.patch b/media-gfx/exiv2/files/exiv2-0.26-cmake6.patch
new file mode 100644
index 000000000000..105b5889fea6
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.26-cmake6.patch
@@ -0,0 +1,27 @@
+From 88cf58613ffde4c907011bea82f61daae6006c3c Mon Sep 17 00:00:00 2001
+From: clanmills <robin@clanmills.com>
+Date: Sun, 4 Jun 2017 09:07:14 +0100
+Subject: [PATCH] #8 Adding INCLUDE_DIRECTORIES(${Intl_INCLUDE_DIRS})
+
+---
+ config/CMakeChecks.txt | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/config/CMakeChecks.txt b/config/CMakeChecks.txt
+index e6100c0f..b90d4fde 100644
+--- a/config/CMakeChecks.txt
++++ b/config/CMakeChecks.txt
+@@ -102,11 +102,12 @@ IF( EXIV2_ENABLE_NLS )
+ INCLUDE_DIRECTORIES(${Intl_INCLUDE_DIRS})
+ find_library(LIBINTL_LIBRARY NAMES intl libintl)
+ if(libintl_FOUND)
++ INCLUDE_DIRECTORIES(${Intl_INCLUDE_DIRS})
+ SET(LIBINTL_LIBRARIES ${LIBINTL_LIBRARY})
+ else()
+ SET(LIBINTL_LIBRARIES)
+ if ( APPLE OR CYGWIN )
+- SET(LIBINTL_LIBRARIES -lintl)
++ SET(LIBINTL_LIBRARIES -lintl)
+ endif()
+ endif()
+ endif()
diff --git a/media-gfx/exiv2/files/exiv2-0.26-cmake7.patch b/media-gfx/exiv2/files/exiv2-0.26-cmake7.patch
new file mode 100644
index 000000000000..0eff32a80d57
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.26-cmake7.patch
@@ -0,0 +1,38 @@
+From 15e0b9052eacd3438c8b39bf3fdda5da69ec068a Mon Sep 17 00:00:00 2001
+From: Bernd Kuhls <bernd.kuhls@t-online.de>
+Date: Sun, 4 Jun 2017 10:13:14 +0200
+Subject: [PATCH] cmake: simplify libintl check
+
+According to https://cmake.org/cmake/help/v3.4/module/FindIntl.html
+the FindIntl module already checks for libintl.so.
+---
+ config/CMakeChecks.txt | 15 ++++-----------
+ 1 file changed, 4 insertions(+), 11 deletions(-)
+
+diff --git a/config/CMakeChecks.txt b/config/CMakeChecks.txt
+index b90d4fde..0cd28ec7 100644
+--- a/config/CMakeChecks.txt
++++ b/config/CMakeChecks.txt
+@@ -98,18 +98,11 @@ ENDIF( EXIV2_ENABLE_SHARED )
+
+ IF( EXIV2_ENABLE_NLS )
+ FIND_PACKAGE(Intl)
+- if(Intl_FOUND AND NOT MSVC)
++ if(Intl_FOUND)
+ INCLUDE_DIRECTORIES(${Intl_INCLUDE_DIRS})
+- find_library(LIBINTL_LIBRARY NAMES intl libintl)
+- if(libintl_FOUND)
+- INCLUDE_DIRECTORIES(${Intl_INCLUDE_DIRS})
+- SET(LIBINTL_LIBRARIES ${LIBINTL_LIBRARY})
+- else()
+- SET(LIBINTL_LIBRARIES)
+- if ( APPLE OR CYGWIN )
+- SET(LIBINTL_LIBRARIES -lintl)
+- endif()
+- endif()
++ SET(LIBINTL_LIBRARIES ${Intl_LIBRARIES})
++ else()
++ SET(LIBINTL_LIBRARIES)
+ endif()
+ IF( NOT LOCALEDIR )
+ SET( LOCALEDIR "${CMAKE_INSTALL_LOCALEDIR}" )
diff --git a/media-gfx/exiv2/files/exiv2-0.26-fix-docs.patch b/media-gfx/exiv2/files/exiv2-0.26-fix-docs.patch
new file mode 100644
index 000000000000..a88867173df7
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.26-fix-docs.patch
@@ -0,0 +1,70 @@
+--- a/CMakeLists.txt 2015-07-19 16:04:35.363628707 +0200
++++ b/CMakeLists.txt 2015-07-19 16:28:31.051680136 +0200
+@@ -216,9 +216,7 @@
+ ADD_SUBDIRECTORY( xmpsdk )
+ ADD_SUBDIRECTORY( src )
+
+-IF( EXIV2_ENABLE_BUILD_SAMPLES )
+- ADD_SUBDIRECTORY( samples )
+-ENDIF( EXIV2_ENABLE_BUILD_SAMPLES )
++ADD_SUBDIRECTORY( samples )
+
+ IF( EXIV2_ENABLE_BUILD_PO )
+ ADD_SUBDIRECTORY( po )
+--- a/samples/CMakeLists.txt 2015-07-19 16:04:35.360628744 +0200
++++ b/samples/CMakeLists.txt 2015-07-19 16:30:46.415987850 +0200
+@@ -21,6 +21,10 @@
+ include_directories("${CMAKE_SOURCE_DIR}/include" "${CMAKE_SOURCE_DIR}/src")
+
+-SET( SAMPLES addmoddel.cpp
++SET( SAMPLES taglist.cpp )
++
++IF( EXIV2_ENABLE_BUILD_SAMPLES )
++ SET( SAMPLES ${SAMPLES}
++ addmoddel.cpp
+ convert-test.cpp
+ easyaccess-test.cpp
+ exifcomment.cpp
+@@ -38,7 +42,6 @@
+ mmap-test.cpp
+ prevtest.cpp
+ stringto-test.cpp
+- taglist.cpp
+ tiff-test.cpp
+ werror-test.cpp
+ write-test.cpp
+@@ -47,6 +50,7 @@
+ xmpparser-test.cpp
+ xmpsample.cpp
+ )
++ENDIF()
+
+ FOREACH(entry ${SAMPLES})
+ STRING( REPLACE ".cpp" "" target ${entry})
+@@ -63,6 +67,7 @@
+ SET( MC_SRC ${MC_SRC} ../src/getopt_win32.c )
+ ENDIF( MSVC )
+
++IF( EXIV2_ENABLE_BUILD_SAMPLES )
+ SET( MC_SRC ${MC_SRC} metacopy.cpp ../src/utils.cpp )
+ ADD_EXECUTABLE( metacopy ${MC_SRC} )
+ TARGET_LINK_LIBRARIES( metacopy exiv2lib )
+@@ -79,6 +84,7 @@
+ # ******************************************************************************
+ # Man page
+ INSTALL( FILES exiv2samples.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1 )
++ENDIF()
+
+ # That's all Folks!
+ ##
+--- a/doc/templates/Makefile 2015-07-19 16:50:50.589933604 +0200
++++ b/doc/templates/Makefile 2015-07-19 16:51:07.686719864 +0200
+@@ -143,7 +143,7 @@
+ xmp_mwg-rs \
+ xmp_mwg-kw
+
+-TAGLIST = ../../bin/taglist
++TAGLIST = ../../src/bin/taglist
+
+ # **********************************************************************
+ # ======================================================================
diff --git a/media-gfx/exiv2/files/exiv2-0.26-tools-optional.patch b/media-gfx/exiv2/files/exiv2-0.26-tools-optional.patch
new file mode 100644
index 000000000000..045e9dc58f03
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.26-tools-optional.patch
@@ -0,0 +1,27 @@
+--- a/CMakeLists.txt 2017-06-07 00:14:25.374608170 +0200
++++ b/CMakeLists.txt 2017-06-07 00:17:00.680483299 +0200
+@@ -60,6 +60,7 @@
+ OPTION( EXIV2_ENABLE_SSH "USE Libssh for SshIo" ON )
+ SET ( EXIV2_ENABLE_DYNAMIC_RUNTIME OFF )
+ ENDIF()
++OPTION( EXIV2_ENABLE_TOOLS "Build exiv2 executable" ON )
+
+ # set include path for FindXXX.cmake files
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/config/")
+--- a/src/CMakeLists.txt 2017-06-07 00:14:25.368608098 +0200
++++ b/src/CMakeLists.txt 2017-06-07 00:16:06.710831682 +0200
+@@ -317,9 +317,11 @@
+
+ # ******************************************************************************
+ # exiv2 application
+-ADD_EXECUTABLE( exiv2 ${EXIV2_SRC} ${EXIV2_HDR} )
+-TARGET_LINK_LIBRARIES( exiv2 exiv2lib ${LIBINTL_LIBRARIES} )
+-INSTALL( TARGETS exiv2 ${INSTALL_TARGET_STANDARD_ARGS} )
++IF(EXIV2_ENABLE_TOOLS)
++ ADD_EXECUTABLE( exiv2 ${EXIV2_SRC} ${EXIV2_HDR} )
++ TARGET_LINK_LIBRARIES( exiv2 exiv2lib ${LIBINTL_LIBRARIES} )
++ INSTALL( TARGETS exiv2 ${INSTALL_TARGET_STANDARD_ARGS} )
++ENDIF( EXIV2_ENABLE_TOOLS )
+
+ # ******************************************************************************
+ # connection test application