summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/gqview/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/gqview/files')
-rw-r--r--media-gfx/gqview/files/gqview-2.1.5-glibc.patch39
-rw-r--r--media-gfx/gqview/files/gqview-2.1.5-windows.patch16
2 files changed, 55 insertions, 0 deletions
diff --git a/media-gfx/gqview/files/gqview-2.1.5-glibc.patch b/media-gfx/gqview/files/gqview-2.1.5-glibc.patch
new file mode 100644
index 000000000000..957080737040
--- /dev/null
+++ b/media-gfx/gqview/files/gqview-2.1.5-glibc.patch
@@ -0,0 +1,39 @@
+diff --git a/Makefile.in b/Makefile.in
+index 38f6b25..4d7ad2c 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -123,6 +123,7 @@ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+ INSTOBJEXT = @INSTOBJEXT@
+ INTLLIBS = @INTLLIBS@
+ LCMS_LIBS = @LCMS_LIBS@
++LIBM = @LIBM@
+ LDFLAGS = @LDFLAGS@
+ LIBOBJS = @LIBOBJS@
+ LIBS = @LIBS@
+diff --git a/configure.in b/configure.in
+index 9335493..2299b4a 100644
+--- a/configure.in
++++ b/configure.in
+@@ -52,6 +52,9 @@ fi
+ AC_SUBST(LCMS_LIBS)
+ AM_CONDITIONAL(HAVE_LCMS, test "$have_lcms" = "yes")
+
++AC_CHECK_LIB(m, ceil, LIBM="-lm")
++AC_SUBST(LIBM)
++
+ ALL_LINGUAS="ar be bg ca cs da de eo es et eu fi fr hu id it ja ko nl no pl pt_BR ro ru sk sl sv th tr uk vi zh_CN.GB2312 zh_TW"
+ GETTEXT_PACKAGE=$PACKAGE
+ AC_SUBST(GETTEXT_PACKAGE)
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 7ce4702..5005877 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -166,7 +166,7 @@ gqview_SOURCES = \
+ view_file_icon.c \
+ view_file_icon.h
+
+-gqview_LDADD = $(GTK_LIBS) $(INTLLIBS) $(LCMS_LIBS)
++gqview_LDADD = $(GTK_LIBS) $(INTLLIBS) $(LCMS_LIBS) $(LIBM)
+
+ EXTRA_DIST = \
+ $(extra_SLIK)
diff --git a/media-gfx/gqview/files/gqview-2.1.5-windows.patch b/media-gfx/gqview/files/gqview-2.1.5-windows.patch
new file mode 100644
index 000000000000..207f3c02fabd
--- /dev/null
+++ b/media-gfx/gqview/files/gqview-2.1.5-windows.patch
@@ -0,0 +1,16 @@
+--- old/src/main.c 2006-11-01 17:28:37.000000000 +0000
++++ new/src/main.c 2008-06-21 23:31:06.000000000 +0000
+@@ -1054,11 +1054,8 @@
+ if (layout_valid(&lw))
+ {
+ main_window_maximized = window_maximized(lw->window);
+- if (!main_window_maximized)
+- {
+- layout_geometry_get(NULL, &main_window_x, &main_window_y,
+- &main_window_w, &main_window_h);
+- }
++ layout_geometry_get(NULL, &main_window_x, &main_window_y,
++ &main_window_w, &main_window_h);
+ }
+
+ layout_geometry_get_dividers(NULL, &window_hdivider_pos, &window_vdivider_pos);