summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-21 15:00:28 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-21 15:00:28 +0200
commit5a53c0332f0aff736a371c3716dc1987e8f6f195 (patch)
treeccb5cee71287b01ab5289ea8151149a689271ac7 /media-gfx/hugin
parentmedia-gfx/hugin: Drop 2018.0.0 (diff)
downloadgentoo-5a53c0332f0aff736a371c3716dc1987e8f6f195.tar.gz
gentoo-5a53c0332f0aff736a371c3716dc1987e8f6f195.tar.bz2
gentoo-5a53c0332f0aff736a371c3716dc1987e8f6f195.zip
media-gfx/hugin: Fix QA warnings, using xdg.eclass
Closes: https://bugs.gentoo.org/646730 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/hugin')
-rw-r--r--media-gfx/hugin/hugin-2019.0.0.ebuild2
-rw-r--r--media-gfx/hugin/hugin-9999.ebuild6
2 files changed, 6 insertions, 2 deletions
diff --git a/media-gfx/hugin/hugin-2019.0.0.ebuild b/media-gfx/hugin/hugin-2019.0.0.ebuild
index 89e66a9dc80a..65ee4e79249f 100644
--- a/media-gfx/hugin/hugin-2019.0.0.ebuild
+++ b/media-gfx/hugin/hugin-2019.0.0.ebuild
@@ -6,7 +6,7 @@ EAPI=6
WX_GTK_VER="3.0"
PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-inherit python-single-r1 wxwidgets cmake-utils eapi7-ver
+inherit python-single-r1 wxwidgets cmake-utils eapi7-ver xdg
DESCRIPTION="GUI for the creation & processing of panoramic images"
HOMEPAGE="http://hugin.sf.net"
diff --git a/media-gfx/hugin/hugin-9999.ebuild b/media-gfx/hugin/hugin-9999.ebuild
index 0783740a35d3..5ec24c68ade6 100644
--- a/media-gfx/hugin/hugin-9999.ebuild
+++ b/media-gfx/hugin/hugin-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
WX_GTK_VER="3.0"
PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-inherit mercurial python-single-r1 wxwidgets cmake-utils eapi7-ver
+inherit mercurial python-single-r1 wxwidgets cmake-utils eapi7-ver xdg
DESCRIPTION="GUI for the creation & processing of panoramic images"
HOMEPAGE="http://hugin.sf.net"
@@ -64,6 +64,10 @@ pkg_setup() {
setup-wxwidgets
}
+src_prepare() {
+ cmake-utils_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DBUILD_HSI=$(usex python)