summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-29 09:36:43 +0000
committerSam James <sam@gentoo.org>2024-01-29 09:37:34 +0000
commit892e038ce84ea5079ab87955e84bc76af2a4eb60 (patch)
treebf8376d08d593af8410b631808d339f87d66aaca /media-gfx/inkscape
parentdev-libs/mimalloc: append -latomic if required (diff)
downloadgentoo-892e038ce84ea5079ab87955e84bc76af2a4eb60.tar.gz
gentoo-892e038ce84ea5079ab87955e84bc76af2a4eb60.tar.bz2
gentoo-892e038ce84ea5079ab87955e84bc76af2a4eb60.zip
media-gfx/inkscape: fix build w/ libxml2-2.12
Closes: https://bugs.gentoo.org/923247 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/inkscape')
-rw-r--r--media-gfx/inkscape/files/inkscape-1.3.2-libxml2-2.12.patch29
-rw-r--r--media-gfx/inkscape/inkscape-1.3.2.ebuild12
-rw-r--r--media-gfx/inkscape/inkscape-9999.ebuild10
3 files changed, 42 insertions, 9 deletions
diff --git a/media-gfx/inkscape/files/inkscape-1.3.2-libxml2-2.12.patch b/media-gfx/inkscape/files/inkscape-1.3.2-libxml2-2.12.patch
new file mode 100644
index 000000000000..7e981e36fc1e
--- /dev/null
+++ b/media-gfx/inkscape/files/inkscape-1.3.2-libxml2-2.12.patch
@@ -0,0 +1,29 @@
+https://bugs.gentoo.org/923247
+https://gitlab.com/inkscape/inkscape/-/merge_requests/6089
+
+From 694d8ae43d06efff21adebf377ce614d660b24cd Mon Sep 17 00:00:00 2001
+From: Christian Hesse <mail@eworm.de>
+Date: Fri, 17 Nov 2023 22:30:42 +0100
+Subject: [PATCH] include missing header file
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This fixes build error:
+```
+/build/inkscape/src/inkscape/src/object/uri.cpp: In constructor ‘Inkscape::URI::URI(const gchar*, const char*)’:
+/build/inkscape/src/inkscape/src/object/uri.cpp:86:9: error: ‘xmlFree’ was not declared in this scope; did you mean ‘xmlFreeURI’?
+ 86 | xmlFree(full);
+```
+--- a/src/object/uri.h
++++ b/src/object/uri.h
+@@ -13,6 +13,7 @@
+ #define INKSCAPE_URI_H
+
+ #include <libxml/uri.h>
++#include <libxml/xmlmemory.h>
+ #include <memory>
+ #include <string>
+
+--
+GitLab
diff --git a/media-gfx/inkscape/inkscape-1.3.2.ebuild b/media-gfx/inkscape/inkscape-1.3.2.ebuild
index ca758524da42..a59e5ee19170 100644
--- a/media-gfx/inkscape/inkscape-1.3.2.ebuild
+++ b/media-gfx/inkscape/inkscape-1.3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,6 +8,9 @@ PYTHON_REQ_USE="xml(+)"
MY_P="${P/_/}"
inherit cmake flag-o-matic xdg toolchain-funcs python-single-r1
+DESCRIPTION="SVG based generic vector-drawing program"
+HOMEPAGE="https://inkscape.org/ https://gitlab.com/inkscape/inkscape/"
+
if [[ ${PV} = 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/inkscape/inkscape.git"
@@ -16,8 +19,7 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
-DESCRIPTION="SVG based generic vector-drawing program"
-HOMEPAGE="https://inkscape.org/ https://gitlab.com/inkscape/inkscape/"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
@@ -104,7 +106,9 @@ DEPEND="${COMMON_DEPEND}
test? ( dev-cpp/gtest )
"
-S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.2-libxml2-2.12.patch
+)
pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
diff --git a/media-gfx/inkscape/inkscape-9999.ebuild b/media-gfx/inkscape/inkscape-9999.ebuild
index 0f162519d9ab..698236284069 100644
--- a/media-gfx/inkscape/inkscape-9999.ebuild
+++ b/media-gfx/inkscape/inkscape-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,6 +8,9 @@ PYTHON_REQ_USE="xml(+)"
MY_P="${P/_/}"
inherit cmake flag-o-matic xdg toolchain-funcs python-single-r1
+DESCRIPTION="SVG based generic vector-drawing program"
+HOMEPAGE="https://inkscape.org/ https://gitlab.com/inkscape/inkscape/"
+
if [[ ${PV} = 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/inkscape/inkscape.git"
@@ -16,8 +19,7 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
-DESCRIPTION="SVG based generic vector-drawing program"
-HOMEPAGE="https://inkscape.org/ https://gitlab.com/inkscape/inkscape/"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
@@ -104,8 +106,6 @@ DEPEND="${COMMON_DEPEND}
test? ( dev-cpp/gtest )
"
-S="${WORKDIR}/${MY_P}"
-
pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}