summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomasz Hołubowicz <mail@alternateved.com>2022-08-11 16:58:16 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-08-28 11:22:10 +0300
commit396a4fbd1b9bc0d6b0f75e2ef2e36bbaf5141c07 (patch)
treedb601235a1691d1855a81d870f6e151ce21ec06a /media-gfx/maim
parentapp-backup/rear: add pkg_postrm() for udev_reload to 2.7 (diff)
downloadgentoo-396a4fbd1b9bc0d6b0f75e2ef2e36bbaf5141c07.tar.gz
gentoo-396a4fbd1b9bc0d6b0f75e2ef2e36bbaf5141c07.tar.bz2
gentoo-396a4fbd1b9bc0d6b0f75e2ef2e36bbaf5141c07.zip
media-gfx/maim: add version 5.7.4
Signed-off-by: Tomasz Hołubowicz <mail@alternateved.com> Closes: https://github.com/gentoo/gentoo/pull/26823 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx/maim')
-rw-r--r--media-gfx/maim/Manifest1
-rw-r--r--media-gfx/maim/maim-5.7.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/media-gfx/maim/Manifest b/media-gfx/maim/Manifest
index 4a2cbc76c70a..7fbc55f9c0d9 100644
--- a/media-gfx/maim/Manifest
+++ b/media-gfx/maim/Manifest
@@ -1 +1,2 @@
DIST maim-5.6.3.tar.gz 40217 BLAKE2B 90f6854d8e54b92f8c6e8d5b597ea287e85e622ad689f1b72361aa919d0ce57bf4f28f289fd0da51b30c1195977b70982837d8b4b81ec5597361bc6ed5f1ad0a SHA512 8e19bd4e89db117bcb74a9b9e35f3232cdd0ef3836a536d170f803d7159fbc4be415d20695e5e61942ff7714d990d027149cee20a689f797d25d01610cc1c3be
+DIST maim-5.7.4.tar.gz 41663 BLAKE2B beb6cb327ae0cf022a90c095bf56b307870d3d7bd281f0e060d9cf7d49ba604cf4cbdfd9270b0e185295f0e3d2a151fbb8ba69398034145a08fc2721cc93740e SHA512 f91ba00e436514d2d0eecc664c02dd45c53750045b5bc4abbc2cfbf64159085e83736e820c54fa819b4d82b0905a3cfe76a5227db49dd54238f655fd4899cd6c
diff --git a/media-gfx/maim/maim-5.7.4.ebuild b/media-gfx/maim/maim-5.7.4.ebuild
new file mode 100644
index 000000000000..ffedcb2e1110
--- /dev/null
+++ b/media-gfx/maim/maim-5.7.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Commandline tool to take screenshots of the desktop"
+HOMEPAGE="https://github.com/naelstrof/maim"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/naelstrof/maim.git"
+else
+ SRC_URI="https://github.com/naelstrof/maim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="icu"
+
+DEPEND="
+ media-libs/libglvnd
+ media-libs/libjpeg-turbo
+ media-libs/libpng:0=
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ >=x11-misc/slop-7.5:=
+ icu? ( dev-libs/icu:= )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMAIM_UNICODE=$(usex icu)
+ )
+ cmake_src_configure
+}