summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/mcomix
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/mcomix')
-rw-r--r--media-gfx/mcomix/Manifest2
-rw-r--r--media-gfx/mcomix/mcomix-1.00-r1.ebuild48
-rw-r--r--media-gfx/mcomix/mcomix-1.01.ebuild49
-rw-r--r--media-gfx/mcomix/metadata.xml12
4 files changed, 111 insertions, 0 deletions
diff --git a/media-gfx/mcomix/Manifest b/media-gfx/mcomix/Manifest
new file mode 100644
index 000000000000..848fefe718bd
--- /dev/null
+++ b/media-gfx/mcomix/Manifest
@@ -0,0 +1,2 @@
+DIST mcomix-1.00.tar.bz2 527779 SHA256 d8453109a297153f67fdc898d822fa57057d575b71ed857e538da9a7426f0cde SHA512 9fc975afa92ad7130fe0d39058463cf26f8a9415257869e45e4cf83fae5e2bd8f4f264821046fcf425ee3729ec3dacfa59cd52342055a6246cf0b61b866f09b1 WHIRLPOOL 6aed2176904d5f12cd66e7f6f41fc23914d5a81cd514242a209994222b7ee1d18ceca4367e78f8a61bb6edbec559d0da94165f4db841c44840d6d768ba700f14
+DIST mcomix-1.01.tar.bz2 543293 SHA256 da333d0bce5157fc8e15d13de6d9ce46b1c35692aa510cb20d6b2230f7c2774c SHA512 d31ed5d851c761d9680643df5c5bac1af817c61b49455bfd887381e0d7651593f9fb70fdbdb7533ae7bb6f8a203f0cabcbfdcce8a9681aa1d9ceaa3a411c1e70 WHIRLPOOL eb57890b612341d9920894b757c2eed8d1b6e8d31c911f2d7aff33a76c7cc2d1c3f5ebf3bfe96945fc0fa3ad612c369e6d96517b200ead3679559be69924329a
diff --git a/media-gfx/mcomix/mcomix-1.00-r1.ebuild b/media-gfx/mcomix/mcomix-1.00-r1.ebuild
new file mode 100644
index 000000000000..b1ca4fa54d6d
--- /dev/null
+++ b/media-gfx/mcomix/mcomix-1.00-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 eutils fdo-mime
+
+DESCRIPTION="A fork of comix, a GTK image viewer for comic book archives"
+HOMEPAGE="http://mcomix.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=dev-python/pygtk-2.14[${PYTHON_USEDEP}]
+ virtual/jpeg
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf
+ !media-gfx/comix"
+
+DOCS=( ChangeLog README )
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ echo
+ elog "Additional packages are required to open most common comic files:"
+ elog
+ elog " cbr: app-arch/unrar"
+ elog " cbz: app-arch/unzip"
+ elog
+ elog "You can also add support for 7z or LHA archives by installing"
+ elog "app-arch/p7zip or app-arch/lha."
+ echo
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
diff --git a/media-gfx/mcomix/mcomix-1.01.ebuild b/media-gfx/mcomix/mcomix-1.01.ebuild
new file mode 100644
index 000000000000..1dfcd26042ea
--- /dev/null
+++ b/media-gfx/mcomix/mcomix-1.01.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 eutils fdo-mime
+
+DESCRIPTION="A fork of comix, a GTK image viewer for comic book archives"
+HOMEPAGE="http://mcomix.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=dev-python/pygtk-2.14[${PYTHON_USEDEP}]
+ virtual/jpeg
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf
+ !media-gfx/comix"
+
+DOCS=( ChangeLog README )
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ echo
+ elog "Additional packages are required to open the most common comic archives:"
+ elog
+ elog " cbr: app-arch/unrar"
+ elog " cbz: app-arch/unzip"
+ elog
+ elog "You can also add support for 7z or LHA archives by installing"
+ elog "app-arch/p7zip or app-arch/lha. Install app-text/mupdf for"
+ elog "pdf support."
+ echo
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
diff --git a/media-gfx/mcomix/metadata.xml b/media-gfx/mcomix/metadata.xml
new file mode 100644
index 000000000000..7cb3023cf69d
--- /dev/null
+++ b/media-gfx/mcomix/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <maintainer>
+ <email>rhill@gentoo.org</email>
+ <name>Ryan Hill</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">mcomix</remote-id>
+ </upstream>
+</pkgmetadata>