summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-30 08:23:03 +0100
committerSam James <sam@gentoo.org>2022-05-30 08:25:33 +0100
commit7fb1ad844228c4c67efef3039abc4d2862241de6 (patch)
treee5c127a6f6234ca8d77321cdb4fcfe05ee69bcf2 /media-gfx/pstoedit
parentdev-python/nuitka: Bump to 0.8.3 (diff)
downloadgentoo-7fb1ad844228c4c67efef3039abc4d2862241de6.tar.gz
gentoo-7fb1ad844228c4c67efef3039abc4d2862241de6.tar.bz2
gentoo-7fb1ad844228c4c67efef3039abc4d2862241de6.zip
media-gfx/pstoedit: fix build with GCC 12
Closes: https://bugs.gentoo.org/844040 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/pstoedit')
-rw-r--r--media-gfx/pstoedit/files/pstoedit-3.75-gcc12.patch13
-rw-r--r--media-gfx/pstoedit/pstoedit-3.75.ebuild7
2 files changed, 18 insertions, 2 deletions
diff --git a/media-gfx/pstoedit/files/pstoedit-3.75-gcc12.patch b/media-gfx/pstoedit/files/pstoedit-3.75-gcc12.patch
new file mode 100644
index 000000000000..fa42a7a831b6
--- /dev/null
+++ b/media-gfx/pstoedit/files/pstoedit-3.75-gcc12.patch
@@ -0,0 +1,13 @@
+https://src.fedoraproject.org/rpms/pstoedit/raw/rawhide/f/pstoedit-fix-gcc12.patch
+https://bugs.gentoo.org/844040
+--- a/src/drvpptx.cpp
++++ b/src/drvpptx.cpp
+@@ -65,6 +65,7 @@
+ #define ZIP_EXTERN extern
+
+ #include <zip.h>
++#include <memory>
+
+ #ifdef _MSC_VER
+ // MS VC++ Windows
+
diff --git a/media-gfx/pstoedit/pstoedit-3.75.ebuild b/media-gfx/pstoedit/pstoedit-3.75.ebuild
index 6469d052b2b6..e866acb3c778 100644
--- a/media-gfx/pstoedit/pstoedit-3.75.ebuild
+++ b/media-gfx/pstoedit/pstoedit-3.75.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -30,7 +30,10 @@ DEPEND="${RDEPEND}"
DOCS=( doc/readme.txt )
HTML_DOCS=( doc/{changelog,pstoedit}.htm )
-PATCHES=( "${FILESDIR}"/${P}-libdl.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-libdl.patch
+ "${FILESDIR}"/${P}-gcc12.patch
+)
src_prepare() {
default