summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-03-05 15:32:38 -0500
committerMatt Turner <mattst88@gentoo.org>2023-03-05 15:32:52 -0500
commit1cff7d2418b4111ad0108badd404bba85244d21f (patch)
tree5ec1c74a620ddd9a0db40542b3a30e3abe238bed /media-gfx/shotwell
parentmedia-libs/waffle: Version bump to 1.7.2 (diff)
downloadgentoo-1cff7d2418b4111ad0108badd404bba85244d21f.tar.gz
gentoo-1cff7d2418b4111ad0108badd404bba85244d21f.tar.bz2
gentoo-1cff7d2418b4111ad0108badd404bba85244d21f.zip
media-gfx/shotwell: Add patch to build with vala-0.56.4
Closes: https://bugs.gentoo.org/895912 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-gfx/shotwell')
-rw-r--r--media-gfx/shotwell/files/shotwell-gphoto2-Add-missing-cheader-attributes-of-delegate-s.patch57
-rw-r--r--media-gfx/shotwell/shotwell-0.30.17-r1.ebuild5
2 files changed, 61 insertions, 1 deletions
diff --git a/media-gfx/shotwell/files/shotwell-gphoto2-Add-missing-cheader-attributes-of-delegate-s.patch b/media-gfx/shotwell/files/shotwell-gphoto2-Add-missing-cheader-attributes-of-delegate-s.patch
new file mode 100644
index 000000000000..76e959266fc7
--- /dev/null
+++ b/media-gfx/shotwell/files/shotwell-gphoto2-Add-missing-cheader-attributes-of-delegate-s.patch
@@ -0,0 +1,57 @@
+From cd82759231e5ece2fa0dea40397c9051d15fd5c2 Mon Sep 17 00:00:00 2001
+From: Rico Tzschichholz <ricotz@ubuntu.com>
+Date: Sun, 5 Feb 2023 20:44:49 +0100
+Subject: [PATCH] gphoto2: Add missing cheader attributes of delegate symbols
+
+---
+ vapi/libgphoto2.vapi | 21 +++++++++++++++++++++
+ 1 file changed, 21 insertions(+)
+
+diff --git a/vapi/libgphoto2.vapi b/vapi/libgphoto2.vapi
+index e9387b29..67cb2098 100644
+--- a/vapi/libgphoto2.vapi
++++ b/vapi/libgphoto2.vapi
+@@ -340,19 +340,40 @@ namespace GPhoto {
+ public void set_message_func([CCode (delegate_target_pos=3.1)] ContextMessageFunc messageFunc);
+ }
+
++ [CCode (
++ cheader_filename="gphoto2/gphoto2-context.h"
++ )]
+ public delegate void ContextIdleFunc(Context context);
+
++ [CCode (
++ cheader_filename="gphoto2/gphoto2-context.h"
++ )]
+ public delegate void ContextErrorFunc(Context context, string text);
+
++ [CCode (
++ cheader_filename="gphoto2/gphoto2-context.h"
++ )]
+ public delegate void ContextStatusFunc(Context context, string text);
+
++ [CCode (
++ cheader_filename="gphoto2/gphoto2-context.h"
++ )]
+ public delegate void ContextMessageFunc(Context context, string text);
+
+ // TODO: Support for va_args in Vala, esp. for delegates?
++ [CCode (
++ cheader_filename="gphoto2/gphoto2-context.h"
++ )]
+ public delegate uint ContextProgressStartFunc(Context context, float target, string text);
+
++ [CCode (
++ cheader_filename="gphoto2/gphoto2-context.h"
++ )]
+ public delegate void ContextProgressUpdateFunc(Context context, uint id, float current);
+
++ [CCode (
++ cheader_filename="gphoto2/gphoto2-context.h"
++ )]
+ public delegate void ContextProgressStopFunc(Context context, uint id);
+
+ [CCode (
+--
+2.39.2
+
diff --git a/media-gfx/shotwell/shotwell-0.30.17-r1.ebuild b/media-gfx/shotwell/shotwell-0.30.17-r1.ebuild
index 3eb97823c813..332fa0c27c41 100644
--- a/media-gfx/shotwell/shotwell-0.30.17-r1.ebuild
+++ b/media-gfx/shotwell/shotwell-0.30.17-r1.ebuild
@@ -51,7 +51,10 @@ BDEPEND="
app-crypt/gcr:0[vala]
"
-PATCHES=( "${FILESDIR}"/0.30.16-optional-wayland.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-gphoto2-Add-missing-cheader-attributes-of-delegate-s.patch
+ "${FILESDIR}"/0.30.16-optional-wayland.patch
+)
src_prepare() {
default