summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2024-02-18 10:07:18 -0600
committerBen Kohler <bkohler@gentoo.org>2024-02-19 07:15:07 -0600
commit268de19d48358a01944a3d13882dac96e61c4c4e (patch)
tree60f9a7d7637140e18f07911ffcf92b37b4c18486 /media-gfx
parentdev-vcs/stgit: drop 2.4.3 (diff)
downloadgentoo-268de19d48358a01944a3d13882dac96e61c4c4e.tar.gz
gentoo-268de19d48358a01944a3d13882dac96e61c4c4e.tar.bz2
gentoo-268de19d48358a01944a3d13882dac96e61c4c4e.zip
media-gfx/rawtherapee: add 5.10
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/rawtherapee/Manifest1
-rw-r--r--media-gfx/rawtherapee/rawtherapee-5.10.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/media-gfx/rawtherapee/Manifest b/media-gfx/rawtherapee/Manifest
index f0e2ae008708..173500760c5d 100644
--- a/media-gfx/rawtherapee/Manifest
+++ b/media-gfx/rawtherapee/Manifest
@@ -1 +1,2 @@
+DIST rawtherapee-5.10.tar.xz 16943724 BLAKE2B 2d1250a03f2902ffcff666514f9785036c808e9883957f674bfdb9545b2feac8f2313ab819e0cb64f39196bd3db36e8084b52bda6194de9197215824e695809c SHA512 79d6d54f90fec6006d3dff53aca00ccd385c398ebede2f06a223905d69e1045c6ab772bd5aca4bde01d9086c3c03183be22c0df521166b1af63b60bd7d0e1cfc
DIST rawtherapee-5.9.tar.xz 16219076 BLAKE2B 32039d6927eb4a4efbb49f3ad2bd019bd9f73c92a5e7125b7c560aaf7b6a42a5f1a2f67b24a713e4b255867539eda2bf63ea4e988453ec9634c917a11432a7fb SHA512 0d848a36293eb5cac3212910eaf1d011315269c6bbe780c4c2e5f91719721e25a7d1678a7e4453fa4a9694618978b04828612dc03e1d50cb9c11ad4d238e7ca8
diff --git a/media-gfx/rawtherapee/rawtherapee-5.10.ebuild b/media-gfx/rawtherapee/rawtherapee-5.10.ebuild
new file mode 100644
index 000000000000..e4a69dd837de
--- /dev/null
+++ b/media-gfx/rawtherapee/rawtherapee-5.10.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=${P/_rc/-rc}
+inherit cmake flag-o-matic toolchain-funcs xdg-utils
+
+DESCRIPTION="A powerful cross-platform raw image processing program"
+HOMEPAGE="https://www.rawtherapee.com/"
+SRC_URI="https://rawtherapee.com/shared/source/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="openmp tcmalloc"
+
+RDEPEND="
+ dev-cpp/atkmm:0
+ dev-cpp/cairomm:0
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0
+ dev-cpp/pangomm:1.4
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/libsigc++:2
+ gnome-base/librsvg:2
+ media-gfx/exiv2:=
+ media-libs/lcms:2
+ media-libs/lensfun
+ media-libs/libcanberra[gtk3]
+ media-libs/libiptcdata
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:0=
+ media-libs/tiff:=
+ sci-libs/fftw:3.0=
+ sys-libs/zlib
+ x11-libs/gtk+:3
+ tcmalloc? ( dev-util/google-perftools )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ # upstream tested that "fast-math" give wrong results, so filter it
+ # https://bugs.gentoo.org/show_bug.cgi?id=606896#c2
+ filter-flags -ffast-math
+ # -Ofast enable "fast-math" both in gcc and clang
+ replace-flags -Ofast -O3
+ # In case we add an ebuild for klt we can (i)use that one,
+ # see http://cecas.clemson.edu/~stb/klt/
+ local mycmakeargs=(
+ -DOPTION_OMP=$(usex openmp)
+ -DDOCDIR=/usr/share/doc/${PF}
+ -DCREDITSDIR=/usr/share/${PN}
+ -DLICENCEDIR=/usr/share/${PN}
+ -DCACHE_NAME_SUFFIX=""
+ -DWITH_SYSTEM_KLT="off"
+ -DENABLE_TCMALLOC=$(usex tcmalloc)
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}